View Issue Details

IDProjectCategoryView StatusLast Update
0025620mantisbtuipublic2019-04-05 17:14
ReporterrogueresearchAssigned Toatrol 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version2.19.0 
Target VersionFixed in Version 
Summary0025620: In Safari (but not Firefox) adding an attachment results in the progress bar never progressing, despite upload completing
Description

With Safari on macOS, if you drag a file to the 'Upload Files' section of an issue, it shows the file upload widget, and there's an animating progress bar, but the progress bar never progresses. Turns out the file upload completes successfully, it's just that the widget doesn't indicate this. Does not occur in Firefox.

TagsNo tags attached.

Activities

rogueresearch

rogueresearch

2019-03-18 12:00

reporter  

ProgressBar.png (26,454 bytes)
ProgressBar.png (26,454 bytes)
atrol

atrol

2019-03-18 12:23

developer   ~0061688

rogueresearch,

I was not able to reproduce your problem with a fresh install of the latest stable MantisBT release (2.20.0 at the moment).
There are a lot of attachment upload related enhancements in 2.20.0, especially an upgrade of the JS library which handles the attachment area.

I recommend that you upgrade to the latest (download from [1]). If after doing so the problem persists, do not hesitate to reopen the issue and provide detailed step-by-step instructions to reproduce the issue; the following additional information may also be useful:

  • Exact version of PHP, Database, Web server, Browser and Operating System
  • Relevant customizations (e.g. changes in config_inc.php, etc)
  • Installed plugins or custom functions ?
  • Was the MantisBT source code modified in any way ?

[1] http://mantisbt.org/download.php

rogueresearch

rogueresearch

2019-03-18 12:40

reporter   ~0061689

On Friday, I finally updated from Mantis 1.2.x to 2.19.0. Of course you release 2.20 the next day. :)

I'll upgrade my test server to 2.20 and reopen if necessary... thanks!

Issue History

Date Modified Username Field Change
2019-03-18 12:00 rogueresearch New Issue
2019-03-18 12:00 rogueresearch File Added: ProgressBar.png
2019-03-18 12:23 atrol Assigned To => atrol
2019-03-18 12:23 atrol Status new => resolved
2019-03-18 12:23 atrol Resolution open => no change required
2019-03-18 12:23 atrol Note Added: 0061688
2019-03-18 12:24 atrol Resolution no change required => unable to reproduce
2019-03-18 12:40 rogueresearch Note Added: 0061689
2019-04-05 17:14 atrol Status resolved => closed