View Issue Details

IDProjectCategoryView StatusLast Update
0025932mantisbtbugtrackerpublic2020-05-02 10:49
ReporterOliver-B Assigned Todregad  
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionno change required 
Platformx86_64OSWindowsOS VersionServer 2016
Product Version2.21.1 
Summary0025932: Mantis - Application error
Description

mantisbt /my_view_page.php and view_all_bug_page.php show an error message only.

Additional Information

INTERNAL APPLICATION ERROR

Argument 1 passed to columns_remove_invalid() must be of the type array, null given, called in C:\xampp\htdocs\mantisbt\core\custom_function_api.php on line 315

Please use the "Back" button in your web browser to return to the previous page. There you can correct whatever problems were identified in this error or select another action. You can also click an option from the menu bar to go directly to a new section.
Detailed error information
Full path: C:\xampp\htdocs\mantisbt\core\error_api.php
Line number: 92
Stack trace

Filename Line Class Type Function Args

0 C:\xampp\htdocs\mantisbt\core\custom_function_api.php 315 - - columns_remove_invalid <NULL>NULL, <array> { [0] => 'id', [1] => 'project_id', [2] => 'reporter_id', [3] => 'handler_id', [4] => 'priority', [5] => 'severity', [6] => 'reproducibility', [7] => 'status', [8] => 'resolution', [9] => 'category_id', [10] => 'date_submitted', [11] => 'last_updated', [12] => 'os', [13] => 'os_build', [14] => 'platform', [15] => 'version', [16] => 'fixed_in_version', [17] => 'target_version', [18] => 'view_state', [19] => 'summary', [20] => 'due_date', [21] => 'description', [22] => 'steps_to_reproduce', [23] => 'additional_information', [24] => 'attachment_count', [25] => 'bugnotes_count', [26] => 'selection', [27] => 'edit', [28] => 'notes', [29] => 'tags', [30] => 'overdue', [31] => 'custom_Approved', [32] => 'custom_Client (initials)', [33] => 'custom_Client Department', [34] => 'custom_Effort [days]', [35] => 'custom_Effort [hours]', [36] => 'custom_Estimated time required [days]', [37] => 'custom_Estimated time required [hours]', [38] => 'custom_Requested date', [39] => 'custom_When', [40] => 'custom_Production Support', [41] => 'custom_Post NPI', [42] => 'custom_Test required', [43] => 'custom_Tested', [44] => 'custom_Version', [45] => 'custom_Reliability', [46] => 'custom_Custom Field' }
1 C:\xampp\htdocs\mantisbt\core\helper_api.php 471 - - custom_function_default_get_columns_to_view <integer>1, <NULL>NULL
2 C:\xampp\htdocs\mantisbt\core\helper_api.php 506 - - helper_call_custom_function <string>'get_columns_to_view', <array> { [0] => 1, [1] => NULL }
3 C:\xampp\htdocs\mantisbt\core\filter_api.php 3586 - - helper_get_columns_to_view <integer>1
4 C:\xampp\htdocs\mantisbt\core\classes\BugFilterQuery.class.php 1569 - - filter_get_visible_sort_properties_array <array> { ['_version'] => 'v9', ['_view_type'] => 'simple', ['category_id'] => <array> { [0] => '0' }, ['severity'] => <array> { [0] => 0 }, ['status'] => <array> { [0] => 0 }, ['highlight_changed'] => 6, ['reporter_id'] => <array> { [0] => 0 }, ['handler_id'] => <array> { [0] => 1 }, ['project_id'] => <array> { [0] => -3 }, ['resolution'] => <array> { [0] => 0 }, ['build'] => <array> { [0] => '0' }, ['version'] => <array> { [0] => '0' }, ['hide_status'] => <array> { [0] => 80 }, ['monitor_user_id'] => <array> { [0] => 0 }, ['sort'] => 'last_updated', ['dir'] => 'DESC', ['per_page'] => 50, ['match_type'] => 0, ['platform'] => <array> { [0] => '0' }, ['os'] => <array> { [0] => '0' }, ['os_build'] => <array> { [0] => '0' }, ['fixed_in_version'] => <array> { [0] => '0' }, ['target_version'] => <array> { [0] => '0' }, ['profile_id'] => <array> { [0] => 0 }, ['priority'] => <array> { [0] => 0 }, ['note_user_id'] => <array> { [0] => 0 }, ['sticky'] => true, ['filter_by_date'] => false, ['start_month'] => '07', ['end_month'] => '07', ['start_day'] => 1, ['end_day'] => '17', ['start_year'] => '2019', ['end_year'] => '2019', ['filter_by_last_updated_date'] => false, ['last_updated_start_month'] => '07', ['last_updated_end_month'] => '07', ['last_updated_start_day'] => 1, ['last_updated_end_day'] => '17', ['last_updated_start_year'] => '2019', ['last_updated_end_year'] => '2019', ['search'] => '', ['view_state'] => 0, ['tag_string'] => '', ['tag_select'] => 0, ['relationship_type'] => -1, ['relationship_bug'] => 0, ['custom_fields'] => <array> { [1] => <array> { [0] => '0' }, [2] => <array> { [0] => '0' }, [3] => <array> { [0] => '0' }, [4] => <array> { [0] => '0' }, [5] => <array> { [0] => '0' }, [6] => <array> { [0] => '0' }, [17] => <array> { [0] => '0' }, [8] => <array> { [0] => '0' }, [9] => <array> { [0] => '0' }, [10] => <array> { [0] => '0' }, [11] => <array> { [0] => '0' }, [12] => <array> { [0] => '0' }, [13] => <array> { [0] => '0' }, [14] => <array> { [0] => '0' }, [15] => <array> { [0] => '0' }, [16] => <array> { [0] => '0' } } }
5 C:\xampp\htdocs\mantisbt\core\classes\BugFilterQuery.class.php 311 BugFilterQuery -> build_order_by -
6 C:\xampp\htdocs\mantisbt\core\classes\BugFilterQuery.class.php 206 BugFilterQuery -> string_query_list -
7 C:\xampp\htdocs\mantisbt\core\classes\BugFilterQuery.class.php 180 BugFilterQuery -> set_query_type <integer>0
8 C:\xampp\htdocs\mantisbt\core\filter_api.php 1345 BugFilterQuery -> __construct <array> { ['_version'] => 'v9', ['_view_type'] => 'simple', ['category_id'] => <array> { [0] => '0' }, ['severity'] => <array> { [0] => 0 }, ['status'] => <array> { [0] => 0 }, ['highlight_changed'] => 6, ['reporter_id'] => <array> { [0] => 0 }, ['handler_id'] => <array> { [0] => 1 }, ['project_id'] => <array> { [0] => -3 }, ['resolution'] => <array> { [0] => 0 }, ['build'] => <array> { [0] => '0' }, ['version'] => <array> { [0] => '0' }, ['hide_status'] => <array> { [0] => 80 }, ['monitor_user_id'] => <array> { [0] => 0 }, ['sort'] => 'last_updated', ['dir'] => 'DESC', ['per_page'] => 50, ['match_type'] => 0, ['platform'] => <array> { [0] => '0' }, ['os'] => <array> { [0] => '0' }, ['os_build'] => <array> { [0] => '0' }, ['fixed_in_version'] => <array> { [0] => '0' }, ['target_version'] => <array> { [0] => '0' }, ['profile_id'] => <array> { [0] => 0 }, ['priority'] => <array> { [0] => 0 }, ['note_user_id'] => <array> { [0] => 0 }, ['sticky'] => true, ['filter_by_date'] => false, ['start_month'] => '07', ['end_month'] => '07', ['start_day'] => 1, ['end_day'] => '17', ['start_year'] => '2019', ['end_year'] => '2019', ['filter_by_last_updated_date'] => false, ['last_updated_start_month'] => '07', ['last_updated_end_month'] => '07', ['last_updated_start_day'] => 1, ['last_updated_end_day'] => '17', ['last_updated_start_year'] => '2019', ['last_updated_end_year'] => '2019', ['search'] => '', ['view_state'] => 0, ['tag_string'] => '', ['tag_select'] => 0, ['relationship_type'] => -1, ['relationship_bug'] => 0, ['custom_fields'] => <array> { [1] => <array> { [0] => '0' }, [2] => <array> { [0] => '0' }, [3] => <array> { [0] => '0' }, [4] => <array> { [0] => '0' }, [5] => <array> { [0] => '0' }, [6] => <array> { [0] => '0' }, [17] => <array> { [0] => '0' }, [8] => <array> { [0] => '0' }, [9] => <array> { [0] => '0' }, [10] => <array> { [0] => '0' }, [11] => <array> { [0] => '0' }, [12] => <array> { [0] => '0' }, [13] => <array> { [0] => '0' }, [14] => <array> { [0] => '0' }, [15] => <array> { [0] => '0' }, [16] => <array> { [0] => '0' } } }, <array> { ['query_type'] => 0, ['project_id'] => NULL, ['user_id'] => NULL, ['use_sticky'] => NULL }
9 C:\xampp\htdocs\mantisbt\my_view_inc.php 243 - - filter_get_bug_rows <integer>1, <integer>10, <NULL>NULL, <NULL>NULL, <array> { ['_version'] => 'v9', ['_view_type'] => 'simple', ['category_id'] => <array> { [0] => '0' }, ['severity'] => <array> { [0] => 0 }, ['status'] => <array> { [0] => 0 }, ['highlight_changed'] => 6, ['reporter_id'] => <array> { [0] => 0 }, ['handler_id'] => <array> { [0] => 1 }, ['project_id'] => <array> { [0] => -3 }, ['resolution'] => <array> { [0] => 0 }, ['build'] => <array> { [0] => '0' }, ['version'] => <array> { [0] => '0' }, ['hide_status'] => <array> { [0] => 80 }, ['monitor_user_id'] => <array> { [0] => 0 }, ['sort'] => 'last_updated', ['dir'] => 'DESC', ['per_page'] => 50, ['match_type'] => 0, ['platform'] => <array> { [0] => '0' }, ['os'] => <array> { [0] => '0' }, ['os_build'] => <array> { [0] => '0' }, ['fixed_in_version'] => <array> { [0] => '0' }, ['target_version'] => <array> { [0] => '0' }, ['profile_id'] => <array> { [0] => 0 }, ['priority'] => <array> { [0] => 0 }, ['note_user_id'] => <array> { [0] => 0 }, ['sticky'] => true, ['filter_by_date'] => false, ['start_month'] => '07', ['end_month'] => '07', ['start_day'] => 1, ['end_day'] => '17', ['start_year'] => '2019', ['end_year'] => '2019', ['filter_by_last_updated_date'] => false, ['last_updated_start_month'] => '07', ['last_updated_end_month'] => '07', ['last_updated_start_day'] => 1, ['last_updated_end_day'] => '17', ['last_updated_start_year'] => '2019', ['last_updated_end_year'] => '2019', ['search'] => '', ['view_state'] => 0, ['tag_string'] => '', ['tag_select'] => 0, ['relationship_type'] => -1, ['relationship_bug'] => 0, ['custom_fields'] => <array> { [1] => <array> { [0] => '0' }, [2] => <array> { [0] => '0' }, [3] => <array> { [0] => '0' }, [4] => <array> { [0] => '0' }, [5] => <array> { [0] => '0' }, [6] => <array> { [0] => '0' }, [17] => <array> { [0] => '0' }, [8] => <array> { [0] => '0' }, [9] => <array> { [0] => '0' }, [10] => <array> { [0] => '0' }, [11] => <array> { [0] => '0' }, [12] => <array> { [0] => '0' }, [13] => <array> { [0] => '0' }, [14] => <array> { [0] => '0' }, [15] => <array> { [0] => '0' }, [16] => <array> { [0] => '0' } } }
10 C:\xampp\htdocs\mantisbt\my_view_page.php 153 - - include <string>'C:\xampp\htdocs\mantisbt\my_view_inc.php'

TagsNo tags attached.

Activities

Oliver-B

Oliver-B

2019-07-17 06:54

reporter   ~0062391

I've alredy checked 0020872, 0023028, 0023081

tedritheni

tedritheni

2019-07-22 19:18

reporter   ~0062412

We also getting this issue

Oliver-B

Oliver-B

2019-07-23 10:10

reporter   ~0062418

it looks like a database corruption or something.

I've installed a fresh mantis on a SUSE Leap. Worked fine. After importing my DB the same error occurs.

cproensa

cproensa

2019-07-23 11:10

developer   ~0062419

Last edited: 2019-07-23 11:10

View 2 revisions

Does this error happen after an upgrade? which version from, and wich one to?

what are the values for the config option view_issues_page_columns, in you local config files, and any definition in the database for any of ALL_USERS or your specific user overrides?

Does the error dissapear after going to the column configuration (in "my account") and modifying and updating the "columns to view"

Oliver-B

Oliver-B

2019-07-23 11:15

reporter   ~0062420

I deleted the "columns" entrys in my config table and Mantis is working again.

dregad

dregad

2020-04-21 09:35

developer   ~0063880

Resolving the issue as "no change required" since you indicated in 0025932:0062420 that your system was working again.

dregad

dregad

2020-04-21 12:21

developer   ~0063883

Last edited: 2020-04-21 12:21

View 2 revisions

For the record, I just realized that the problem can be reproduced by setting

$g_view_issues_page_columns = null;

in config_inc.php (assuming the current user did not customize their columns), or setting it to empty via adm_config_report.php.

While this problem is unlikely to happen in a normal usage scenario since it is not possible to save an empty columns list in manage_columns_page.php (that triggers APPLICATION ERROR 2601, Field "view_issues" contains invalid field "".), we could improve the error handling by either providing a more meaningful error message, or fallback to some defaulted columns set.

Issue History

Date Modified Username Field Change
2019-07-17 06:51 Oliver-B New Issue
2019-07-17 06:54 Oliver-B Note Added: 0062391
2019-07-22 19:18 tedritheni Note Added: 0062412
2019-07-23 10:10 Oliver-B Note Added: 0062418
2019-07-23 11:10 cproensa Note Added: 0062419
2019-07-23 11:10 cproensa Note Edited: 0062419 View Revisions
2019-07-23 11:15 Oliver-B Note Added: 0062420
2020-04-21 09:35 dregad Assigned To => dregad
2020-04-21 09:35 dregad Status new => resolved
2020-04-21 09:35 dregad Resolution open => no change required
2020-04-21 09:35 dregad Note Added: 0063880
2020-04-21 12:21 dregad Note Added: 0063883
2020-04-21 12:21 dregad Note Edited: 0063883 View Revisions
2020-05-02 10:49 atrol Status resolved => closed