View Issue Details

IDProjectCategoryView StatusLast Update
0025944mantisbtinstallationpublic2019-07-28 10:49
Reportersanddweller Assigned To 
PriorityhighSeverityblockReproducibilityalways
Status newResolutionopen 
PlatformAWS RDSOSCentos7 
Product Version2.21.1 
Summary0025944: Install cannot connect ot AWS/RDS Database(s) [mysql or postgresql]
Description

Cannot connect to an Amazon AWS/RDS database.

This seems to be an issue with conecting to a remote database.
Mantis install being atempted on Centos7 and an Amazon AWS EC2 instance.
Postgres and mysql are installed.
Creting eather database type via AWS RDS is trivial, and these databases can be accessed normally and as expected from the EC2 instance.

MantisBT is setp to run under nginx, however when runing the admin/install.php page, it fails to connect to the database(s)

Using a Postgres database,
Does administrative user have access to the database? ( Database connection failed )

Attempting a mysql database,
it appears to fail suggesting administraive user does not have sufficient permisison (dont have exact message now)

I have seen various similar issues of different forum, but no apparent working solution to this issue.
There seems to be some issue with making these remote connections.

Steps To Reproduce

attempt to install mantisbt on an AWS EC2 instance after defining an AWS RDS (postgresql|mysql) database.

Additional Information

screenshot attached... (added admin username, database name password, hostname to output to berify that these were correctly referenced)

#aws #centos7 #rds #mysql #postgresql #install #ec2 #connection

TagsNo tags attached.

Activities

sanddweller

sanddweller

2019-07-25 06:00

reporter  

mantisInstall.PNG (52,361 bytes)   
mantisInstall.PNG (52,361 bytes)   
sanddweller

sanddweller

2019-07-28 05:49

reporter   ~0062443

tested with local database, , , same error. :/
cant find any informaiton about fail. No connetion attempts logged in database logs (connectiion an statement logging is turned on)

sanddweller

sanddweller

2019-07-28 10:24

reporter   ~0062444

Last edited: 2019-07-28 10:49

View 3 revisions

looks liek an issue with adodb...

On a clean install, check shows:

Database
Checking use of the ADOdb extension
The ADOdb extension is not supported and must be disabled FAIL
Version of ADOdb available is at least 5.20.2
ADOdb version 5.20.14 was found. PASS

apaprently not the cause. fixed adodb

Database
Checking use of the ADOdb extension
The ADOdb extension is not supported and must be disabled PASS
Version of ADOdb available is at least 5.20.2
ADOdb version 5.20.14 was found.

but connection fail stil occurs

Issue History

Date Modified Username Field Change
2019-07-25 06:00 sanddweller New Issue
2019-07-25 06:00 sanddweller File Added: mantisInstall.PNG
2019-07-28 05:49 sanddweller Note Added: 0062443
2019-07-28 10:24 sanddweller Note Added: 0062444
2019-07-28 10:35 sanddweller Note Edited: 0062444 View Revisions
2019-07-28 10:49 sanddweller Note Edited: 0062444 View Revisions