View Issue Details

IDProjectCategoryView StatusLast Update
0025986mantisbtfilterspublic2019-08-25 12:38
Reporterrichard.rastall Assigned Todregad  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionwon't fix 
Product Version2.19.1 
Summary0025986: Mantis remembering filter and free word search entries
Description

How do I stop Mantis from remembering previously entered filters / searches.

E.G. If I go to "View Issues" and set the filters, add a search term and do a search and then close or go off of the page, the next time I go to "View Issues" the filters and search term is set with the previous settings.

How can I set this to automatically clear search terms and reset filters.

Thanks

 

TagsNo tags attached.

Activities

dregad

dregad

2019-08-09 09:59

developer   ~0062543

Last edited: 2019-08-09 10:45

View 2 revisions

This behavior is by design, and I don't think it is possible to do what you want. Maybe @cproensa can comment, he knows this stuff better than I do.

That being said, clearing the filter is just 1 click away with the [x Reset] button...

cproensa

cproensa

2019-08-09 10:20

developer   ~0062544

This behavior is by design, and I don't think it is not possible to do what you want

Right. It's by design.

By changing the source code, modifying this function in filter_api.php, to alwys return true:

function filter_user_can_use_persistent( $p_user_id = null ) {
    return !user_is_anonymous( $p_user_id );
}
dregad

dregad

2019-08-09 10:47

developer   ~0062546

Based on provided feedback, we won't be changing this in core, so I'm closing this issue as "won't fix".

Feel free to experiment with the given suggestion, at your own risk of course.

Issue History

Date Modified Username Field Change
2019-08-09 08:14 richard.rastall New Issue
2019-08-09 09:59 dregad Note Added: 0062543
2019-08-09 10:20 cproensa Note Added: 0062544
2019-08-09 10:45 dregad Note Edited: 0062543 View Revisions
2019-08-09 10:47 dregad Assigned To => dregad
2019-08-09 10:47 dregad Status new => resolved
2019-08-09 10:47 dregad Resolution open => won't fix
2019-08-09 10:47 dregad Note Added: 0062546
2019-08-25 12:38 vboctor Status resolved => closed