View Issue Details

IDProjectCategoryView StatusLast Update
0025992mantisbtrsspublic2019-09-09 17:27
Reporterjavadahmadzadeh Assigned Todregad  
PriorityhighSeveritycrashReproducibilityalways
Status closedResolutionno change required 
PlatformPHP 7.3 
Product Version2.21.1 
Summary0025992: RSS Builder is not working on PHP 7.2+
Description

On PHP 7.2+ when I try to access the RSS output, it just throw me a white page. There is no problem with PHP 5.6 family.

Steps To Reproduce

On PHP 7.2+ just go to RSS page.

Additional Information

I think there is something wrong the "Flaimo RSS Builder" library, why are we using such an outdated library!?

TagsNo tags attached.

Relationships

related to 0025213 closedatrol RSS feeds broken when using PHP >= 7.0 
related to 0024145 new Replace rssbuilder with a well maintained library via composer 

Activities

dregad

dregad

2019-08-14 04:20

developer   ~0062563

@javadahmadzadeh Replacing our outdated RSS library is a known work item, that has been logged a while ago (see 0024145). I actually started working on that a while ago, but it's not a priority for me and I never finished the work (https://github.com/dregad/mantisbt/tree/rssbuilder-replace). If you or anyone else wishes to pick up on that feature branch, be my guest.

As for the feeds being broken with PHP 7.2+, I'm not able to reproduce the error. It works fine on this instance, as well as on my DEV box (PHP 7.3). If you get a white page, maybe you'll find some error(s) in your PHP logs that would help identifying the problem.

atrol

atrol

2019-08-25 05:07

developer   ~0062646

javadahmadzadeh,

You did not provide any feedback; I am therefore resolving this issue as "no change required".

Feel free to reopen the issue at a later time and provide the requested information.

Issue History

Date Modified Username Field Change
2019-08-13 17:16 javadahmadzadeh New Issue
2019-08-14 02:11 atrol Relationship added related to 0025213
2019-08-14 02:11 atrol Relationship added related to 0024145
2019-08-14 04:20 dregad Status new => feedback
2019-08-14 04:20 dregad Note Added: 0062563
2019-08-25 05:07 atrol Assigned To => atrol
2019-08-25 05:07 atrol Status feedback => resolved
2019-08-25 05:07 atrol Resolution open => no change required
2019-08-25 05:07 atrol Note Added: 0062646
2019-08-25 05:07 atrol Assigned To atrol => dregad
2019-09-09 17:27 atrol Status resolved => closed