View Issue Details

IDProjectCategoryView StatusLast Update
0026103mantisbtbugtrackerpublic2019-09-25 19:08
Reporteramphetamine Assigned Todregad  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version2.22.0 
Summary0026103: reminder to user not show on note
Description

reporter post issue and then "send a reminder" to member, but can't see content on note or no activities show up. even reporter can't see the issue history is regard with this matter. but administrator can see whole thing (Normal)

TagsNo tags attached.

Activities

amphetamine

amphetamine

2019-09-03 07:47

reporter   ~0062705

for reporter viewpoint, is this situation okay or not? post the issue and then send a reminder, but can't see the note and history (no activities)

dregad

dregad

2019-09-03 08:19

developer   ~0062706

You probably have $g_default_reminder_view_status = VS_PRIVATE; and your reporter is not allowed to see private notes.

dregad

dregad

2019-09-03 08:22

developer   ~0062707

Nevermind what I just wrote, user should be able to see their own private notes.

I just checked, on my dev box, and as reporter I can see the reminder notes.

Maybe you set $g_store_reminders = OFF; ? In any case, this is caused by your config, because it works just fine for me.

amphetamine

amphetamine

2019-09-03 08:42

reporter   ~0062711

Could you test again on version 2.22? as reporter to create a new issue (public) and then choose one member to click "Send a Reminder", I've test two machines and get the same results (weird)

dregad

dregad

2019-09-03 11:42

developer   ~0062717

Could you test again on version 2.22?

I tested with latest master. Can't reproduce.

Please try it with a fresh installation of Mantis, and provide detailed step-by-step instructions to reproduce (including specific config if any).

dregad

dregad

2019-09-13 02:11

developer   ~0062787

amphetamine,

You did not provide any feedback; I am therefore resolving this issue. Feel free to reopen at a later time and provide the requested information.

Issue History

Date Modified Username Field Change
2019-08-31 01:37 amphetamine New Issue
2019-09-03 07:47 amphetamine Note Added: 0062705
2019-09-03 08:19 dregad Assigned To => dregad
2019-09-03 08:19 dregad Status new => feedback
2019-09-03 08:19 dregad Note Added: 0062706
2019-09-03 08:22 dregad Note Added: 0062707
2019-09-03 08:42 amphetamine Note Added: 0062711
2019-09-03 08:42 amphetamine Status feedback => assigned
2019-09-03 11:42 dregad Note Added: 0062717
2019-09-03 11:42 dregad Status assigned => feedback
2019-09-13 02:11 dregad Status feedback => resolved
2019-09-13 02:11 dregad Resolution open => unable to reproduce
2019-09-13 02:11 dregad Note Added: 0062787
2019-09-25 19:08 atrol Status resolved => closed