View Issue Details

IDProjectCategoryView StatusLast Update
0026156mantisbtcustomizationpublic2019-11-01 07:19
ReporterJeremy13560 Assigned Todregad  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionwon't fix 
Product Version2.22.0 
Summary0026156: custom_meta_inc include disappear
Description

The function which allow to include the custom_meta_inc.php has been removed since v2.9.

I have always used this functionnality but now in 2.20 I can't.

Can I make a simple pull request to allow this include ?

This pull request have been done by a team member of my team : https://www.mantisbt.org/bugs/view.php?id=17176

TagsNo tags attached.

Relationships

related to 0017176 closeddregad Add the possibility to define the x-ua-compatible meta 
related to 0023573 closedatrol Unneeded code for option meta_include_file 

Activities

dregad

dregad

2019-09-18 04:13

developer   ~0062859

@Jeremy13560 meta_include_file configuration was indeed obsoleted in 2.9.0, but as far as I can tell it has effectively been removed from MantisBT since 2.0.0-beta.1, as part of the migration to Modern UI (see commit MantisBT master 577c38e3 ).

I am not sure whether that was truly intentional or not - maybe @syncguru can comment - and if so, what was the reason for the decision.

If it was indeed intentional, then I guess it wouldn't make sense to submit a PR to reintroduce the config in core. In that case you would have to fix with this some other way.

Jeremy13560

Jeremy13560

2019-09-30 10:51

reporter   ~0062926

@syncguru , could help us about this subject ?

thanks

syncguru

syncguru

2019-09-30 20:01

developer   ~0062929

@Jeremy13560 custom_meta_inc was intentionally removed. The modern UI was significantly more complex than the classic which makes it very easy to break by introducing custom code at will. Plugins is the official way to make custom changes.

dregad

dregad

2019-10-01 04:13

developer   ~0062931

Based on @syncguru's feedback, I'm resolving this as won't fix.

Related Changesets

MantisBT: master 577c38e3

2014-10-23 02:15:00

Rafik Robeal

Details Diff
Fix breaks after merge. One temp fix in columns_api.php. Affected Issues
0026156
mod - account_prof_menu_page.php Diff File
mod - adm_config_report.php Diff File
mod - bugnote_view_inc.php Diff File
mod - core/columns_api.php Diff File
mod - core/layout_api.php Diff File
mod - core/tag_api.php Diff File
mod - login_page.php Diff File
mod - manage_custom_field_page.php Diff File
mod - manage_plugin_page.php Diff File
mod - manage_proj_page.php Diff File
mod - manage_user_page.php Diff File
mod - my_view_inc.php Diff File

Issue History

Date Modified Username Field Change
2019-09-18 03:19 Jeremy13560 New Issue
2019-09-18 03:46 dregad Relationship added related to 0017176
2019-09-18 03:52 dregad Relationship added related to 0023573
2019-09-18 04:13 dregad Status new => acknowledged
2019-09-18 04:13 dregad Note Added: 0062859
2019-09-18 04:16 dregad Changeset attached => MantisBT master 577c38e3
2019-09-30 10:51 Jeremy13560 Note Added: 0062926
2019-09-30 20:01 syncguru Note Added: 0062929
2019-10-01 04:13 dregad Assigned To => dregad
2019-10-01 04:13 dregad Status acknowledged => resolved
2019-10-01 04:13 dregad Resolution open => won't fix
2019-10-01 04:13 dregad Note Added: 0062931
2019-11-01 07:19 atrol Status resolved => closed