View Issue Details

IDProjectCategoryView StatusLast Update
0026181mantisbtauthenticationpublic2019-10-07 16:52
Reporterdavid_stephensen Assigned Toatrol  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionno change required 
PlatformWindows 
Summary0026181: v 1.2.15 crashes on login
Description

Resurrecting my version 1.2.15 installation so that I can upgrade. Haven't used it for a while.

Running under PHP 5.4 (the closest my hosting provider can do, as far as I can see)

I fixed the msqli thing and got to the login page.

When I logged in I got this crash message:

Fatal error: Uncaught Error: Call to undefined function user_pref_get_language() in /home2/quarrion/public_html/mantis/core/lang_api.php:104 Stack trace: #0 /home2/quarrion/public_html/mantis/core/error_api.php(78): lang_get_default() 0000001 /home2/quarrion/public_html/mantis/core/string_api.php(33): error_handler(8192, 'Methods with th...', '/home2/quarrion...', 31, Array) 0000002 /home2/quarrion/public_html/mantis/core/string_api.php(33): require_once() 0000003 /home2/quarrion/public_html/mantis/core/email_api.php(40): require_once('/home2/quarrion...') 0000004 /home2/quarrion/public_html/mantis/core/bug_api.php(33): require_once('/home2/quarrion...') 0000005 /home2/quarrion/public_html/mantis/core/project_api.php(36): require_once('/home2/quarrion...') #6 /home2/quarrion/public_html/mantis/core.php(219): require_once('/home2/quarrion...') 0000007 /home2/quarrion/public_html/mantis/index.php(26): require_once('/home2/quarrion...') #8 {main} thrown in /home2/quarrion/public_html/mantis/core/lang_api.php on line 104

I have not done modifications apart from a small config_local.php with a few settings

Steps To Reproduce

see above

Additional Information

Please advise if I should go to the forums instead

TagsNo tags attached.

Activities

david_stephensen

david_stephensen

2019-09-24 10:25

reporter  

config_inc.php (231 bytes)   
<?php
	$g_hostname = 'localhost';
	$g_db_type = 'mysqli';
	$g_database_name = 'quarrion_mantis';
	$g_db_username = 'quarrion_mantis';
	$g_db_password = 'pAQ3oVT0rDxA';
	include("config_local.php");
/* 1l1k3m1nt135 
*/
?>
config_inc.php (231 bytes)   
config_local.php (20,052 bytes)   
<?
    /* config_local.php - Local configuration file
       -------------------------------------------
       In this file you can place your custom configuration, instead of editing
       config_inc.php directly, although this is possible too.

       Please note: Everything you set here has precedence over and replaces settings defined in the config_inc.php. 
    */

	
	/****************************
	 * Signup and Lost Password *
	 ****************************/

	/**
	 * allow users to signup for their own accounts.
	 * Mail settings must be correctly configured in order for this to work
	 * @global int $g_allow_signup
	 */
	$g_allow_signup			= OFF;

	/**
	 * Max. attempts to login using a wrong password before lock the account.
	 * When locked, it's required to reset the password (lost password)
	 * Value resets to zero at each successfully login
	 * Set to OFF to disable this control
	 * @global int $g_max_failed_login_count
	 */
	$g_max_failed_login_count = 7;

	/***************************
	 * MantisBT Email Settings *
	 ***************************/

	/**
	 * Administrator Email address
	 * @global string $g_administrator_email
	 */
	$g_administrator_email	= 'mantis@qdt.com.au';

	/**
	 * Webmaster email
	 * @global string $g_webmaster_email
	 */
	$g_webmaster_email		= 'mantis@qdt.com.au';

	/**
	 * the sender email, part of 'From: ' header in emails
	 * @global string $g_from_email
	 */
 	$g_from_email			= 'noreply@qdt.com.au';

	/**
	 * the return address for bounced mail
	 * @global string $g_return_path_email
	 */
	$g_return_path_email	= 'mantis@qdt.com.au';

	/**
	 * the sender's name, part of 'From: ' header in emails
	 * @global string $g_from_name
	 */
	$g_from_name 	= 'QDT Issue Tracker';

	/***************************
	 * MantisBT Version String *
	 ***************************/

	/**
	 * Set to off by default to not expose version to users
	 * @global int $g_show_version
	 */
	$g_show_version = ON;


	/*****************************
	 * MantisBT Display Settings *
	 *****************************/

	/**
	 * browser window title
	 * @global string $g_window_title
	 */
	$g_window_title = 'QDT Issue Tracker';

	/**
	 * Logo
	 * @global string $g_logo_image
	 */
	$g_logo_image = 'images/qdt_issue_tracker_79.png';

	/**
	 * show extra menu bar with all available projects
	 * @global int $g_show_project_menu_bar
	 */
	$g_show_project_menu_bar = OFF;

	/**
	 * The default columns to be included in the View Issues Page.
	 * This can be overriden using Manage -> Manage Configuration -> Manage Columns
	 * Also each user can configure their own columns using My Account -> Manage Columns
	 * Some of the columns specified here can be removed automatically if they conflict with other configuration.
	 * Or if the current user doesn't have the necessary access level to view them.
	 * For example, sponsorship_total will be removed if sponsorships are disabled.
	 * To include custom field 'xyz', include the column name as 'custom_xyz'.
	 *
	 * Standard Column Names (i.e. names to choose from):
	 * id, project_id, reporter_id, handler_id, duplicate_id, priority, severity,
	 * reproducibility, status, resolution, category_id, date_submitted, last_updated,
	 * os, os_build, platform, version, fixed_in_version, target_version, view_state,
	 * summary, sponsorship_total, due_date, description, steps_to_reproduce,
	 * additional_info, attachment_count, bugnotes_count, selection, edit,
	 * overdue
	 *
	 * @global array $g_view_issues_page_columns
	 */
	$g_view_issues_page_columns = array ( 
		'selection', 
		'edit', 
		'id', 
		'bugnotes_count', 
		'attachment_count', 
		'category_id', 
		'status', 
		'reporter_id',
		'due_date',
		'overdue',
		'last_updated', 
		'date_submitted', 
		'summary' 
	);

	/**
	 * The default columns to be included in the Print Issues Page.
	 * This can be overriden using Manage -> Manage Configuration -> Manage Columns
	 * Also each user can configure their own columns using My Account -> Manage Columns
	 * @global array $g_print_issues_page_columns
	 */
	$g_print_issues_page_columns = array ( 
		'id', 
		'bugnotes_count',
		'attachment_count', 
		'category_id', 
		'status', 
		'reporter_id',
		'due_date',
		'overdue',
		'last_updated', 
		'date_submitted', 
		'summary' 
	);

	/**
	 * The default columns to be included in the CSV export.
	 * This can be overriden using Manage -> Manage Configuration -> Manage Columns
	 * Also each user can configure their own columns using My Account -> Manage Columns
	 * @global array $g_csv_columns
	 */
	$g_csv_columns = array ( 
		'id', 
		'bugnotes_count', 
		'attachment_count',
		'category_id', 
		'status', 
		'reporter_id',
		'due_date',
		'overdue',
		'last_updated', 
		'date_submitted', 
		'summary' 
	);

	/**
	 * The default columns to be included in the Excel export.
	 * This can be overriden using Manage -> Manage Configuration -> Manage Columns
	 * Also each user can configure their own columns using My Account -> Manage Columns
	 * @global array $g_excel_columns
	 */
	$g_excel_columns = array ( 
		'id', 
		'bugnotes_count',
		'attachment_count', 
		'category_id', 
		'status', 
		'reporter_id',
		'due_date',
		'overdue',
		'last_updated', 
		'date_submitted', 
		'summary' 
	);

	/*****************************
	 * MantisBT Summary Settings *
	 *****************************/


	/**
	 * how many reporters to show
	 * this is useful when there are hundreds of reporters
	 * @global int $g_reporter_summary_limit
	 */
	$g_reporter_summary_limit	= 30;

	/**
	 * Define the multipliers which are used to determine the effectiveness
	 * of reporters based on the severity of bugs. Higher multipliers will
	 * result in an increase in reporter effectiveness.
	 * @global array $g_severity_multipliers
	 * 
	 * For business use we regard all contributions as equally valuable.
	 *
	 */
	$g_severity_multipliers = array( MINOR   => 8,
	                                 MAJOR   => 8,
	                                 CRASH   => 8,
									 );

	/**
	 * Define the resolutions which are used to determine the effectiveness
	 * of reporters based on the resolution of bugs. Higher multipliers will
	 * result in a decrease in reporter effectiveness. The only resolutions
	 * that need to be defined here are those which match or exceed
	 * $g_bug_resolution_not_fixed_threshold.
	 * @global array $g_resolution_multipliers
	 *
	 * For business use we have reduced the 'not fixed' resolutions to 3
	 * and regard duplicate issues as less valuable.
	 *
	 */
	$g_resolution_multipliers = array( DUPLICATE          => 3,
	                                   DEFERRED           => 1,
	                                   REJECTED            => 1,
									   );

	/******************************
	 * MantisBT Reminder Settings *
	 ******************************/

	/**
	 * Automatically add recipients of reminders to monitor list, if they are not
	 * the handler or the reporter (since they automatically get notified, if required)
	 * If recipients of the reminders are below the monitor threshold, they will not be added.
	 * @global int $g_reminder_recipients_monitor_bug
	 *
	 * In business use you need to strike a balance with this and perhaps enable it for some projects.
	 * If there is a lot of traffic with an issue, people who have received one reminder and become Monitor
	 * may be annoyed by the flood of emails. For this reason we start with it being OFF.
	 */
	$g_reminder_recipients_monitor_bug = OFF;

	/**
	 * The minimum access level required to show up in the list of users who can receive a reminder.
	 * The access level is that of the project to which the issue belongs.
	 * @global int $g_reminder_receive_threshold
	 */
	$g_reminder_receive_threshold = ANYBODY;


	/*********************************
	 * MantisBT File Upload Settings *
	 *********************************/

	/**
	 * Maximum file size that can be uploaded
	 * Also check your PHP settings (default is usually 2MBs)
	 * @global int $g_max_file_size
	 */
	$g_max_file_size		= 2500000;




	/*******************
	 * Status Settings *
	 *******************/

	/**
	 * 'status_enum_workflow' defines the workflow, and reflects a simple
	 *  2-dimensional matrix. For each existing status, you define which
	 *  statuses you can go to from that status, e.g. from NEW_ you might list statuses
	 *  '10:new,20:feedback,30:acknowledged' but not higher ones.
	 * The following example can be transferred to config_inc.php
	 * $g_status_enum_workflow[NEW_]='20:feedback,30:acknowledged,40:confirmed,50:assigned,80:resolved';
	 * $g_status_enum_workflow[FEEDBACK] ='10:new,30:acknowledged,40:confirmed,50:assigned,80:resolved';
	 * $g_status_enum_workflow[ACKNOWLEDGED] ='20:feedback,40:confirmed,50:assigned,80:resolved';
	 * $g_status_enum_workflow[CONFIRMED] ='20:feedback,50:assigned,80:resolved';
	 * $g_status_enum_workflow[ASSIGNED] ='20:feedback,80:resolved,90:closed';
	 * $g_status_enum_workflow[RESOLVED] ='50:assigned,90:closed';
	 * $g_status_enum_workflow[CLOSED] ='50:assigned';
	 * @global array $g_status_enum_workflow
	 *
	 * For business use we omit ACKNOWLEDGED and CONFIRMED.
	 * FEEDBACK shows as Reopened
	 *
	 */
	$g_status_enum_workflow = array (
		NEW_ => '50:assigned,80:resolved,90:closed',
		FEEDBACK => '50:assigned,80:resolved,90:closed',
		ASSIGNED => '80:resolved,90:closed',
		RESOLVED => '20:feedback,90:closed',
		CLOSED => '20:feedback',
	);


	/**********************
	 * Field Visibility
	 **********************/

	/**
	 * An array of the fields to show on the bug report page.
	 *
	 * The following fields can not be included:
	 * id, project, date_submitted, last_updated, status,
	 * resolution, tags, fixed_in_version, projection, eta,
	 * reporter.
	 *
	
	 * The following fields must be included:
	 * category_id, summary, description.
	 *
	 * To override this setting for individual projects the settings must be included in the database through
	 * the generic configuration form.
	 *
	 * @global array $g_bug_report_page_fields
	 */
	$g_bug_report_page_fields = array(
		'category_id',
		'handler',
		'summary',
		'description',
		'attachments',
		'due_date',
	); 

	/**
	 * An array of the fields to show on the bug view page.
	 *
	 * To override this setting for individual projects the settings must be included in the database through
	 * the generic configuration form.
	 *
	 * @global array $g_bug_view_page_fields
	 */
	$g_bug_view_page_fields = array (
		'id',
		'project',
		'category_id',
		'date_submitted',
		'last_updated',
		'reporter',
		'handler',
		'status',
		'resolution',
		'summary',
		'description',
		'additional_info',
		'attachments',
		'due_date',
	); 

	/**
	 * An array of the fields to show on the bug print page.
	 * @global array $g_bug_print_page_fields
	 */
	$g_bug_print_page_fields = array (
		'id',
		'project',
		'category_id',
		'date_submitted',
		'last_updated',
		'reporter',
		'handler',
		'status',
		'resolution',
		'summary',
		'additional_info',
		'description',
		'attachments',
		'due_date',
	); 

	/**
	 * An array of the fields to show on the bug update page.
	 *
	 * To override this setting for individual projects the settings must be included in the database through
	 * the generic configuration form.
	 *
	 * @global array $g_bug_update_page_fields
	 */
	$g_bug_update_page_fields = array (
		'id',
		'project',
		'category_id',
		'date_submitted',
		'last_updated',
		'reporter',
		'handler',
		'status',
		'resolution', 
		'summary',
		'additional_info',
		'description',
		'attachments',
		'due_date',
	); 

	/**
	 * An array of the fields to show on the bug change status page.
	 *
	 * To overload this setting per project, then the settings must be included in the database through
	 * the generic configuration form.
	 *
	 * @global array $g_bug_change_status_page_fields
	 */
	$g_bug_change_status_page_fields = array (
		'id',
		'project',
		'category_id',
		'date_submitted',
		'last_updated',
		'reporter',
		'handler',
		'status',
		'resolution', 
		'summary',
		'description',
		'tags',
		'attachments',
		'due_date',
	);


	/**************************
	 * MantisBT Misc Settings *
	 **************************/

	/**
	 * access level needed to report a bug
	 * @global int $g_report_bug_threshold
	 */
	$g_report_bug_threshold = REPORTER;

	/**
	 * access level needed to update bugs (i.e., the update_bug_page)
	 * This controls whether the user sees the "Update Bug" button in bug_view*_page
	 * and the pencil icon in view_all_bug_page
	 * @global int $g_update_bug_threshold
	 */
	$g_update_bug_threshold = MANAGER;

	/**
	 * Access level needed to monitor bugs.
	 * Look in the constant_inc.php file if you want to set a different value.
	 * @global int $g_monitor_bug_threshold
	 */
	$g_monitor_bug_threshold = array (
		REPORTER,
		DEVELOPER,
		MANAGER,
		ADMINISTRATOR,
	);

	/**
	 * access level needed to view handler in bug reports and notification email
	 * @todo yarick123: now it is implemented for notification email only
	 * @global int $g_view_handler_threshold
	 */
	$g_view_handler_threshold = array (
		REPORTER,
		DEVELOPER,
		MANAGER,
		ADMINISTRATOR,
	);

	/**
	 * access level needed to view history in bug reports and notification email
	 * @todo yarick123: now it is implemented for notification email only
	 * @global int $g_view_history_threshold
	 */
	$g_view_history_threshold = array (
		REPORTER,
		DEVELOPER,
		MANAGER,
		ADMINISTRATOR,
	);

	/**
	 * access level needed to send a reminder from the bug view pages
	 * set to NOBODY to disable the feature
	 * @global int $g_bug_reminder_threshold
	 */
	$g_bug_reminder_threshold = array (
		REPORTER,
		DEVELOPER,
		MANAGER,
		ADMINISTRATOR,
	);

	/**
	 * Add bugnote threshold
	 * @global int $g_add_bugnote_threshold
	 */
	$g_add_bugnote_threshold = array (
		REPORTER,
		DEVELOPER,
		MANAGER,
		ADMINISTRATOR,
	);

	/**
	 * Update bugnote threshold (if the bugnote is not your own)
	 * @global int $g_update_bugnote_threshold
	 */
	$g_update_bugnote_threshold = ADMINISTRATOR;

	/**
	 * Threshold needed to add/delete/modify news
	 * @global int $g_manage_news_threshold
	 */
	$g_manage_news_threshold = NOBODY;

	/**
	 * Delete bug threshold
	 * @global int $g_delete_bug_threshold
	 */
	$g_delete_bug_threshold = ADMINISTRATOR;

	/**
	 * Delete bugnote threshold
	 * @global string $g_delete_bugnote_threshold
	 */
	$g_delete_bugnote_threshold = MANAGER;

	/**
	 * Move bug threshold
	 * @global int $g_move_bug_threshold
	 */
	$g_move_bug_threshold = MANAGER;

	/**
	 * Threshold needed to set the view status (public or private) while reporting a bug or a bug note.
	 * @global int $g_set_view_status_threshold
	 */
	$g_set_view_status_threshold = MANAGER;

	/**
	 * Threshold needed to update the view status (public or private) while updating a bug or a bug note.
	 * This threshold should be greater or equal to $g_set_view_status_threshold.
	 * @global int $g_change_view_status_threshold
	 */
	$g_change_view_status_threshold = MANAGER;

	/**
	 * Threshold needed to show the list of users montoring a bug on the bug view pages.
	 * @global int $g_show_monitor_list_threshold
	 */
	$g_show_monitor_list_threshold = array (
		REPORTER,
		DEVELOPER,
		MANAGER,
		ADMINISTRATOR,
	);

	/**
	 * threshold for viewing changelog
	 * @global int $g_view_changelog_threshold
	 *
	 * This is not relevant to business use
	 *
	 */
	$g_view_changelog_threshold = NOBODY;

	/**
	 * threshold for viewing roadmap
	 * @global int $g_roadmap_view_threshold
	 *
	 * This is not relevant to business use
	 *
	 */
	$g_roadmap_view_threshold = NOBODY;

	/**
	 * access level needed to reopen bugs
	 * @global int $g_reopen_bug_threshold
	 */
	$g_reopen_bug_threshold = REPORTER;

	/**
	 * this array sets the access thresholds needed to enter each status listed.
	 * if a status is not listed, it falls back to $g_update_bug_status_threshold
	 * example: $g_set_status_threshold = array( ACKNOWLEDGED => MANAGER, CONFIRMED => DEVELOPER, CLOSED => MANAGER );
	 * @global array $g_set_status_threshold
	 *
	 * For business use we omit ACKNOWLEDGED and CONFIRMED
	 *
	 */
	$g_set_status_threshold = array(
		FEEDBACK => REPORTER,
		ACKNOWLEDGED => NOBODY,
		CONFIRMED => NOBODY,
		ASSIGNED => DEVELOPER,
		RESOLVED => DEVELOPER,
		CLOSED => MANAGER,
	);

	/**
	 * reporter can reopen
	 * Allow reporters to reopen the bugs they reported, after they're marked resolved.
	 * @global int $g_allow_reporter_reopen
	 */
	$g_allow_reporter_reopen = ON;

	/************************************
	 * MantisBT Look and Feel Variables *
	 ************************************/
	/**

	 * status color codes, using the Tango color palette
	 * @global array $g_status_colors
	 */
	$g_status_colors		= array( 'new'			=> '#fcbdbd',
									 'reopened'	=> '#e3b7eb', 
									 'acknowledged'	=> '#ffcd85',
									 'confirmed'	=> '#fff494',
									 'assigned'		=> '#c2dfff',
									 'resolved'		=> '#d2f5b0',
									 'closed'		=> '#c9ccc4');


	/**
	 * The padding level when displaying bug ids
	 *  The bug id will be padded with 0's up to the size given
	 * @global int $g_display_bug_padding
	 */
	$g_display_bug_padding		= 5;

	/**
	 * The padding level when displaying bugnote ids
	 *  The bugnote id will be padded with 0's up to the size given
	 * @global int $g_display_bugnote_padding
	 */
	$g_display_bugnote_padding	= 5;

	/*************************
	 * MantisBT Enum Strings *
	 *************************/

	/**
	 * status from $g_status_index-1 to 79 are used for the onboard customization (if enabled)
	 * directly use MantisBT to edit them.
	 * @global string $g_access_levels_enum_string
	 */
	$g_access_levels_enum_string		= '25:reporter,55:problem solver,70:manager,90:administrator';

	/**
	 *
	 * @global string $g_severity_enum_string
	 */
	$g_severity_enum_string				= '50:no effect now,60:may stop production,70:stops production';

	/**
	 *
	 * @global string $g_status_enum_string
	 */
	$g_status_enum_string				= '10:new,20:reopened,50:assigned,80:resolved,90:closed';

	/**
	 * @@@ for documentation, the values in this list are also used to define variables in the language files
	 *  (e.g., $s_new_bug_title referenced in bug_change_status_page.php )
	 * Embedded spaces are converted to underscores (e.g., "working on" references $s_working_on_bug_title).
	 * they are also expected to be english names for the states
	 * @global string $g_resolution_enum_string
	 */
	$g_resolution_enum_string = '10:open,20:fixed,30:reopened,60:duplicate,80:deferred,90:rejected';

	/****************
	 * Custom Menus *
	 ****************/

	/**
	 * Add custom options to the main menu.  For example:
	 * $g_main_menu_custom_options = array(	array( "My Link",  MANAGER,       'my_link.php' ),
	 *					array( "My Link2", ADMINISTRATOR, 'my_link2.php' ) );
	 * Note that if the caption is found in custom_strings_inc.php, then it will be replaced by the
	 * translated string.  Options will only be added to the menu if the current logged in user has
	 * the appropriate access level.
	 * @global array $g_main_menu_custom_options
	 */
	$g_main_menu_custom_options = array(
		array( "QDT Website", REPORTER, 'http://qdt.com.au/'), 
	);

	/********************
	 * My View Settings *
	 ********************/

	/**
	 * Number of bugs shown in each box
	 * @global int $g_my_view_bug_count
	 */
	$g_my_view_bug_count = 10;

	/**
	 * Boxes to be shown and their order
	 * A box that is not to be shown can have its value set to 0
	 * @global array $g_my_view_boxes
	 */
	$g_my_view_boxes = array (
		'assigned'      => '1',
		'unassigned'    => '5',
		'reported'      => '2',
		'monitored'      => '8',
		'recent_mod'	=> '4',
		'resolved'	=> '7',
		'feedback'	=> '3',
		'verify'	=> '0',
		'my_comments'	=> '6'
	);

	/************
	 * Due Date *
	 ************/

	/**
	 * threshold to update due date submitted
	 * @global int $g_due_date_update_threshold
	 */
	$g_due_date_update_threshold = DEVELOPER;

	/**
	 * threshold to see due date
	 * @global int $g_due_date_view_threshold
	 */
	$g_due_date_view_threshold = REPORTER;



?>
config_local.php (20,052 bytes)   
custom_constants_inc.php (300 bytes)   
<?PHP

/*
* We have redefined the level 80 and 90 resolution constants as DEFERRED and REJECTED.
* They used to be SUSPENDED and WON'T FIX.  
* The corresponding texts displayed in user interface 
* are 'Deferred' and 'Rejected'
*/

define( 'DEFERRED', 80 );
define( 'REJECTED', 90 );

?>
custom_constants_inc.php (300 bytes)   
custom_strings_inc.php (2,233 bytes)   
<?PHP

/***
Changes to text in the user interface to convert Mantis Bug Tracker for use with business issues.

***/

/*
Severity levels 
We reduced them to 3 in the config files.
Nore that the severity level constants for 50, 60, 70 are still MINOR, MAJOR and CRASH 
throughout the config files, but appear as the strings below in the user interface.
We omit FEATURE, TRIVIAL, TEXT, TWEAK, BLOCK.
*/

$s_severity_enum_string = '50:no effect now,60:may stop production,70:stops production';

/*
Resolutions
We reduced them to 6. 
The first 3 are automatically set according to the status of the issue. 
The last 3 are different types of 'not fixed' resolution.
We have redefined the level 80 and 90 constants as DEFERRED and REJECTED.
They used to be SUSPENDED and WON'T FIX.
We omit UNABLE TO DUPLICATE, NOT FIXABLE and NOT A BUG. 
*/

$s_resolution_enum_string = '10:open,20:fixed,30:reopened,60:duplicate,80:deferred,90:rejected';

/*
Change 'Feedback' status to 'Reopened' status
Note that the status level 20 constant is still FEEDBACK throughout the config files, 
but appears as 'Reopened' in the user interface.
*/

$s_status_enum_string = '10:new,20:reopened,50:assigned,80:resolved,90:closed';
$s_email_notification_title_for_status_bug_feedback = 'The following issue has been REOPENED.';
$s_email_on_feedback = 'E-mail on Reopened';
/* 
$s_feedback_bug_title = 'Reopen Issue';
$s_feedback_bug_button = 'Reopen Issue'; 
*/
$s_reopened_bug_title = 'Reopen Issue';
$s_reopened_bug_button = 'Reopen Issue';
$s_reminder_explain = 'This note will be sent to the recipients listed stating that issue has been reopened.';
$s_my_view_title_feedback = 'Reopened, previously Assigned to me';

/*
Change 'Developer' to 'Problem Solver' and reduce number of displayed user levels.
Note that the role level 55 constant is still DEVELOPER throughout the config files,
but appears as 'Problem Solver' in the user interface.
*/

$s_by_developer = 'By Problem Solver';
$s_developer_by_resolution = 'Problem Solver By Resolution';
$s_developer_stats = 'Problem Solver Stats';
$s_access_levels_enum_string = '25:reporter,55:problem solver,70:manager,90:administrator';


?>




custom_strings_inc.php (2,233 bytes)   
error_log.zip (40,163 bytes)
atrol

atrol

2019-09-24 11:13

developer   ~0062897

Running under PHP 5.4

Sure? I assume you are running 7.x

dregad

dregad

2019-09-24 11:33

developer   ~0062898

Last edited: 2019-09-24 11:34

View 2 revisions

First of all, If your only purpose is to upgrade, note that you don't need to have the old 1.2.x instance up and running at all, just the database. Please follow instructions in the documentation http://mantisbt.org/docs/master/en-US/Admin_Guide/html-desktop/#admin.install.upgrade .

Second, config_local.php is not a standard MantisBT config file - we only use config_inc.php. So the question is, how was your system installed ? You are probably using some 3rd party distribution, which is likely to be the problem's root cause.

For the record, user_pref_get_language() is a standard core api function, defined in core/user_pref_api.php. Make sure this file exists.

If you really do need to have the legacy site running, you could try downloading our standard distribution package from https://sourceforge.net/projects/mantisbt/files/mantis-stable/1.2.20/ and install that.

As a side note, when you upload a log file, you should make sure to only include portions relevant to the issue at hand... uploading 50'000 lines of data worth 2.8 MB going back to 2013-2014 is not useful to debug the problem at hand.

david_stephensen

david_stephensen

2019-09-24 23:29

reporter   ~0062899

Atrol - well, I went into CPanel PHP and told it to use 5.4 (the only choice beside 7) and it seemed to have set that

Dregad - thanks for this useful information. I'll proceed with the upgrade.

I created config_local.php myself because I believed this was how to add your own settings in a way that was not overwritten when you upgraded. After an upgrade you could re-attach this file to override the settings that you wanted to change. Is there a better way these days? Since we use Mantis for business issues rather than software development it needs simplifying and slightly different terminology. I had learnt how to hide things such as as version number, have different workflows and different role and status names. After the upgrade I'll have to learn how to put all of this back in. I assume that it will revert to default and things will be called what they would have been without my extra settings.

Apologies about the big log file. I am quite ignorant about some things. I am not a PHP MySQL expert but am trying my best. Also I've been away from Mantis for a few years but want to get going with it again. For business quality management it REALLY simplifies things.

An I'd like to thank you and Atrol for your help and support over the years. You are open source heroes and I want to be like you when I grow up.

atrol

atrol

2019-09-25 02:55

developer   ~0062901

I went into CPanel PHP and told it to use 5.4 (the only choice beside 7) and it seemed to have set that

I asked as we had similar issues, e.g. 0020484

created config_local.php myself because I believed this was how to add your own settings in a way that was not overwritten when you upgraded.

Not needed, config_inc.php is not changed when upgrading

After the upgrade I'll have to learn how to put all of this back in.
I assume that it will revert to default ...

No, most of your changes will work after upgrade. Just add the contents of config_local.php to config/config_inc.php

david_stephensen,

This is not a bug or feature request for MantisBT (you are asking for help on how to upgrade the system). I am therefore resolving this issue as "no change required".

Please use the forums to get support on customizing and using MantisBT (refer to http://www.mantisbt.org/support.php for links and further details).

david_stephensen

david_stephensen

2019-09-25 03:55

reporter   ~0062902

thanks, Atrol

Issue History

Date Modified Username Field Change
2019-09-24 10:25 david_stephensen New Issue
2019-09-24 10:25 david_stephensen File Added: config_inc.php
2019-09-24 10:25 david_stephensen File Added: config_local.php
2019-09-24 10:25 david_stephensen File Added: custom_constants_inc.php
2019-09-24 10:25 david_stephensen File Added: custom_strings_inc.php
2019-09-24 10:25 david_stephensen File Added: error_log.zip
2019-09-24 11:13 atrol Status new => feedback
2019-09-24 11:13 atrol Note Added: 0062897
2019-09-24 11:33 dregad Note Added: 0062898
2019-09-24 11:34 dregad Note Edited: 0062898 View Revisions
2019-09-24 23:29 david_stephensen Note Added: 0062899
2019-09-24 23:29 david_stephensen Status feedback => new
2019-09-25 02:55 atrol Assigned To => atrol
2019-09-25 02:55 atrol Status new => resolved
2019-09-25 02:55 atrol Resolution open => no change required
2019-09-25 02:55 atrol Note Added: 0062901
2019-09-25 03:55 david_stephensen Note Added: 0062902
2019-10-07 16:52 atrol Status resolved => closed