View Issue Details

IDProjectCategoryView StatusLast Update
0026254mantisbtreportspublic2019-11-01 07:17
Reporterszabo.arpad Assigned Todregad  
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Product Version2.22.1 
Summary0026254: Graph not showing in the Summary Section
Description

Totally new installation to a localhost server, windows, managed by IIS.
Under the "Summary" tab the core "Synthesis" works fine but changing to other sections like "By Developer" or "By Reporter" there are no graphcs are showing, only empty area.

Steps To Reproduce
  1. Login
  2. Go to Manage
  3. Install Graph plugin
  4. Change to Summary
  5. Change to anything else except bundled Synthesis option
  6. No graphs showing
Additional Information

Uploaded screenshots about the issue:

  • my Mantis server info
  • Mantis graph section
  • Console log from Google Chrome browser
TagsNo tags attached.

Activities

szabo.arpad

szabo.arpad

2019-10-09 05:14

reporter  

mantis_config.PNG (81,900 bytes)   
mantis_config.PNG (81,900 bytes)   
mantis_consolelog.PNG (32,113 bytes)   
mantis_consolelog.PNG (32,113 bytes)   
mantisa_nograph.PNG (68,708 bytes)   
mantisa_nograph.PNG (68,708 bytes)   
szabo.arpad

szabo.arpad

2019-10-09 10:21

reporter   ~0062969

Resolution:

Under IIS on Windows changed my PHP to 7.3.7, added php_ftp extension, and increased max upload limit to 5 MB.
Not sure, but one of these helped on my issue.

*Recommended to use Bitnami mantis stack instead of manual install on IIS server .

dregad

dregad

2019-10-10 04:27

developer   ~0062971

I understand from your last post 0026254:0062969 that the problem is resolved.

It would be interesting to know, why the plugin API returned a syntax error when including the various javascripts required to generate the graphs.
If you can still reproduce the problem, try to open one of the plugin_file.php?file=... URLs, and view page source to see what is causing the error. There may be something in your PHP error log as well.

Issue History

Date Modified Username Field Change
2019-10-09 05:14 szabo.arpad New Issue
2019-10-09 05:14 szabo.arpad File Added: mantis_config.PNG
2019-10-09 05:14 szabo.arpad File Added: mantis_consolelog.PNG
2019-10-09 05:14 szabo.arpad File Added: mantisa_nograph.PNG
2019-10-09 10:21 szabo.arpad Note Added: 0062969
2019-10-10 04:27 dregad Assigned To => dregad
2019-10-10 04:27 dregad Status new => resolved
2019-10-10 04:27 dregad Resolution open => no change required
2019-10-10 04:27 dregad Note Added: 0062971
2019-11-01 07:17 atrol Status resolved => closed