View Issue Details

IDProjectCategoryView StatusLast Update
0026351mantisbtpreferencespublic2019-11-13 12:19
ReporterCamille Desmots Assigned Todregad  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.22.1 
Target Version2.22.2Fixed in Version2.22.2 
Summary0026351: Field "EXCEL columns" has space or tabulation
Description

When you go on the page https://www.mantisbt.org/bugs/account_manage_columns_page.php in the text field corresponding to the label "Excel columns" the data are displayed with tabs or spaces before and after the enumeration of the fields.

The function helper_get_columns_to_view() should clean the text before returning it.

Steps To Reproduce

Go to the page https://www.mantisbt.org/bugs/account_manage_columns_page.php with Firefox 60.9.0esr (32 bits) or Microsoft Edge.
On the latest text field named "Excel Columns" the text displayed not immediatly at the beginning. If you enter in the field you will see that there is tabulations.

TagsNo tags attached.

Relationships

related to 0025839 closeddregad Leading newlines disappear when editing data in textarea elements 

Activities

Camille Desmots

Camille Desmots

2019-11-13 10:09

reporter  

Capture 2019-11-013-15-31.PNG (108,564 bytes)   
Capture 2019-11-013-15-31.PNG (108,564 bytes)   
atrol

atrol

2019-11-13 10:40

developer   ~0063085

@dregad seems to be a regression caused by the changes to fix 0025839

dregad

dregad

2019-11-13 11:59

developer   ~0063088

I'll have a look.

Related Changesets

MantisBT: master d975045e

2019-06-05 12:40:27

dregad

Details Diff
Add newline after <textarea> tags

The HTML 5 specification states that "Newlines at the start of textarea
elements are ignored as an authoring convenience." [1]

To avoid altering user data (e.g. issue description, steps to reproduce,
etc.) having leading newline(s) when editing and saving, the markup of
all pages displaying user content in textarea tags has been modified to
add a newline after the opening tag.

Fixes 0025839

[1]: https://www.w3.org/TR/html52/syntax.html#the-in-body-insertion-mode
Affected Issues
0025839, 0026351
mod - account_prof_edit_page.php Diff File
mod - bug_report_page.php Diff File
mod - bug_update_page.php Diff File
mod - manage_columns_inc.php Diff File
mod - manage_custom_field_edit_page.php Diff File
mod - manage_proj_edit_page.php Diff File
mod - manage_proj_ver_edit_page.php Diff File
mod - news_edit_page.php Diff File
mod - proj_doc_edit_page.php Diff File
mod - tag_update_page.php Diff File

MantisBT: master-2.22 9b0dce28

2019-11-13 12:09:33

dregad

Details Diff
Remove unwanted whitespace in Excel columns textarea

Regression introduced by d975045e9a30d253a21662a9c14868ef63f5b5c7.

Fixes 0026351
Affected Issues
0025839, 0026351
mod - manage_columns_inc.php Diff File

Issue History

Date Modified Username Field Change
2019-11-13 10:09 Camille Desmots New Issue
2019-11-13 10:09 Camille Desmots File Added: Capture 2019-11-013-15-31.PNG
2019-11-13 10:39 atrol Relationship added related to 0025839
2019-11-13 10:40 atrol Note Added: 0063085
2019-11-13 10:40 atrol Status new => confirmed
2019-11-13 11:59 dregad Note Added: 0063088
2019-11-13 12:13 dregad Assigned To => dregad
2019-11-13 12:13 dregad Status confirmed => assigned
2019-11-13 12:13 dregad Target Version => 2.22.2
2019-11-13 12:13 dregad Changeset attached => MantisBT master-2.22 9b0dce28
2019-11-13 12:13 dregad Status assigned => resolved
2019-11-13 12:13 dregad Resolution open => fixed
2019-11-13 12:18 dregad Fixed in Version => 2.22.2
2019-11-13 12:19 dregad Changeset attached => MantisBT master d975045e