View Issue Details

IDProjectCategoryView StatusLast Update
0026371mantisbtotherpublic2019-12-02 17:12
Reporteramphetamine Assigned Todregad  
PriorityhighSeveritymajorReproducibilityhave not tried
Status closedResolutionno change required 
Product Version2.22.0 
Summary0026371: view status set to public, but still may post private note
Description

Allowed for any user with access level

  • Set view state when reporting a new issue or note > unticked all of them
TagsNo tags attached.

Activities

amphetamine

amphetamine

2019-11-21 22:50

reporter  

image.png (6,041 bytes)   
image.png (6,041 bytes)   
dregad

dregad

2019-11-22 08:17

developer   ~0063118

amphetamine,

The provided information is not sufficient to provide any help in resolving the issue. A complete and detailed description is required for the support team to get a clear understanding of the problem.

Please explain what you do, what are the results you expect to get and what you actually get.

Also provide detailed, step-by-step instructions to reproduce the issue; the additional information listed below may also be useful:

  • Exact version of MantisBT, PHP, Database, Web server, Browser and Operating System
  • Relevant customizations (e.g. changes in config_inc.php, etc)
  • Installed plugins or custom functions ?
  • Was the MantisBT source code modified in any way ?
amphetamine

amphetamine

2019-11-22 09:27

reporter   ~0063119

  1. unselect all "Set view state when reporting a new issue or note" (as attached)
    to make default report issue and note are public

  2. when someone add the note, then can make the note to private (see above)

image-2.png (5,461 bytes)   
image-2.png (5,461 bytes)   
dregad

dregad

2019-11-22 10:15

developer   ~0063121

Did you also set Change view state of existing issue or note ($g_change_view_status_threshold) and/or Change view state of own notes ($g_bugnote_user_change_view_state_threshold) accordingly ?

amphetamine

amphetamine

2019-11-22 10:50

reporter   ~0063123

none of them

dregad

dregad

2019-11-22 10:57

developer   ~0063124

Then do. $g_change_view_status_threshold = NOBODY; will do what you want.

This is not a bug or feature request for MantisBT (you are asking for help on how to configure the system). I am therefore resolving this issue as "no change required".

Please use the forums to get support on customizing and using MantisBT (refer to http://www.mantisbt.org/support.php for links and further details).

Issue History

Date Modified Username Field Change
2019-11-21 22:50 amphetamine New Issue
2019-11-21 22:50 amphetamine File Added: image.png
2019-11-22 08:17 dregad Assigned To => dregad
2019-11-22 08:17 dregad Status new => feedback
2019-11-22 08:17 dregad Note Added: 0063118
2019-11-22 09:27 amphetamine Note Added: 0063119
2019-11-22 09:27 amphetamine File Added: image-2.png
2019-11-22 09:27 amphetamine Status feedback => assigned
2019-11-22 10:15 dregad Status assigned => feedback
2019-11-22 10:15 dregad Note Added: 0063121
2019-11-22 10:50 amphetamine Note Added: 0063123
2019-11-22 10:50 amphetamine Status feedback => assigned
2019-11-22 10:57 dregad Status assigned => resolved
2019-11-22 10:57 dregad Resolution open => no change required
2019-11-22 10:57 dregad Note Added: 0063124
2019-12-02 17:12 atrol Status resolved => closed