View Issue Details

IDProjectCategoryView StatusLast Update
0026454mantisbtupgradepublic2019-12-23 01:50
Reportersystem Assigned Todregad  
PriorityhighSeverityminorReproducibilityhave not tried
Status closedResolutionno change required 
Product Version2.23.0 
Summary0026454: No change in DB names post upgrade
Description

Hi,

I have tried upgrading my mantisbt to 2.23.0 from 2.22.1 version and I have a doubt to get it confirm regarding this.

I have observed that there are structural changes in database in new version which should reflect in an upgraded installation. i.e In new version (2.23.0) all the database tables are ending with "_mantis" names however in the previous version (2.22.1) all the tables were ending with "_table"

When I see database structural changes in my upgraded installation, I found that these are not reflecting post upgrade. i.e post upgrading to new version the database tables remains "****_table" only.

However the upgraded installation works perfectly fine.

I just wanted to confirm is this left purposely or any modifications are required ?

Steps To Reproduce
  1. Take mysql dump of an installation which is to be upgraded.
  2. Make an upgrade to 2.23.0 version
  3. Take a mysql dump of upgraded installation.
  4. Compare both the mysql dumps
Additional Information

PHP 5.5
Mysql 5.5
source installation version 2.22.1
upgraded to version 2.23.0

TagsNo tags attached.

Activities

system

system

2019-12-10 04:23

reporter  

mantisbt.png (57,243 bytes)   
mantisbt.png (57,243 bytes)   
dregad

dregad

2019-12-10 05:27

developer   ~0063226

You need to provide the table prefix / suffix settings upon first installation; defaults are "mantis_" and "_table" respectively. These are then saved in your config_inc.php file, and should not be requested again when performing an upgrade.

This begs the question of how you actually executed the upgrade - it looks like you're performing a new installation instead of an upgrade, and maybe swapped the prefix/suffix.

system

system

2019-12-10 06:20

reporter   ~0063230

Hi Dregad,

Thank you for the help.

In the previous installation only $g_db_table_prefix setting was there and no $g_db_table_suffix and $g_db_table_plugin_prefix. As it is not asking during upgrade process to set these values in config.inc.php file will it make any difference if upgraded installation has tables ending with "_mantis" and there is no entry of it in config file ?

dregad

dregad

2019-12-10 07:06

developer   ~0063233

will it make any difference if upgraded installation has tables ending with "_mantis" and there is no entry of it in config file ?

It makes no difference, as long as the suffix defined in your config, matches the actual tables in your database.

The MantisBT upgrade process will not change these settings, therefore I still think there is something wrong with your system, most likely you did not perform the upgrade as described in the Admin Guide.

system

system

2019-12-10 08:48

reporter   ~0063238

Hi,

I think there is some confusion with this.

I wanted to confirm following

  1. $g_db_table_plugin_prefix and $g_db_table_suffix variables are added in latest version only and not present in previous version. So previously script was taking default suffix for database table as"_table' only without asking enduser.

  2. These two variables are present in config file and in database in fresh installation only. When user upgrades its installation to latest version, its database table suffix is "_table" only (which is default value from source installation) and its entry in not present in config.inc.php

system

system

2019-12-10 08:55

reporter   ~0063239

I have followed all the procedure described in admin upgrade guide.

dregad

dregad

2019-12-10 11:26

developer   ~0063243

$g_db_table_plugin_prefix and $g_db_table_suffix variables are added in latest version only and not present in previous version

If you want to change your prefix/suffix, then you need to rename your tables accordingly so that they match. MantisBT cannot do this.

As I understand things from your note 0026454:0063238, there is really no problem with the software, just a configuration issue, so I'm closing this as no change required.

Issue History

Date Modified Username Field Change
2019-12-10 04:23 system New Issue
2019-12-10 04:23 system File Added: mantisbt.png
2019-12-10 05:27 dregad Assigned To => dregad
2019-12-10 05:27 dregad Status new => feedback
2019-12-10 05:27 dregad Note Added: 0063226
2019-12-10 06:20 system Note Added: 0063230
2019-12-10 06:20 system Status feedback => assigned
2019-12-10 07:06 dregad Note Added: 0063233
2019-12-10 08:48 system Note Added: 0063238
2019-12-10 08:55 system Note Added: 0063239
2019-12-10 11:26 dregad Status assigned => resolved
2019-12-10 11:26 dregad Resolution open => no change required
2019-12-10 11:26 dregad Note Added: 0063243
2019-12-23 01:50 atrol Status resolved => closed