View Issue Details

IDProjectCategoryView StatusLast Update
0026592mantisbtbugtrackerpublic2020-01-14 07:31
Reporterrenegustavo7 Assigned Toatrol  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version2.23.0 
Summary0026592: Internal Application Error to clone issues after 2.23 update
Description

After update my Mantis version to 2.23, I can't clone issues, always returning the message "INTERNAL APPLICATION ERROR". I get this message only in this operation.

MantisBT Version: 2.23.0
Schema Version: 210
PHP Version: 7.2.11

The log file from this operation it's attached.

Steps To Reproduce

View.php page > Clone action > INTERNAL APPLICATION ERROR Please use the "Back" button in your web browser to return to the previous page. There you can correct whatever problems were identified in this error or select another action. You can also click an option from the menu bar to go directly to a new section.

TagsNo tags attached.

Activities

renegustavo7

renegustavo7

2020-01-13 08:27

reporter  

mantis.log (7,467 bytes)   
2020-01-13 10:12 -03 DB database_api.php:161 db_connect() array (
  0 => 'SET NAMES UTF8',
  1 => '0.0002',
)
2020-01-13 10:12 -03 DB plugin_api.php:910 plugin_register_installed() array (
  0 => 'SELECT basename, priority, protected FROM mantis_plugin_table WHERE enabled=\'1\' ORDER BY priority DESC',
  1 => '0.0005',
)
2020-01-13 10:12 -03 DB authentication_api.php:1062 auth_is_cookie_valid() array (
  0 => 'SELECT * FROM mantis_user_table WHERE cookie_string=\'b3667935edd2434caab96cb1b5d211c182ec78defd468102536532df53cf08e0\'',
  1 => '0.0004',
)
2020-01-13 10:12 -03 DB user_pref_api.php:334 user_pref_cache_array_rows() array (
  0 => 'SELECT * FROM mantis_user_pref_table WHERE user_id IN (158) AND project_id = 0',
  1 => '0.0005',
)
2020-01-13 10:12 -03 DB project_api.php:109 project_cache_row() array (
  0 => 'SELECT * FROM mantis_project_table WHERE id=\'113\'',
  1 => '0.0003',
)
2020-01-13 10:12 -03 DB config_api.php:728 config_cache_all() array (
  0 => 'SELECT config_id, user_id, project_id, type,  value, access_reqd FROM mantis_config_table',
  1 => '0.0007',
)
2020-01-13 10:12 -03 DB tokens_api.php:254 token_purge_expired() array (
  0 => 'DELETE FROM mantis_tokens_table WHERE 1578921167 > expiry',
  1 => '0.0003',
)
2020-01-13 10:12 -03 DB tokens_api.php:85 token_get() array (
  0 => 'SELECT * FROM mantis_tokens_table WHERE type=5 AND owner=158',
  1 => '0.0004',
)
2020-01-13 10:12 -03 DB bug_api.php:871 bug_cache_row() array (
  0 => 'SELECT * FROM mantis_bug_table WHERE id=27071',
  1 => '0.0003',
)
2020-01-13 10:12 -03 DB bug_api.php:978 bug_text_cache_row() array (
  0 => 'SELECT bt.* FROM mantis_bug_text_table bt, mantis_bug_table b
				  WHERE b.id=27071 AND b.bug_text_id = bt.id',
  1 => '0.0003',
)
2020-01-13 10:12 -03 DB project_hierarchy_api.php:167 project_hierarchy_cache() array (
  0 => 'SELECT DISTINCT p.id, ph.parent_id, p.name, p.inherit_global, ph.inherit_parent
				  FROM mantis_project_table p
				  LEFT JOIN mantis_project_hierarchy_table ph
				    ON ph.child_id = p.id
				  WHERE p.enabled = \'1\'
				  ORDER BY p.name',
  1 => '0.0006',
)
2020-01-13 10:12 -03 DB version_api.php:238 version_cache_array_rows() array (
  0 => 'SELECT * FROM mantis_project_version_table WHERE project_id = 225',
  1 => '0.0004',
)
2020-01-13 10:12 -03 DB user_api.php:1174 user_get_accessible_subprojects() array (
  0 => 'SELECT DISTINCT p.id, p.name, ph.parent_id
					  FROM mantis_project_table p
					  LEFT JOIN mantis_project_hierarchy_table ph
					    ON ph.child_id = p.id
					  WHERE p.enabled = \'1\' AND
					  	 ph.parent_id IS NOT NULL
					  ORDER BY p.name',
  1 => '0.0005',
)
2020-01-13 10:12 -03 DB project_api.php:109 project_cache_row() array (
  0 => 'SELECT * FROM mantis_project_table WHERE id=225',
  1 => '0.0011',
)
2020-01-13 10:12 -03 DB project_api.php:149 project_cache_array_rows() array (
  0 => 'SELECT * FROM mantis_project_table WHERE id IN (141,161,263,145,257,247,240,246,34,100,36,30,107,157,266,260,248,192,173,164,167,101,116,216,28,213,160,170,31,35,210,243,79,91,144,231,228,234,237,219,222,255)',
  1 => '0.0011',
)
2020-01-13 10:12 -03 DB tokens_api.php:85 token_get() array (
  0 => 'SELECT * FROM mantis_tokens_table WHERE type=3 AND owner=158',
  1 => '0.0004',
)
2020-01-13 10:12 -03 DB bug_api.php:910 bug_cache_array_rows() array (
  0 => 'SELECT * FROM mantis_bug_table WHERE id IN (23538,27500,25826,26786)',
  1 => '0.0004',
)
2020-01-13 10:12 -03 DB category_api.php:491 category_get_all_rows() array (
  0 => 'SELECT c.*, p.name AS project_name FROM mantis_category_table c
				LEFT JOIN mantis_project_table p
					ON c.project_id=p.id
				WHERE  project_id IN ( 225 )  ORDER BY c.name',
  1 => '0.0004',
)
2020-01-13 10:12 -03 DB custom_field_api.php:817 custom_field_get_linked_ids() array (
  0 => 'SELECT CFP.project_id, CF.id FROM mantis_custom_field_table CF  JOIN mantis_custom_field_project_table CFP ON CFP.field_id = CF.id WHERE CFP.project_id IN (225)	ORDER BY sequence ASC, name ASC',
  1 => '0.0004',
)
2020-01-13 10:12 -03 DB custom_field_api.php:165 custom_field_cache_array_rows() array (
  0 => 'SELECT * FROM mantis_custom_field_table WHERE id IN (66)',
  1 => '0.0003',
)
2020-01-13 10:12 -03 DB custom_field_api.php:185 custom_field_cache_array_rows() array (
  0 => 'SELECT field_id, project_id FROM mantis_custom_field_project_table WHERE field_id IN (66)',
  1 => '0.0002',
)
2020-01-13 10:12 -03 DB custom_field_api.php:257 custom_field_cache_values() array (
  0 => 'SELECT B.id AS bug_id, CF.id AS field_id, CFS.value, CFS.text FROM mantis_bug_table B LEFT OUTER JOIN mantis_custom_field_table CF ON 1 = 1 LEFT OUTER JOIN mantis_custom_field_string_table CFS ON ( B.id = CFS.bug_id AND CF.id = CFS.field_id ) WHERE B.id IN (27071) AND CF.id IN (66)',
  1 => '0.0003',
)
2020-01-13 10:12 -03 DB custom_field_api.php:165 custom_field_cache_array_rows() array (
  0 => 'SELECT * FROM mantis_custom_field_table WHERE id IN (47)',
  1 => '0.0003',
)
2020-01-13 10:12 -03 DB custom_field_api.php:185 custom_field_cache_array_rows() array (
  0 => 'SELECT field_id, project_id FROM mantis_custom_field_project_table WHERE field_id IN (47)',
  1 => '0.0007',
)
2020-01-13 10:12 -03 DB custom_field_api.php:257 custom_field_cache_values() array (
  0 => 'SELECT B.id AS bug_id, CF.id AS field_id, CFS.value, CFS.text FROM mantis_bug_table B LEFT OUTER JOIN mantis_custom_field_table CF ON 1 = 1 LEFT OUTER JOIN mantis_custom_field_string_table CFS ON ( B.id = CFS.bug_id AND CF.id = CFS.field_id ) WHERE B.id IN (27071) AND CF.id IN (47)',
  1 => '0.0005',
)
2020-01-13 10:12 -03 DB custom_field_api.php:165 custom_field_cache_array_rows() array (
  0 => 'SELECT * FROM mantis_custom_field_table WHERE id IN (4)',
  1 => '0.0003',
)
2020-01-13 10:12 -03 DB custom_field_api.php:185 custom_field_cache_array_rows() array (
  0 => 'SELECT field_id, project_id FROM mantis_custom_field_project_table WHERE field_id IN (4)',
  1 => '0.0002',
)
2020-01-13 10:12 -03 DB custom_field_api.php:257 custom_field_cache_values() array (
  0 => 'SELECT B.id AS bug_id, CF.id AS field_id, CFS.value, CFS.text FROM mantis_bug_table B LEFT OUTER JOIN mantis_custom_field_table CF ON 1 = 1 LEFT OUTER JOIN mantis_custom_field_string_table CFS ON ( B.id = CFS.bug_id AND CF.id = CFS.field_id ) WHERE B.id IN (27071) AND CF.id IN (4)',
  1 => '0.0003',
)
2020-01-13 10:12 -03 DB custom_field_api.php:165 custom_field_cache_array_rows() array (
  0 => 'SELECT * FROM mantis_custom_field_table WHERE id IN (69)',
  1 => '0.0003',
)
2020-01-13 10:12 -03 DB custom_field_api.php:185 custom_field_cache_array_rows() array (
  0 => 'SELECT field_id, project_id FROM mantis_custom_field_project_table WHERE field_id IN (69)',
  1 => '0.0006',
)
2020-01-13 10:12 -03 DB custom_field_api.php:257 custom_field_cache_values() array (
  0 => 'SELECT B.id AS bug_id, CF.id AS field_id, CFS.value, CFS.text FROM mantis_bug_table B LEFT OUTER JOIN mantis_custom_field_table CF ON 1 = 1 LEFT OUTER JOIN mantis_custom_field_string_table CFS ON ( B.id = CFS.bug_id AND CF.id = CFS.field_id ) WHERE B.id IN (27071) AND CF.id IN (69)',
  1 => '0.0007',
)
2020-01-13 10:12 -03 DB tokens_api.php:85 token_get() array (
  0 => 'SELECT * FROM mantis_tokens_table WHERE type=3 AND owner=158',
  1 => '0.0003',
)
2020-01-13 10:12 -03 DB user_api.php:1489 user_update_last_visit() array (
  0 => 'UPDATE mantis_user_table SET last_visit=1578921167 WHERE id=158',
  1 => '0.0011',
)
mantis.log (7,467 bytes)   
atrol

atrol

2020-01-14 03:30

developer   ~0063433

I was not able to reproduce the issue using the given information

After update my Mantis version to 2.23

Which version did you use before?

The log file from this operation it's attached.

As this is an "INTERNAL APPLICATION ERROR", you should also check the webserver and PHP logs for errors and warnings.

renegustavo7

renegustavo7

2020-01-14 07:25

reporter   ~0063434

Ok, I understood the problem, it was some differences on the bug_report_page page where we made some customizations. I managed to fix the problem.

Sorry for the inconvenience and thanks!

atrol

atrol

2020-01-14 07:31

developer   ~0063435

Thanks for the feedback.

Issue History

Date Modified Username Field Change
2020-01-13 08:27 renegustavo7 New Issue
2020-01-13 08:27 renegustavo7 File Added: mantis.log
2020-01-14 03:30 atrol Status new => feedback
2020-01-14 03:30 atrol Note Added: 0063433
2020-01-14 07:25 renegustavo7 Note Added: 0063434
2020-01-14 07:25 renegustavo7 Status feedback => new
2020-01-14 07:31 atrol Assigned To => atrol
2020-01-14 07:31 atrol Status new => resolved
2020-01-14 07:31 atrol Resolution open => no change required
2020-01-14 07:31 atrol Note Added: 0063435