View Issue Details

IDProjectCategoryView StatusLast Update
0026708mantisbtattachmentspublic2020-06-02 16:56
Reporterfishgirl Assigned Toatrol  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.21.1 
Summary0026708: Attachments make notes deletable
Description

In our system it is not allowed to delete foreign notes for other users.

However, if the note ONLY includes a file (no metter what .pdf, .xslx, .jpg) it is possible to delete the note. For everyone.

Notes with some text +attachment cannot be deleted.

Please, see the pictures below.

Additional Information

System information:

MantisBT Version
2.21.1
Schema Version
209
PHP Version
7.3.1
Database Driver
mysqli
Database Version, Description
8.0.16, 8.0.16

TagsNo tags attached.

Activities

fishgirl

fishgirl

2020-02-17 05:27

reporter  

Attachment with text.jpg (38,698 bytes)   
Attachment with text.jpg (38,698 bytes)   
Attachment without text.jpg (12,531 bytes)   
Attachment without text.jpg (12,531 bytes)   
vboctor

vboctor

2020-03-14 18:05

manager   ~0063760

@fishgirl this area has significantly changed in MantisBT 2.23.0. Can you please upgrade and test?

atrol

atrol

2020-05-21 10:40

developer   ~0064016

fishgirl,

I tried latest version and was not able to reproduce using the given information.
Feel free to reopen the issue at a later time if you should encounter the issue after upgrading,.

Issue History

Date Modified Username Field Change
2020-02-17 05:27 fishgirl New Issue
2020-02-17 05:27 fishgirl File Added: Attachment with text.jpg
2020-02-17 05:27 fishgirl File Added: Attachment without text.jpg
2020-03-14 18:05 vboctor Assigned To => vboctor
2020-03-14 18:05 vboctor Status new => feedback
2020-03-14 18:05 vboctor Note Added: 0063760
2020-05-21 10:40 atrol Assigned To vboctor => atrol
2020-05-21 10:40 atrol Status feedback => resolved
2020-05-21 10:40 atrol Resolution open => fixed
2020-05-21 10:40 atrol Note Added: 0064016
2020-06-02 16:56 atrol Status resolved => closed