View Issue Details

IDProjectCategoryView StatusLast Update
0026713mantisbtintegrationpublic2020-02-29 11:52
Reporterrajasekaran1980 Assigned Todregad  
PriorityhighSeveritymajorReproducibilitysometimes
Status closedResolutionno change required 
Product Version2.13.1 
Summary0026713: Plugin "Mantis" returned an error: SOAP-ERROR:
Description

Hi
I have installed Testrail app and trying to integrate with Mantis when i push the result i do receive below error :

Plugin "Mantis" returned an error: SOAP-ERROR: Parsing WSDL: Couldn't load from 'https://192.168.168.150:9999/mantis/api/soap/mantisconnect.php?wsdl' : failed to load external entity "https://192.168.168.150:9999/mantis/api/soap/mantisconnect.php?wsdl"

Below is Testrail Sys error log:

[SoapFault] SOAP-ERROR: Parsing WSDL: Couldn't load from 'https://103.2.181.180:9999/mantis/api/soap/mantisconnect.php?wsdl' : failed to load external entity "https://103.2.181.180:9999/mantis/api/soap/mantisconnect.php?wsdl"

---
Details: <missing>
File: C:\inetpub\wwwroot\testrail\sys\helpers\soap.php
Line: 44
Status Code: 500
Host: localhost
Uri: /testrail/index.php?/defects/ajax_prepare_push (POST)
---
Browser: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.106 Safari/537.36
PHP: 7.2.26
Server: Windows NT 6.3 build 9600 (Windows Server 2012 R2 Standard Edition) AMD64
---
status_id: 1
assignedto: <empty>
comment: <empty>
version: <empty>
elapsed: <empty>
defects: <empty>
attachments: <empty>
project_id: 1
test_ids: 1
_token: HdVr5FcJbwpstzBlPRhj
_version: 6.1.1.1020
---
Trace:
at SoapClient->SoapClient (soap.php:44)
at soap::get_client (Mantis.php:409)
at Mantis_api->__construct (Mantis.php:99)
at Mantis_defect_plugin->_get_api (Mantis.php:229)
at Mantis_defect_plugin->prepare_field (defects.php:616)
at Defects_controller->_prepare_form (defects.php:667)
at Defects_controller->ajax_prepare_push (controller.php:257)
at Controller->_invoke_web_call (controller.php:168)
at Controller->_invoke_web (controller.php:120)
at Controller->_invoke (gizmo.php:107)
at require_once (index.php:114)

could you please help to solve this issue

TagsNo tags attached.

Activities

dregad

dregad

2020-02-18 03:37

developer   ~0063644

It would appear that the problem is caused by your "Testrail" software, which AFAICT is just a client using MantisBT's SOAP API. I would suggest to contact the support for Testrail.

Make sure that MantisBT is properly configured to use the SOAP API.

rajasekaran1980

rajasekaran1980

2020-02-18 05:17

reporter   ~0063647

Hi Dregad

Thanks for your info.

could you please provide the SOAP API configuration steps to check whether it is correct or not

Thanks
Raja

Issue History

Date Modified Username Field Change
2020-02-17 23:40 rajasekaran1980 New Issue
2020-02-18 03:23 dregad Description Updated View Revisions
2020-02-18 03:37 dregad Assigned To => dregad
2020-02-18 03:37 dregad Status new => resolved
2020-02-18 03:37 dregad Resolution open => no change required
2020-02-18 03:37 dregad Note Added: 0063644
2020-02-18 05:17 rajasekaran1980 Note Added: 0063647
2020-02-29 11:52 atrol Status resolved => closed