View Issue Details

IDProjectCategoryView StatusLast Update
0026734mantisbtadministrationpublic2020-03-10 17:23
ReporterWma Assigned Toatrol  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version2.23.0 
Summary0026734: Colors of a customer state in a table are not shown
Description

I have already extended Mantis in version 1.2.19 with different editing/processing states.

In version V2.23 I have taken over these states from V1.2.19.
Unfortunately the states do not work.
Therefore I have extended the <b>config_inc.php</b> with a status <b>"IN_PROGRESS"</b> and assigned a color to it.
See screenshot.

In the table ("View issues") - I see only Black for the State "IN_PROGRESS" -> See Screenshot

Additional Information

Define in Config_inc.php

/**

  • WMA, 23.12.2019
  • Neue States definieren
    */
    define( 'TESTED_NIO', 60 );
    define( 'IN_PROGRESS', 70 );
    define( 'TESTS_DOCS', 81 );
    define( 'REVIEWED', 82 );
    define( 'TESTED', 85 );

    // Status: tested NOK
    $g_status_colors['tested_nio'] = '#FF5E5E'; #

    // Status: in_progress
    $g_status_colors['IN_PROGRESS'] = '#3A9FE7';

    // Status: tests_docs -> wurde entfernt 23.12.2019
    $g_status_colors['tests_docs'] = '#ACE7AE';

    // Status: reviewed
    $g_status_colors['reviewed'] = '#02B21E'; #

TagsNo tags attached.

Activities

Wma

Wma

2020-02-24 08:48

reporter   ~0063682

Last edited: 2020-02-24 08:52

View 2 revisions

Different Screenshots
1.) Definition
2.) Color definition
3.) View Issues

image.png (31,829 bytes)   
image.png (31,829 bytes)   
image-2.png (18,139 bytes)   
image-2.png (18,139 bytes)   
image-3.png (11,227 bytes)   
image-3.png (11,227 bytes)   
atrol

atrol

2020-02-24 16:50

developer   ~0063683

Wma,

Ensure that you are exactly following the steps provided in Admin Guide https://mantisbt.org/docs/master/en-US/Admin_Guide/html-desktop/#admin.customize.status

This is not a bug or feature request for MantisBT (you are asking for help on how to configure the system). I am therefore resolving this issue as "no change required".

Please use the forums to get support on customizing and using MantisBT (refer to http://www.mantisbt.org/support.php for links and further details).

Wma

Wma

2020-02-25 01:48

reporter   ~0063686

I did it exactly like this. Now in a second project I copied the texts for "testing" from the manual and pasted them into the files. The status remains black.
I will look around in the forums.

image-4.png (3,369 bytes)   
image-4.png (3,369 bytes)   

Issue History

Date Modified Username Field Change
2020-02-24 08:43 Wma New Issue
2020-02-24 08:48 Wma Note Added: 0063682
2020-02-24 08:48 Wma File Added: image.png
2020-02-24 08:48 Wma File Added: image-2.png
2020-02-24 08:48 Wma File Added: image-3.png
2020-02-24 08:52 Wma Note Edited: 0063682 View Revisions
2020-02-24 16:50 atrol Assigned To => atrol
2020-02-24 16:50 atrol Status new => resolved
2020-02-24 16:50 atrol Resolution open => no change required
2020-02-24 16:50 atrol Note Added: 0063683
2020-02-25 01:48 Wma Note Added: 0063686
2020-02-25 01:48 Wma File Added: image-4.png
2020-03-10 17:23 atrol Status resolved => closed