View Issue Details

IDProjectCategoryView StatusLast Update
0026761mantisbtfilterspublic2020-05-21 10:51
Reportersadovsf Assigned Toatrol  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.23.0 
Summary0026761: Relationship filtering not working properly for none case
Description

I need to filter all "root" tasks for specific target version. This should be quite simple filter:

Relationship:  child of none (type child, id -2)
Target version: My_product_version

This works but only as long as no child task have target version set to My_product_version. When this happens such task will be output as result of filter along with roots although it does have relationship of type child to some other task

Steps To Reproduce
  1. Create 2 tasks:

    • Parent_task with target version set to My_product_version (can be any version used later in filter)
    • Child_task with target version set to My_product_version (can be any version used later in filter)
  2. Add child of relationship so created tasks are in hierarchy (Parent_task will have relationship parent of to Child_task).

  3. Create new filter according to description

  4. You will see both tasks being output to table

Wanted state:
Only Parent_task visible in table

Additional Information

Attached files are:

  • Filter used to achieve described result
  • IDs of bug output to result table
  • Relationship details of what is Child_task in this case (you can see it has child relationship to other bug in results (Parent_task)
TagsNo tags attached.

Activities

sadovsf

sadovsf

2020-03-04 09:03

reporter  

image.png (18,205 bytes)   
image.png (18,205 bytes)   
image-2.png (6,418 bytes)   
image-2.png (6,418 bytes)   
image-3.png (7,148 bytes)   
image-3.png (7,148 bytes)   
atrol

atrol

2020-03-04 14:20

developer   ~0063731

No time to check myself at the moment, but this might be already fixed in next version 2.24.0, see 0026621
You could try a nightly build https://mantisbt.org/builds.php

syncguru

syncguru

2020-03-06 19:22

developer   ~0063734

@sadovsf I am curious about the dark background shown on the snapshot, how did you end up with a dark theme?

sadovsf

sadovsf

2020-03-07 02:33

reporter   ~0063735

Iam actually working on quite a big client side application for planning and project overview. Part of it being own fast php api for mass operations in mantis and part typescript api for client side of things. Results are ability to download thousands tasks from dB into client side app and work with it locally with indo redo support and stuff. Then you hit save and everything gets. Stored in mantis.

Part of this was request from our employees to have dark theme so I did reskin of whole mantis and add button to switch themes into mantis toolbar using simple js code. Thanks to this we now have slightly better looking light and dark themes that works everywhere.

It's not yet finished but if you would like to I could probably share CSS along with js that handles switching in forum of simple plugin maybe �

atrol

atrol

2020-05-21 10:51

developer   ~0064017

sadovsf,

I tried latest version and was not able to reproduce using the given information.

Feel free to reopen the issue at a later time if you should still encounter the problem after upgrading.

Issue History

Date Modified Username Field Change
2020-03-04 09:03 sadovsf New Issue
2020-03-04 09:03 sadovsf File Added: image.png
2020-03-04 09:03 sadovsf File Added: image-2.png
2020-03-04 09:03 sadovsf File Added: image-3.png
2020-03-04 14:20 atrol Status new => feedback
2020-03-04 14:20 atrol Note Added: 0063731
2020-03-06 19:22 syncguru Note Added: 0063734
2020-03-07 02:33 sadovsf Note Added: 0063735
2020-03-07 02:33 sadovsf Status feedback => new
2020-03-07 09:41 atrol Status new => feedback
2020-05-21 10:51 atrol Assigned To => atrol
2020-05-21 10:51 atrol Status feedback => resolved
2020-05-21 10:51 atrol Resolution open => fixed
2020-05-21 10:51 atrol Note Added: 0064017