View Issue Details

IDProjectCategoryView StatusLast Update
0027375mantisbtfilterspublic2020-10-06 04:36
Reporterhloehnert Assigned Todregad  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.25.0 
Target Version2.25.0Fixed in Version2.25.0 
Summary0027375: search field at project-selection is not working anymore
Description

After updating to the actual master-branch (V2.25.0) the search-field at the project-selection-dropdown is not working anymore.

TagsNo tags attached.

Relationships

related to 0026888 resolveddregad Refactor printing of project selection menus 

Activities

atrol

atrol

2020-10-05 15:00

developer   ~0064523

Regression introduced in 0026888

dregad

dregad

2020-10-06 04:26

developer   ~0064527

I'll look into it

Related Changesets

MantisBT: master aaa5807d

2020-10-06 04:34:10

dregad

Details Diff
Fix search in project selector

Commit edb40eabd5299d5fe4c4a23865ff3523d020b6f5 (issue 0026888) introduced
a regression causing the filtered projects list to always be empty,
regardless of what the user typed in the Search field.

The bug was caused by a typo in CSS class name (`project_link` instead
of `project-link`).

Fixes 0027375
Affected Issues
0026888, 0027375
mod - core/layout_api.php Diff File

Issue History

Date Modified Username Field Change
2020-10-05 11:19 hloehnert New Issue
2020-10-05 15:00 atrol Relationship added related to 0026888
2020-10-05 15:00 atrol Assigned To => dregad
2020-10-05 15:00 atrol Status new => confirmed
2020-10-05 15:00 atrol Note Added: 0064523
2020-10-05 15:01 atrol Target Version => 2.25.0
2020-10-06 04:26 dregad Status confirmed => assigned
2020-10-06 04:26 dregad Note Added: 0064527
2020-10-06 04:36 dregad Changeset attached => MantisBT master aaa5807d
2020-10-06 04:36 dregad Status assigned => resolved
2020-10-06 04:36 dregad Resolution open => fixed
2020-10-06 04:36 dregad Fixed in Version => 2.25.0
2020-10-06 04:36 dregad Product Version => 2.25.0