View Issue Details

IDProjectCategoryView StatusLast Update
0027411mantisbtbugtrackerpublic2020-11-01 05:01
ReporterPozinux Assigned Todregad  
PrioritynormalSeveritytextReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version2.24.3 
Summary0027411: UTF8 not working
Description

Hello,

Refering to the following post, I experience the same issue but with french caracters.

https://mantisbt.org/forums/viewtopic.php?f=3&t=27165&view=unread&sid=48c9970a614567d2f6f012b65ccd1972#unread

When I enter the accent "é", I get "é" (I think it is ISO 8859-1).
It happens when I use forms to report new bug, to add a note etc.

But when I use the modify button to change a note or bug title or anything else, it keep the right letter.

The DB is all UTF8 and the admin check page indicates that everything is ok with UTF8.

I installed the 2.24.2 and the 2.22.1 versions and created new DB but I still get the same problem.

TagsNo tags attached.

Activities

Pozinux

Pozinux

2020-10-15 16:06

reporter  

2020-10-15_22h03_36.png (93,397 bytes)   
2020-10-15_22h03_36.png (93,397 bytes)   
Pozinux

Pozinux

2020-10-15 16:07

reporter   ~0064550

What's funny is that your MantisBT is working well.... I would like the same. ;)

2020-10-15_22h06_30.png (50,604 bytes)   
2020-10-15_22h06_30.png (50,604 bytes)   
dregad

dregad

2020-10-16 03:33

developer   ~0064551

As you have yourself pointed out, UTF8 support is perfectly fine on this bugtracker, as well as on my dev environment. I am able to store and view accented characters without UTF8 <-> ISO-8559-1 conversion issues.

The problem is therefore not caused by a bug in MantisBT, so I will resolve this as "unable to reproduce".

There must be something wrong with your system's configuration. You did not specify what DB engine you're using, but regardless of what the Admin Checks say, I would suggest to double-check if all tables and columns are properly configured to support UTF8.

Pozinux

Pozinux

2020-10-16 08:43

reporter   ~0064553

Last edited: 2020-10-16 08:44

View 3 revisions

Thanks so much for answering so quickly!
I use "InnoDB" engine.
" I would suggest to double-check if all tables and columns are properly configured to support UTF8"
I will and let you know if I find something! Thanks!

Note : Here are my system and DB versions :

mysql -V :
mysql Ver 15.1 Distrib 5.5.65-MariaDB, for Linux (x86_64) using readline 5.1
cat /etc/centos-release :
CentOS Linux release 7.8.2003 (Core)

Pozinux

Pozinux

2020-10-16 09:17

reporter   ~0064554

Hi,

Maybe my problem comes from here (see picture).
All my tables are UTF8 but columns are "utf8_general_ci". It seems different. I'm not a charset db expert, can you tell what you have for your table please?

MariaDB [mantisdb]> SHOW FULL COLUMNS FROM mantis_bugnote_text_table;

Thanks,

Tim

ps : Should I alter with "utf8mb4" ?

image.png (23,360 bytes)   
image.png (23,360 bytes)   
Pozinux

Pozinux

2020-10-17 00:02

reporter   ~0064555

Last edited: 2020-10-17 00:02

View 2 revisions

I checked everything I could think about... No luck...
I made a new fresh install DB. Same problem.
I install a newer mariadb version. Same problem.

Can you let me know what your config system and db is please?
Mine :

mysql -V :
mysql Ver 15.1 Distrib 5.5.65-MariaDB, for Linux (x86_64) using readline 5.1
cat /etc/centos-release :
CentOS Linux release 7.8.2003 (Core)

Thanks

Pozinux

Pozinux

2020-10-17 17:59

reporter   ~0064560

I uninstalled everything and made a new fresh POSTGRESQL db this time.
Same encoding problem with accents...
I might reset my server to move to Centos 8.

Pozinux

Pozinux

2020-10-18 05:54

reporter   ~0064561

Reseted the server to Centos 8 and no problems with accents anymore.

Tim

dregad

dregad

2020-10-19 16:32

developer   ~0064564

Good to hear you found a solution to your problem.

Pozinux

Pozinux

2020-10-19 17:19

reporter   ~0064567

Last edited: 2020-10-19 18:03

View 3 revisions

Thanks but unfortunetly I'm afraid it was for a short time... Last night, when I reported bugs, no accents problems. So I assumed it was thanks to the new install with Centos 8. However, this morning, impossible to report a bug without havind issues accents. See my screen capture it's crazy. Same Mantis, same DB, same computer, came Chrome...
I suspect the problem coming from the time I changed the language from auto (french) to english to french back to auto finaly. But no more luck. I then installed a new version of mantis (same .zip) with a new DB but accents problems still there...
I keep investigating because I really like Mantis. :)

2020-10-19_23h19_25.png (135,896 bytes)   
2020-10-19_23h19_25.png (135,896 bytes)   
Pozinux

Pozinux

2020-10-20 09:53

reporter   ~0064572

Ok I'm found where the problem comes from.
I realised that I was adding some lines to my php config because I read somewhere I had to do it (I don't remembere where) and these lines cause the problem.

I was adding in php.ini :

mbstring.language = all
mbstring.internal_encoding = UTF-8
mbstring.http_input = auto
mbstring.http_output = UTF-8
mbstring.encoding_translation = On
mbstring.detect_order = UTF-8
mbstring.substitute_character = none;
mbstring.func_overload = 0
mbstring.strict_encoding = Off

After I install new Centos 8 and Mantis, I probably tried to report a bug, saw that I did not have the accent issue anymore then later reboot which activated this config. After that all the new report bugs had accents problems... I removed the lines, reboot (probably a httpd restart would be sufficent) and the problem was gone.

Sorry to have annoyed you with that and thanks for your support.

Tim

Issue History

Date Modified Username Field Change
2020-10-15 16:06 Pozinux New Issue
2020-10-15 16:06 Pozinux File Added: 2020-10-15_22h03_36.png
2020-10-15 16:07 Pozinux Note Added: 0064550
2020-10-15 16:07 Pozinux File Added: 2020-10-15_22h06_30.png
2020-10-16 03:33 dregad Assigned To => dregad
2020-10-16 03:33 dregad Status new => resolved
2020-10-16 03:33 dregad Resolution open => unable to reproduce
2020-10-16 03:33 dregad Note Added: 0064551
2020-10-16 03:34 dregad Priority urgent => normal
2020-10-16 03:34 dregad Severity crash => text
2020-10-16 03:34 dregad Description Updated View Revisions
2020-10-16 08:43 Pozinux Note Added: 0064553
2020-10-16 08:44 Pozinux Note Edited: 0064553 View Revisions
2020-10-16 08:44 Pozinux Note Edited: 0064553 View Revisions
2020-10-16 09:17 Pozinux Note Added: 0064554
2020-10-16 09:17 Pozinux File Added: image.png
2020-10-17 00:02 Pozinux Note Added: 0064555
2020-10-17 00:02 Pozinux Note Edited: 0064555 View Revisions
2020-10-17 17:59 Pozinux Note Added: 0064560
2020-10-18 05:54 Pozinux Note Added: 0064561
2020-10-19 16:32 dregad Note Added: 0064564
2020-10-19 17:19 Pozinux Note Added: 0064567
2020-10-19 17:19 Pozinux File Added: 2020-10-19_23h19_25.png
2020-10-19 18:03 Pozinux Note Edited: 0064567 View Revisions
2020-10-19 18:03 Pozinux Note Edited: 0064567 View Revisions
2020-10-20 09:53 Pozinux Note Added: 0064572
2020-11-01 05:01 atrol Status resolved => closed