View Issue Details

IDProjectCategoryView StatusLast Update
0031905mantisbtattachmentspublic2023-01-20 01:55
ReporterLuisF Assigned Todregad  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
PlatformApache on WindowsOSWindows Server 2012 
Product Version2.25.5 
Summary0031905: Changes to $g_allowed_files are being ignored
Description

After installing Mantis, some file extensions were allowed, and that worked just fine, however, after changing $g_allowed_files a couple of days, the new changes aren't being applied at all, new allowed extensions added keep getting rejected and newly removed extensions keep getting allowed.

Restarting apache did not fix this, neither did restarting the entire server, clearing browser data on the client-side also did not fix this

Steps To Reproduce

Define allowed extensions $g_allowed_files, then change the $g_allowed_files variable

Additional Information

On the configuration, zip and pfx files were allowed, however, the configuration being loaded is exactly the old one, which do not include these 2 extensions. The actual upload matches the configuration that the browser is loading, zip and pfx files do not get uploaded, despite being allowed in the configuration. I also tried removing pdf from the $g_allowed_files variables but after that it still would get uploaded no problem

TagsNo tags attached.
Attached Files
configuration.png (27,693 bytes)   
configuration.png (27,693 bytes)   
allowed_files_browser.png (6,372 bytes)   
allowed_files_browser.png (6,372 bytes)   

Activities

LuisF

LuisF

2023-01-17 13:49

reporter   ~0067297

One more thing which I forgot to mention, I also swapped the position of jpg and jpeg, that is why they are different in the configuration and the browser loaded allowed types, this change also got ignored

dregad

dregad

2023-01-18 03:28

developer   ~0067298

Not sure you're aware, but this configuration can be set on a per-project basis, so most likely you have it overridden in your database.

Please check the current value in the Manage Configuration / Configuration Report page.

LuisF

LuisF

2023-01-18 07:09

reporter   ~0067299

I did not have that configuration on the database, but adding it there fixed the problem. I would think it is still an issue - considering it was not in the database before - but if it can be fixed in this way, it becomes a very minor one, thank you.

atrol

atrol

2023-01-18 14:14

developer   ~0067300

Last edited: 2023-01-18 14:14

This looks like you are changing the wrong file, or a PHP Opcache issue.
You could add die ('Hello'); to your config_inc.php to find out if the changes are applied.

LuisF

LuisF

2023-01-19 19:37

reporter   ~0067301

Last edited: 2023-01-19 19:45

All this time I have been editing a backup of the file instead of the file itself. I am sorry for wasting your time

dregad

dregad

2023-01-20 01:55

developer   ~0067302


It happens...