View Issue Details

IDProjectCategoryView StatusLast Update
0003211mantisbtbugtrackerpublic2004-12-11 03:01
Reporterjeremy Assigned Tovboctor  
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionwon't fix 
Product Version0.18.0a4 
Fixed in Version0.19.1 
Summary0003211: Bug history for bugnote includes non-useful bugnote number
Description

The Bug History entry that results from adding a bugnote is of the following form:

25-Jun 14:32 jeremy Bugnote Added: 0000287

This number seems to be meaningless to the user. Could it be either:
a) replaced with a bug-specific bugnote number (i.e. bugnotes for a given PR are numbered 1, 2, 3, etc) which is displayed with the bugnote, or
b) removed altogether (the bugnote is probably adequately identified by its timestamp)?

TagsNo tags attached.

Activities

jeremy

jeremy

2003-06-26 10:42

reporter   ~0004363

Version 0.18.0a4

vboctor

vboctor

2003-06-26 16:56

manager   ~0004364

In another bug, a user suggested showing the bugnote number and allow direct linking to specific bugnotes. So in a bug description or a bugnote, a user can refer to another bugnote.

jeremy

jeremy

2003-07-10 06:19

reporter   ~0004391

In that case shouldn't the 'Bug Notes' section display the bugnote number?

Would it be more intuitive to refer to bugnotes as, for example, 0003211-1, 0003211-2 etc?

vboctor

vboctor

2003-07-10 12:04

manager   ~0004392

I think it might be confusing to number them as 1, 2, 3. The reason for that is if the bugnotes are ordered differently (ascending vs descending - which is an option in the configs), the user might be confused.

vboctor

vboctor

2003-07-10 12:04

manager   ~0004393

I think it might be confusing to number them as 1, 2, 3. The reason for that is if the bugnotes are ordered differently (ascending vs descending - which is an option in the configs), the user might be confused.

jeremy

jeremy

2003-07-11 02:32

reporter   ~0004394

I can't see how a user could be confused by ascending or descending numbers, but that's a minor quibble.
The main point is that if the bugnote number doesn't appear with the bugnote there's little point displaying it in the bug history. Looking at the page for this bug, the number 0004393 in the bug history below means nothing, because the bugnote to which this refers doesn't display that number anywhere.

tdok2

tdok2

2004-03-31 15:03

reporter   ~0005306

Jeremy,

If you think that bugnote # is not very useful to the regular users (which I can understand that it's not), then you can do 1 of the two things.

  1. Don't display history at all to the regular users, which are Reporters, since I doubt that they really should be looking at the history anyway.

  2. Edit the /core/history_api.php , function history_get_events_array(), at where the bugnote's # is set into the array. Simply take out the bugnote's #. The line is something like this:
    $t_note = lang_get( 'bugnote_added' ) . ": " . $v_old_value;

tdok2

tdok2

2004-03-31 15:03

reporter   ~0005307

Jeremy,

If you think that bugnote # is not very useful to the regular users (which I can understand that it's not), then you can do 1 of the two things.

  1. Don't display history at all to the regular users, which are Reporters, since I doubt that they really should be looking at the history anyway.

  2. Edit the /core/history_api.php , function history_get_events_array(), at where the bugnote's # is set into the array. Simply take out the bugnote's #. The line is something like this:
    $t_note = lang_get( 'bugnote_added' ) . ": " . $v_old_value;

TomR

TomR

2004-10-05 03:33

reporter   ~0007902

Is there a way to control the display of the history?

$g_view_history_threshold = UPDATER; does not seem to work.

vboctor

vboctor

2004-12-05 04:47

manager   ~0008510

$g_view_history_threshold now works. When it was added, it was implemented only for email notifications. In 0.19.1 (if not before that), I implemented it for viewing issue history as well.

The issue note ids are now displayed as well. Hence, showing the number in the history is useful. In the future, it may be possible to link to a note id directly, and hence showing the ids will become of more value then.

Issue History

Date Modified Username Field Change
2003-06-26 09:28 jeremy New Issue
2003-06-26 10:42 jeremy Note Added: 0004363
2003-06-26 16:56 vboctor Product Version => 0.18.0a4
2003-06-26 16:56 vboctor Note Added: 0004364
2003-07-10 06:19 jeremy Note Added: 0004391
2003-07-10 12:04 vboctor Note Added: 0004392
2003-07-10 12:04 vboctor Note Added: 0004393
2003-07-11 02:32 jeremy Note Added: 0004394
2004-03-31 15:03 tdok2 Note Added: 0005306
2004-03-31 15:03 tdok2 Note Added: 0005307
2004-10-05 03:33 TomR Note Added: 0007902
2004-12-05 04:44 vboctor Assigned To => vboctor
2004-12-05 04:47 vboctor Status new => resolved
2004-12-05 04:47 vboctor Fixed in Version => 0.19.1
2004-12-05 04:47 vboctor Resolution open => won't fix
2004-12-05 04:47 vboctor Note Added: 0008510
2004-12-11 03:01 vboctor Status resolved => closed