View Issue Details

IDProjectCategoryView StatusLast Update
0034382mantisbtotherpublic2024-04-14 07:28
Reporteracoder2020 Assigned Toatrol  
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionno change required 
Product Version2.26.0 
Summary0034382: Unknown named parameter $bug_id on view.php - cannot view any issue
Description

Recently upgraded from PHP 7.4 to PHP 8.0. I get the following when attempting to view any issue:


INTERNAL APPLICATION ERROR

Unknown named parameter $bug_id
Please use the "Back" button in your web browser to return to the previous page. There you can correct whatever problems were identified in this error or select another action. You can also click an option from the menu bar to go directly to a new section.
Detailed error information

Full path: /data/www/mantis/mantisbt-2.26.0/core/error_api.php
Line number: 92

Stack trace

Filename Line Class Type Function Args

0 /data/www/mantis/mantisbt-2.26.0/core/event_api.php 302 - - event_callback -
1 /data/www/mantis/mantisbt-2.26.0/core/event_api.php 175 - - event_type_chain -
2 /data/www/mantis/mantisbt-2.26.0/core/email_api.php 1661 - - event_signal -
3 /data/www/mantis/mantisbt-2.26.0/core/print_api.php 1679 - - email_build_subject -
4 /data/www/mantis/mantisbt-2.26.0/core/print_api.php 227 - - print_email_link_with_subject -
5 /data/www/mantis/mantisbt-2.26.0/bug_view_inc.php 294 - - print_user_with_subject -
6 /data/www/mantis/mantisbt-2.26.0/view.php 36 - - include <string>'/data/www/mantis/mantisbt-2.26.0/bug_view_inc.php'

Steps To Reproduce

Access any issue page in MantisBT

Additional Information

No changes to MantisBT code have been made

TagsNo tags attached.

Activities

acoder2020

acoder2020

2024-04-01 13:44

reporter   ~0068765

Modules installed:

[PHP Modules]
bcmath
bz2
calendar
Core
ctype
curl
date
dom
exif
fileinfo
filter
ftp
gd
gettext
hash
iconv
intl
json
ldap
libxml
mbstring
mysqli
mysqlnd
odbc
openssl
pcntl
pcre
PDO
pdo_mysql
PDO_ODBC
pdo_sqlite
Phar
posix
readline
Reflection
session
shmop
SimpleXML
sockets
SPL
sqlite3
standard
sysvmsg
sysvsem
sysvshm
tokenizer
xml
xmlreader
xmlwriter
xsl
Zend OPcache
zip
zlib

[Zend Modules]
Zend OPcache

atrol

atrol

2024-04-01 14:28

developer   ~0068766

No changes to MantisBT code have been made

Sure?

2 /data/www/mantis/mantisbt-2.26.0/core/email_api.php 1661 - - event_signal -

Looks like you changed core/email_api.php.
Are you able to reproduce the issue using the original source code of MantisBT?

Independent from that, using latest stable version (2.26.1 at the moment) is recommended.

acoder2020

acoder2020

2024-04-01 15:37

reporter   ~0068768

Restoring email_api.php does not resolve the issue. There are several other files untouched from the HTML Email plugin listed in the stack trace.

My understanding was 2.26.1 was just a fix for better handling a MySQL Version check during setup, right?

acoder2020

acoder2020

2024-04-01 15:42

reporter   ~0068769

Lots more updates in the changelog - updating to 2.26.1 now.

acoder2020

acoder2020

2024-04-02 16:29

reporter   ~0068776

Upgrading to 2.26.1 and reinstalling HTMLEmail resolved this issue.

dregad

dregad

2024-04-02 16:36

developer   ~0068777

Thanks for the feedback. Resolving issue as no change required.