View Issue Details

IDProjectCategoryView StatusLast Update
0034469mantisbtfeaturepublic2024-07-22 05:53
Reportervivekg Assigned Todregad  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Summary0034469: Enable status change when assigning bug
Description

Hi Team,

We are facing issue with mantis ticketing configurations. Earlier It used to be the case that when a user set an issue status to "resolved", and then the ticket was assigned or re-assigned to a different user account, then the system would automatically update the issue status to "assigned".

Now, the issue will remain in "resolved" status even when re-assigned.

Could you please suggest what configuration needs to be amended to fix this issue.

Regards,
G P Vivek

Steps To Reproduce

Steps to reproduce.

  1. Create a ticket
  2. Change the status from "New" to Resolved".
  3. Now assign the incident to different personnel.

here expectation is that once the ticket is reassigned the state of the incident changes from "Resolved" to "Assigned".

TagsNo tags attached.

Activities

dregad

dregad

2024-06-17 12:34

developer   ~0068976

Your problem's description is not very clear. My answer assumes you mean use of the Assign To: button on Issue View page.

If so, then the status is changed to assigned, only when the handler is not set yet, and $g_auto_set_status_to_assigned = ON; (check bug_get_status_for_assign() function for full details on conditions for this to happen).

Earlier It used to be the case that when a user set an issue status to "resolved", and then the ticket was assigned or re-assigned to a different user account, then the system would automatically update the issue status to "assigned".

I don't think this behavior has changed, at least not recently.
What do you mean by "Earlier" exactly ? Please specify which MantisBT version, and provide detailed instructions to reproduce.

Could you please suggest what configuration needs to be amended to fix this issue.

Assign to means setting an issue's Handler.
If you wish to change the status, you should use the Change Status button instead.

vivekg

vivekg

2024-07-08 01:27

reporter   ~0069024

Last edited: 2024-07-08 01:29

Hi Team,

Yes, we can use the "Change Status" button to change the status as desired but this was not the case prior to May 16-17.

Even when a closed incident was reassigned to someone the status of incident would automatically change to "Assigned to" but currently if an issue is closed/fixed and than reassigned to a different personnel the status remains closed/fixed and we need to manually change the status to "Assigned".

attachment for reference.

Can you please suggest what configuration needs to be changed in order to fix this?

Mantis version : MantisBT 2.26.2

vivekg

vivekg

2024-07-08 01:30

reporter   ~0069025

attachment

dregad

dregad

2024-07-22 05:53

developer   ~0069043

currently if an issue is closed/fixed and than reassigned to a different personnel the status remains closed/fixed and we need to manually change the status to "Assigned".

This is by design, as mentioned in my earlier note 0034469:0068976.
I am therefore resolving this issue as "no change required".

this was not the case prior to May 16-17.

I asked you a question which you did not answer:
What do you mean by "Earlier" exactly ? Please specify which MantisBT version, and provide detailed instructions to reproduce.