View Issue Details

IDProjectCategoryView StatusLast Update
0007510mantisbtcustomizationpublic2019-04-13 17:59
ReporterrenfrowlAssigned Todregad 
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionno change required 
Product Version1.1.0a1 
Target VersionFixed in Version 
Summary0007510: Database configuration enhancement
Description

I've been playing with the alpha build of mantis you have and love it..

However I have 1 suggestion i would absolutely love. Where I work, I support a lot of projects and we have started setting up mantis instances for them. However like human nature people want to make it as much of a pain to setup for them as it can be.

The basic gripe I get is they want the text customized.. which is no problem i have just been editing the strings_english files. However I’m starting to get to a point of hosting multiple projects on the same instance and that doesn’t necessarily work for me too much anymore.

So you have this new nifty database configuration where i noticed you can set options per project. would it be possible to add in language overrides into that?

So i could do something like s_steps_to_reproduce_updated = foo for project 1 where project 2 could say bar?

TagsNo tags attached.

Activities

ryandesign

ryandesign

2006-10-10 13:34

reporter   ~0013596

You might do better to edit custom_strings_inc.php instead of strings_english.txt. Since that's a PHP file, you might even already be able to write a switch statement to provide different translations depending on the active project.

renfrowl

renfrowl

2006-10-10 13:37

reporter   ~0013597

Last edited: 2007-03-12 23:50

Yes i've been reading over vboctors blog at http://www.futureware.biz/blog/index.php?title=customising_localised_strings_in_mantis&more=1&c=1&tb=1&pb=1

And i have finally managed to setup some custom strings for each project (YAA!)

But adding it into the database would still be nice.. it's a excelent new feature you guys got, and would be nice to see it expanded past just basic configurations.

renfrowl

renfrowl

2006-10-10 14:36

reporter   ~0013599

Last edited: 2006-10-10 14:36

Now i'm in no way a php guru.. but at first i thought i had it until i went to the login screen and it was blank.. so does anybody see any issues doing this in the custom_strings file?

<pre>
if ( auth_is_user_authenticated() ) {
if ( lang_get_current() == 'english' ) {
$currentproject = helper_get_current_project();

if ($currentproject == 44) {
  $s_product_version = 'Target Release';
  $s_steps_to_reproduce = 'Templates';
  $s_versions = 'Target Release';
  $s_update_bug_button = 'Edit Simple Information';
  $s_create_child_bug_button = &quot;Copy Issue&quot;;
 }

}
}
</pre>

ryandesign

ryandesign

2006-10-10 14:54

reporter   ~0013600

If a page is blank, it often means that a PHP error has occurred but you have disabled the onscreen display of PHP errors, in which case hopefully you are logging the error. Does it say anything useful in your Apache or PHP error log?

renfrowl

renfrowl

2006-10-10 15:00

reporter   ~0013601

At first the page was blank, and php logging was enabled, however nothing came up inside the logs. but adding in the statement

if ( auth_is_user_authenticated() ) {

cured the blank page issues.. i'm guessing mantis could not find the current project ID since the user was not authenticated.

darkfader

darkfader

2007-02-15 05:02

reporter   ~0014050

If this issue is about the famous "Database Configuration" or aka "generic configuration", I'd like the edit option also mentioned in 0007586.
It would be even cooler if you could select from available configuration options/values.
Someday, it might even cope with those 2D configurations such as thresholds and transitions. This way it could replace the original configuration pages.

dregad

dregad

2019-03-27 12:24

developer   ~0061787

Customizing language strings is achieved via custom_strings_inc.php, including for multiple languages, as documented in the Admin guide
http://mantisbt.org/docs/master/en-US/Admin_Guide/html-desktop/#admin.customize.strings

Issue History

Date Modified Username Field Change
2006-10-10 12:41 renfrowl New Issue
2006-10-10 12:41 renfrowl Sponsorship Added renfrowl: US$ 10
2006-10-10 12:41 renfrowl Sponsorship Total 0 => 10
2006-10-10 13:34 ryandesign Note Added: 0013596
2006-10-10 13:37 renfrowl Note Added: 0013597
2006-10-10 14:36 renfrowl Note Added: 0013599
2006-10-10 14:36 renfrowl Note Edited: 0013599
2006-10-10 14:54 ryandesign Note Added: 0013600
2006-10-10 15:00 renfrowl Note Added: 0013601
2007-02-15 05:02 darkfader Note Added: 0014050
2007-03-12 23:50 vboctor Note Edited: 0013597
2019-03-27 12:24 dregad Assigned To => dregad
2019-03-27 12:24 dregad Status new => resolved
2019-03-27 12:24 dregad Resolution open => no change required
2019-03-27 12:24 dregad Note Added: 0061787
2019-04-13 17:59 atrol Status resolved => closed