Search found 53 matches

by TomR
May 29, 2018 7:50 am
Forum: Help
Topic: Connection via URL with user/password
Replies: 1
Views: 692

Re: Connection via URL with user/password

In version1.2.x it is possible, but I did not find a solution form v2.x.x

See also https://mantisbt.org/forums/viewtopic.php?f=3&t=25513
by TomR
May 29, 2018 7:34 am
Forum: Help
Topic: Login with API Key in parameter
Replies: 4
Views: 1706

Re: Login with API Key in parameter

Another friendly bump. :D

Can anyone help me out. This is stopping us to migrate to version 2.x.x.

How can we achive auto-login ( with parameters username en password in v1.2.x ) in v2.x.x.
No LDAP available :(
by TomR
Apr 26, 2018 8:59 am
Forum: Help
Topic: Login with API Key in parameter
Replies: 4
Views: 1706

Re: Login with API Key in parameter

Friendly 'bump'. :)

Anyone who can help me get in the right direction?
by TomR
Apr 22, 2018 5:15 am
Forum: Help
Topic: Login with API Key in parameter
Replies: 4
Views: 1706

Re: Login with API Key in parameter

I guess I am really missing something here 8O I want to use https://mymantisbturl/?username=xxx from an external application. Really need no authorization as I will check if the originate from our cloud environment ( that works ). But definitely want to separate users Why is it showing me the defaul...
by TomR
Apr 21, 2018 3:34 pm
Forum: Help
Topic: Login with API Key in parameter
Replies: 4
Views: 1706

Login with API Key in parameter

We want to login from an external application into MantisBT. I looked at the SampleAuth plugin to accomplish that. The plugins is working fine, except it poses a security risc. If you guess a username, one can login without problems with someone elses account. I wonder what would be a feasible use c...
by TomR
Nov 15, 2017 7:33 am
Forum: Help
Topic: Dokuwiki integration CSP errors after upgrade
Replies: 2
Views: 1710

Re: Dokuwiki integration CSP errors after upgrade

https://www.mantisbt.org/bugs/view.php?id=19576 seems to solve the problem,
But that effectively disables CSP al together which seems a bit drastic.

In config_inc.php

Code: Select all

$g_custom_headers = array( 'Content-Security-Policy:' );
by TomR
Nov 15, 2017 4:43 am
Forum: Help
Topic: Automatically Login on load site
Replies: 1
Views: 1057

Re: Automatically Login on load site

Solution for for 2.

In config_inc.php

Code: Select all

$g_default_home_page = 'changelog_page.php'; 
by TomR
Nov 14, 2017 11:01 am
Forum: Help
Topic: Dokuwiki integration CSP errors after upgrade
Replies: 2
Views: 1710

Dokuwiki integration CSP errors after upgrade

Dokuwiki integration gives all kind of CSP errors after upgrade 1.2.20 -> 2.x

Upgrading from 1.2.20 to version 2.x leads to a lot of CSP errors when opening wiki pages with wiki integration from MantisBT
by TomR
Aug 07, 2017 3:55 am
Forum: Help
Topic: Unable to add an issue in MantisBT bugtracker
Replies: 1
Views: 1294

Unable to add an issue in MantisBT bugtracker

I always get an Appliction Error #2800. I tried different browsers, different computers. Cleared cookies, history etc. There are a few things I want to enter in the MantisBT bugtracker. Main issue I have is in the Wiki integration ( DokuWiki ). After upgrading 1.2.20 -> 2.5.1 I get all kinds of CSP ...
by TomR
Jan 10, 2017 9:31 am
Forum: Help
Topic: Black graphs on Mantis 1.3 ?
Replies: 23
Views: 18106

Re: Black graphs on Mantis 1.3 ?

A solution is indeed to copy your fonts to library/font directory and put that in config_inc.php :D

For some reason unknown to me /usr/share/fonts/msttcore is not working anymore in config_inc.php
by TomR
Sep 23, 2016 3:35 pm
Forum: Help
Topic: Black graphs on Mantis 1.3 ?
Replies: 23
Views: 18106

Re: Black graphs on Mantis 1.3 ?

Hi, sorry took some time.

I did a fresh install of MantisBT 1.3.1 as well as MantisBT 2.0.0.beta2
Installed Standard Graphics plugin.

Same problem in both environments. :(

What else can I look for?
by TomR
Sep 15, 2016 6:07 am
Forum: Help
Topic: Black graphs on Mantis 1.3 ?
Replies: 23
Views: 18106

Re: Black graphs on Mantis 1.3 ?

@Atrol, thanks for removing upload .html. I don't know what I was think last night. 8O As a matter of fact the company logo is one thing, the second logo should be the logo of TeamViewer. Both are set in custom_header_inc.php That worked fine on 1.2.19 ( no inline issues there ). For now I removed t...
by TomR
Sep 14, 2016 2:59 pm
Forum: Help
Topic: Black graphs on Mantis 1.3 ?
Replies: 23
Views: 18106

Re: Black graphs on Mantis 1.3 ?

Google Chrome on Win7 ( bTW - same problem on IE11) No 3rd-party plugins. ( yet, I plan to use the same as now in 1.2.19 ) uploaded .html and screenshot Added Google Developer Tools screenshot On a 2.0.0-beta2 installation I also do not see any graphs ( however no black square ). Google Developer To...
by TomR
Sep 08, 2016 7:36 am
Forum: Help
Topic: Black graphs on Mantis 1.3 ?
Replies: 23
Views: 18106

Re: Black graphs on Mantis 1.3 ?

Same problem here as described above. I upgraded 1.2.19 to 1.3.1 admin/check/index.php only give some warnings ( not related to graphs ) No errors in webserver logs Installed msttcorefonts Right-click open link in new tab: same black square! Error shown when inspection of element: Refused to apply i...
by TomR
Mar 23, 2016 4:35 pm
Forum: Customizations
Topic: Hyperlink to bug id in Excel export
Replies: 1
Views: 4446

SOLVED Re: Hyperlink to bug id in Excel export

Figured that one out my self years ago. Change function in core/excel_api.php # Changed to export a link to Excel function excel_format_id( $p_bug ) { $t_url = config_get( 'path' ); $t_url = htmlspecialchars( $t_url ); $t_value = "<Cell ss:HRef=\"" . $t_url . "view.php?id=" . $p_bug->id . "\">" . "<...