Search found 14 matches

by obmsch
Apr 05, 2019 3:53 am
Forum: General Discussion
Topic: Connection to SQL Server 2017 Express
Replies: 9
Views: 1421

Re: Connection to SQL Server 2017 Express

As I said in my previous post, login to SSMS with 'Windows Authentication' to manage/configure your instance. Users are under 'Security->Logins'. You can change any property (including pwd) of a user from there. And before you come back with the next basic question how to configure/manage your datab...
by obmsch
Apr 02, 2019 10:55 am
Forum: General Discussion
Topic: Connection to SQL Server 2017 Express
Replies: 9
Views: 1421

Re: Connection to SQL Server 2017 Express

Are you sure - your SQL Server Instance is running in mixed mode? - that user 'SA_Mantis' exists? - the password is correct? Try to connect with this credentials in SSMS. Make sure, that in the authentication dropdown 'Sql Server Authentication' is selected. This is just for testing. Switch back to ...
by obmsch
Mar 14, 2019 5:08 am
Forum: General Discussion
Topic: Connection to SQL Server 2017 Express
Replies: 9
Views: 1421

Re: Connection to SQL Server 2017 Express

I didn't talk about PHP versions, but the version of the php extension to access a specific database (SQL Server in your case). I only warned you to not use the latest release (5.6.0) there, but to take an older (5.3.0) one. All prerequisites, installation instructions and appropriate links are on h...
by obmsch
Mar 06, 2019 6:31 pm
Forum: General Discussion
Topic: Connection to SQL Server 2017 Express
Replies: 9
Views: 1421

Re: Connection to SQL Server 2017 Express

That link is pretty old, and a lot of things have improved on the MantisBT side with SQLServer. The current version (2.19.0) should install out of the box, if the prerequisites are fulfilled ( https://github.com/Microsoft/msphpsql ). As the latest driver (5.6.0) has a serious bug ( https://github.co...
by obmsch
Oct 19, 2018 3:00 am
Forum: General Discussion
Topic: PHP/SQLServer/MySQL
Replies: 6
Views: 1760

Re: PHP/SQLServer/MySQL

Looks like a start up issue with SQL Server Agent. Please check a) The SQL Server ERRORLOG and if present the SQLAgent.out file b) The windows event log (both application and system), if there are any entries around the time your error occurred That might reveal enough information about the exact ca...
by obmsch
May 24, 2018 2:21 am
Forum: General Discussion
Topic: PHP/SQLServer/MySQL
Replies: 6
Views: 1760

Re: PHP/SQLServer/MySQL

changed IIS to use PHP 7.1 ... Database connection failed. Error received from database was #0: PHP Support for database is not enabled Have you installed/enabled the appropriate driver (extension) in php? For recent releases: https://github.com/Microsoft/msphpsql/releases Make sure the prerequisit...
by obmsch
Nov 09, 2017 7:22 pm
Forum: General Discussion
Topic: Version running on mantisbt.org
Replies: 3
Views: 1320

Re: Version running on mantisbt.org

So that's a regression introduced with 2.8, but there are 2.6 and 2.7. Despite of the additional effort that would put on the spare time of the core developers, I would recommend to keep org in sync with the latest release. Step back to latest stable if regressions require that. Fix as soon as possi...
by obmsch
Nov 09, 2017 2:43 pm
Forum: General Discussion
Topic: Version running on mantisbt.org
Replies: 3
Views: 1320

Version running on mantisbt.org

With the release of MantisBT 2.8, your own Tracker (still 2.5.1-master-...) is way behind.
Makes me wonder if that's a simple oversight or anything else stops you from upgrading.
In any case I would feel more confident installing a new release, if org runs that too.

Martin
by obmsch
Jul 06, 2017 7:52 am
Forum: General Discussion
Topic: Could not open a connection to SQL Server
Replies: 4
Views: 3571

Re: Could not open a connection to SQL Server

This is from my working config_inc.php: # SQL Server 2012 Express/win7-32/IIS7/PHP7.1.6/ODBC-Driver 11/SQL-Driver 4.2 # $g_hostname = 'localhost\SQLEXPRESS'; # SQL Server 2016 Express/win10-64/IIS10/PHP7.1.6/ODBC-Driver 13/SQL-Driver 4.3 $g_hostname = 'MS-2\SQLEXPRESS'; $g_db_type = 'mssqlnative'; $...
by obmsch
Mar 30, 2017 1:44 pm
Forum: Help
Topic: Mantis SVN source control integration
Replies: 2
Views: 3303

Re: Mantis SVN source control integratio

Still an issue? If yes, what is the: SVN client version? SVN server version? Output of "svn info url --xml" from cmd? Make sure you use the same svn ($svn, there might be others in the path) and url=$t_url. Is the xml from (3) Ok? Just to make sure this is a plugin issue and not a problem with svn a...
by obmsch
Sep 22, 2016 1:25 am
Forum: Help
Topic: Not able to upgrade to v1.3.1 from v1.2
Replies: 5
Views: 3354

Re: Not able to upgrade to v1.3.1 from v1.2

I have used the native drivers from the get go, so I wasn't affected by the change dregad mentioned about adodb between 1.2 and 1.3. You should use "$g_db_type = 'mssqlnative'" and the appropriate drivers(extensions) from MS. Depending on your OS, SQLServer version, PHP version, http server there ar...
by obmsch
Sep 20, 2016 7:31 am
Forum: Help
Topic: Not able to upgrade to v1.3.1 from v1.2
Replies: 5
Views: 3354

Re: Not able to upgrade to v1.3.1 from v1.2

Hi Kris, you have a running 1.2 with all the necessary settings in 'config_inc.php'. Move that to the subdir 'config' (new location in 1.3 for config files). Add an entry (change the value!) $g_crypto_master_salt = '1234567890123456'; # Random string of at least 16 chars, unique to the installation ...
by obmsch
Mar 27, 2013 5:26 pm
Forum: General Discussion
Topic: Mantis on IIS/MSSQL
Replies: 3
Views: 9702

Re: Mantis on IIS/MSSQL

Cas,
no corporate standards (I'am a freelancer) or performance issues. But after more than 25 years in the DOS/Windows world,
I thought it would be easier to tackle any problem on a very known platform. And I still think it was the right decision for me.
Martin
by obmsch
Mar 26, 2013 5:29 pm
Forum: General Discussion
Topic: Mantis on IIS/MSSQL
Replies: 3
Views: 9702

Re: Mantis on IIS/MSSQL

I managed to get the following config running: Windows 7 Prof SP1(32) - All Updates/Fixes applied (Locale: de-DE) IIS 7.5 PHP 5.4.9 MantisBT 1.2.14 (Locale: Default) SI-Plugins (VCS 0.18, SVN 0.16, WebSVN 0.17) WebSVN 2.3.3 SQLServer Express 2012 (SP1) Subversion 1.7.8 TortoiseSVN 1.7.11 But believe...