Search found 4 matches

by wutsdis
16 Sep 2019, 15:43
Forum: Help
Topic: REST API is not working
Replies: 10
Views: 7588

Re: REST API is not working

Hello, I have a similar problem with the REST API returning an error 404. The server is on Ubuntu 18.04 with Apache 2.4 and php7.3, mantisBT 2.21.1. When I test it locally with the same apache, php and mantis versions with XAMPP on windows - it is working without any problems. I tried a Virtual Mach...
by wutsdis
11 Sep 2019, 13:02
Forum: Help
Topic: SVG not displayed inline
Replies: 1
Views: 1294

Re: SVG not displayed inline

I see that for the attached SVG images the ["file_type"]=> string(10) "text/plain" and for JPGs it is ["file_type"]=> string(6) "binary" . I have tried to modify it when an SVG is present and set $p_attachment['file_type'] = 'binary'; but still no change even ...
by wutsdis
22 Aug 2019, 16:13
Forum: Customizations
Topic: Sort Assigned to Me (Unresolved) in My View
Replies: 0
Views: 3445

Sort Assigned to Me (Unresolved) in My View

We have a very useful mod that sorts your assigned issues by always putting the ones with higher priority on the top. Our mantis is extremely old (version 1.1.0) and I'm wondering how could this be achieved in the latest version? We have changed the sorting by adding 'sort' => 'priority', in my_view...
by wutsdis
22 Aug 2019, 13:53
Forum: Help
Topic: SVG not displayed inline
Replies: 1
Views: 1294

SVG not displayed inline

Hello, Software used on the server is mantisbt-2.21.1, php-7.3, mariaDB10.4, apache2.4 For some reason, the attached SVG images are not shown. The attachments are stored on the DISK. In conifg_inc.php I have added $g_preview_image_extensions = array('bmp', 'png', 'gif', 'jpg', 'jpeg', 'svg'); Is the...