Application Error #100

MantisBT forum for users who prefer to ask and answer questions in French.

Moderators: Developer, Contributor

Post Reply
Sabbasth
Posts: 2
Joined: Sep 11, 2012 9:13 am

Application Error #100

Post by Sabbasth »

Bonjour,

Lorsqu'un utilisateur essaie de modifier une préférence dans son profil, l'erreur suivante apparait :

Code: Select all

APPLICATION WARNING #100: L'option de configuration « » n'a pas été trouvé.

Code: Select all

Échec de la requête de base de données. L'erreur renvoyée par la base de données était #1064 : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '0 = NULL
WHERE user_id=330 AND project_id=0' at line 2 pour la requête : UPDATE mantis_user_pref_table
SET 0 = ?
WHERE user_id=? AND project_id=?.
Le problème étant que comme l'option de configuration est vide je ne sais pas où chercher.

Voici les informations de version (apparemment correctes) :

Code: Select all

Version de MantisBT	1.2.11
Version du schéma	183
J'ai tenté de re-éxécuter le script d'update, tout se passe bien mais le problème persiste.
J'ai refait une installation de mantis, tout se passe bien mais le problème persiste.

Je ne sais pas trop quoi faire d'autre pour avancer.

Merci,
Bastien Semene

Lapinkiller
Posts: 408
Joined: Jan 28, 2011 1:47 pm
Location: France
Contact:

Re: Application Error #100

Post by Lapinkiller »

Bonjour,

Tu as donc fait une mise à jour depuis une ancienne version ? si oui depuis quelle version ?
Des modifications dans le code hormis le fichier de conf, ont elles été faites ?

quelles sont les version de PHP et MySQL sur ton serveur?

cela le fait pour tous les utilisateurs ?
Lapinkiller,
French PHP developer
New look for your mantis : http://www.mantisbt.org/forums/viewtopi ... =4&t=20055

Sabbasth
Posts: 2
Joined: Sep 11, 2012 9:13 am

Re: Application Error #100

Post by Sabbasth »

Lapinkiller wrote:Tu as donc fait une mise à jour depuis une ancienne version ? si oui depuis quelle version ?
La mise à jour date de plusieurs semaines. Je ne me rappelle plus quelle était cette version.
Le problème n'a pas été vu de suite.
j'étais en 1.2.X c'est sûr, mais je ne sais plus laquelle exactement.
Lapinkiller wrote:Des modifications dans le code hormis le fichier de conf, ont elles été faites ?
Oui,
custom_strings_inc.php pour la traduction d'ajouts à la liste de résolution ($g_resolution_enum_string) dans le fichier de conf.

Donc pour répondre plus clairement à la question uniquement custom_strings_inc.php
Lapinkiller wrote:quelles sont les version de PHP et MySQL sur ton serveur?

Code: Select all

PHP 5.4.4 (cli) (built: Aug 22 2012 13:37:45)
Copyright (c) 1997-2012 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2012 Zend Technologies

Code: Select all

Server version: 5.0.27-max MySQL Community Edition - Experimental (GPL)
Lapinkiller wrote:cela le fait pour tous les utilisateurs ?
Oui.

Post Reply