Configuration de AD avec LDAP

MantisBT forum for users who prefer to ask and answer questions in French.

Moderators: Developer, Contributor

Post Reply
fabpan
Posts: 9
Joined: Jan 20, 2016 9:28 am

Configuration de AD avec LDAP

Post by fabpan » Jan 29, 2016 3:00 am

Bonjour,

Je lance un appel d'aide à ceux qui maitrisent le protocole LDAP sur Mantis.

Cela fait plusieurs jours que je tente de faire fonctioner ce protocole sans succéss et j'avoue être un peu perdu.

Sur mon serveur AD j'ai un utilisateur (CN=Prénom Nom) qui se trouve dans OU=LGE. En dehors de Mantis nous utilisons le SN de l'utilisateur pour se connecter (son pseudo pour faire simple).


J'ai créé cet utilisateur dans Mantis via un compte en nomant ce compte avec son pseudo ou sn pour m'exprimer en langage AD (Peut-être dois-je créer ce compte dans Mantis avec le full name).

Ensuite j'ai configuré le fichier Config_inc_.php comme ceci:


#-- LDAP --
$g_login_method = LDAP;
$g_ldap_server = 'ldap://CTI01.mycompany.home';
$g_ldap_port = '389';
$g_ldap_root_dn = 'OU=LGE, DC=mycompany, DC=home';
$g_ldap_organization = '';
$g_ldap_follow_referrals = OFF;
$g_ldap_bind_dn = 'CN=Prenom Nom, OU=LGE, DC=mycompany, DC=home';
$g_ldap_bind_password = 'userpassword'; // Ici j'ai beaucoup de confusion car certains me disent que c'est le mot de passe utilisateur et d'autres que c'est le mot de passe du serveur AD ????
$g_use_ldap_realname = ON;
$g_ldap_realname_field = 'sn'; // Faut-il utiliser CN a la place ???? car je voudrais utiliser le pseudo

# --- Active directory --
$g_ldap_protocol_version = 3;
$g_ldap_uid_field = 'sAMAccountName';
$g_use_ldap_email = OFF;


J'ai bien entendu un fichier LOG:

2016-01-29 08:31 CET ldap t_ldap_root_dn:OU=LGE, DC=mycompany, DC=home
2016-01-29 08:31 CET ldap Binding to LDAP server p_username=userpseudo p_password=userpassword
2016-01-29 08:31 CET ldap Binding to LDAP server
2016-01-29 08:31 CET ldap Attempting connection to LDAP URI 'ldap://CTI01.mycompany.home'.
2016-01-29 08:31 CET ldap Connection accepted by LDAP server
2016-01-29 08:31 CET ldap Setting LDAP protocol version to 3
2016-01-29 08:31 CET ldap Setting LDAP follow_referrals to 0
2016-01-29 08:31 CET ldap BINDING: p_binddn & p_password are blank()
2016-01-29 08:31 CET ldap BINDING: p_binddn:CN=Prenom Nom, OU=LGE, DC=mycompany, DC=home p_password:
2016-01-29 08:31 CET ldap Attempting anonymous bind to ldap server
2016-01-29 08:31 CET ldap Bind to ldap server successful
2016-01-29 08:31 CET ldap Searching for (&(sAMAccountName=userpseudo))
2016-01-29 08:31 CET ldap Arguments t_ldap_root_dn:OU=LGE, DC=mycompany, DC=home t_search_filter:(&(sAMAccountName=userpseudo)) t_search_attrs:Array
2016-01-29 08:31 CET ldap ERROR #1: Operations error
2016-01-29 08:31 CET ldap ldap search failed

Voilà j'espere que vous pourrez m'aider à m'en sortir car j'ai vraiment envie de trouver un solution à ce problème.

Merci d'avance à tout ceux qui m'aideront.

ldapbt
Posts: 2
Joined: Apr 09, 2016 3:48 pm
Location: Sud est
Contact:

Re: Configuration de AD avec LDAP

Post by ldapbt » Apr 09, 2016 4:32 pm

Bonsoir,

J'ai essayé pas mal de chose et entre autre de configurer mantisBT en LDAP sous Débian. Premièrement, il faut bien configurer son serveur LDAP; avez-vous configuré tous les fichiers du serveur LDAP? Vérifiez par rapport à la liste suivante:
[*]/etc/default/slapd
[*]/etc/ldap/slapd.conf
[*]/etc/rsyslog.d/slapdlog.conf
[*]www/mantisbt/config.inc.php

Pour mon cas, j'ai un serveur LDAP
wheezyserver.com
. J'ai créé un utilisateur
useradmin
dans l'annuaire LDAP. Ensuite j'ai configuré le fichier
/etc/ldap/slapd.conf
pour donner un accès en lecture à
useradmin
J'ai vérifié que je pouvais faire des recherches utilisateurs dans l'annuaire grâce à cet utilisateur
l

Code: Select all

dapsearch -v -D "uid=useradmin,cn=BUC,dc=wheezyserver,dc=com" -w 'MDP' -H ldap://wheezyserver.com -b "cn=BE,cn=BUC,dc=wheezyserver,dc=com"
Normalement tu devrais voir apparaître une réponse serveur

Code: Select all

ldap_initialize( ldap://wheezyserver.com:389/??base )
filter: (objectclass=*)
requesting: All userApplication attributes
# extended LDIF
#
# LDAPv3
# base <cn=BE,cn=BUC,dc=wheezyserver,dc=com> with scope subtree
# filter: (objectclass=*)
# requesting: ALL
#

# BE, BUC, wheezyserver.com
dn: cn=BE,cn=BUC,dc=wheezyserver,dc=com
gidNumber: 501
cn: BE
objectClass: posixGroup
objectClass: top
description:: QnVyZWF1IGQnRXR1ZGUgcXVpIHJlZ3JvdXBlIHRvdXMgbGVzIGNvcnBzIGRlIG3D
 qXRpZXIgdGVjaG5pcXVlcyAoc3VwcG9ydCwgTcOpY2FuaXF1ZSwgRWxlY3Ryb25pcXVlLCBMb2dpY
 2llbCk=

# toto, BE, BUC, wheezyserver.com
BLABLABLA ....

# userserver, BE, BUC, wheezyserver.com
BLABLABAL ...

# search result
search: 2
result: 0 Success

# numResponses: 4
# numEntries: 3
Si tu as configurer le fichier
/etc/rsyslog.d/slapdlog.conf
avec les lignes de codes suivantes:

Code: Select all

#syslog.conf
#fichier de configuration de syslog qui est inclue par rsyslog.conf
local4.*	/var/log/slapd.log
Tu devrais voir tes connexions et requêtes sur le serveur LDAP, du type:

Code: Select all

Apr  9 22:25:58 WheezyServer slapd[5187]: conn=1016 fd=12 ACCEPT from IP=[::1]:40577 (IP=[::]:389)
Apr  9 22:25:58 WheezyServer slapd[5187]: conn=1016 op=0 BIND dn="uid=useradmin,cn=BUC,dc=wheezyserver,dc=com" method=128
Apr  9 22:25:58 WheezyServer slapd[5187]: conn=1016 op=0 BIND dn="uid=useradmin,cn=BUC,dc=wheezyserver,dc=com" mech=SIMPLE ssf=0
Apr  9 22:25:58 WheezyServer slapd[5187]: conn=1016 op=0 RESULT tag=97 err=0 text=
Apr  9 22:25:58 WheezyServer slapd[5187]: conn=1016 op=1 SRCH base="cn=BE,cn=BUC,dc=wheezyserver,dc=com" scope=2 deref=0 filter="(&(uid=administrator))"
Apr  9 22:25:58 WheezyServer slapd[5187]: conn=1016 op=1 SRCH attr=uid dn
Apr  9 22:25:58 WheezyServer slapd[5187]: conn=1016 op=1 SEARCH RESULT tag=101 err=0 nentries=0 text=
Apr  9 22:25:58 WheezyServer slapd[5187]: conn=1016 op=2 UNBIND
Apr  9 22:25:58 WheezyServer slapd[5187]: conn=1016 fd=12 closed
Jusque là tu pourras dire que ton serveur LDAP est opérationnel; si tu as un soucis je connais bien OpenLDAP pour y avoir passé des heures.
Enfin dans la configuration du fichier
www/mantisbt/config.inc.php
tu devrais avoir la configuration suivante:

Code: Select all

$g_login_method = LDAP;
$g_reauthentication = ON;
$g_reauthentication_expiry = 600;
$g_ldap_server = 'ldap://localhost:389';
$g_ldap_root_dn = 'CN=BE,CN=BUC,DC=wheezyserver,DC=com';
#filtre d'organisation LDAP
$g_ldap_organization =  '';
$g_ldap_protocol_version = 3;
$g_ldap_follow_referrals = ON;
$g_ldap_bind_dn = 'UID=useradmin,CN=BUC,DC=wheezyserver,DC=com';
$g_ldap_bind_passwd = 'Mot de passe';
$g_use_ldap_realname = ON;
$g_use_ldap_email = OFF;
$g_allow_blank_email = ON;
Le seul problème est que tu risques de perdre la configuratioon locale de ton compte administrateur par défaut de mantisBT.
Une vrai galère, j'ai essayé avec un compte administrator et sans compte dans OpenLDAP, compte avec différent noms, différents droits et rien n'y fait, tu ne pourras plus administrer mantisBT; Probablement un défaut de mantis. J'ai lu http://www.slideshare.net/elefevre/cour ... e-valtech/ que mantis ne gère pas le local et LDAP en même temps. Mais si tu as une :idea: , je suis preneur :wink:

Je pense que je vais passer à Redmine pour voir! Pour info Dotproject marche à merveille en LDAP

May the force be with you ...

Post Reply