EmailReporting Plugin Not fetching emails

This plugin allows you to report an issue in MantisBT by sending an email to a particular mail account

Moderators: Developer, Contributor

Post Reply
devesh
Posts: 1
Joined: Nov 12, 2018 5:49 am

EmailReporting Plugin Not fetching emails

Post by devesh » Nov 12, 2018 7:33 am

Hello all,

I am new to Mantis. I have set up Mantis 2.18.0 and Email Reporting 0.10.0 on Windows Server 2012 R2.
I am using an Office365 work account with the following config:

Enabled: Yes
Mailbox type: IMAP
Hostname: outlook.office365.com
TCP port: 993
connection encryption: SSL
Verify SSL certificate: Yes
Username: mantis@my-domain.com
Authentication method: USER
Basefolder:
Create project subfolder structure: Yes


When I do a "Complete Test", I am getting

"INTERNAL APPLICATION ERROR

Please use the "Back" button in your web browser to return to the previous page. There you can correct whatever problems were identified in this error or select another action. You can also click an option from the menu bar to go directly to a new section."

Also when I run "bug_report_mail.php" via command Prompt, i get the following:
D:\XamPP\php>php.exe D:\XamPP\htdocs\Mantis\plugins\EmailReporting\scripts\bug_report_mail.php
Start checking all mailboxes: Monday 12th of November 2018 13:30:07

array(14) {
["enabled"]=>
int(1)
["description"]=>
string(10) "Test"
["mailbox_type"]=>
string(4) "IMAP"
["hostname"]=>
string(27) "ssl://outlook.office365.com"
["port"]=>
int(993)
["encryption"]=>
string(3) "SSL"
["ssl_cert_verify"]=>
int(1)
["erp_username"]=>
string(28) "mantis@my-domain.com"
["erp_password"]=>
string(16) "***********=="
["auth_method"]=>
string(4) "USER"
["project_id"]=>
int(10)
["global_category_id"]=>
int(1)
["imap_basefolder"]=>
string(0) ""
["imap_createfolderstructure"]=>
int(1)
}

array(12) {
["enabled"]=>
int(1)
["description"]=>
string(0) ""
["mailbox_type"]=>
string(4) "POP3"
["hostname"]=>
string(0) ""
["port"]=>
int(110)
["encryption"]=>
string(4) "None"
["ssl_cert_verify"]=>
int(1)
["erp_username"]=>
string(0) ""
["erp_password"]=>
string(0) ""
["auth_method"]=>
string(4) "USER"
["project_id"]=>
int(10)
["global_category_id"]=>
int(1)
}

Mailbox:
Message: Failed to connect to the mail server




Done checking all mailboxes


Can someone guide me in the right direction to solve these issues please?
Thanks in advance for your help.

Kind regards,
Devesh

SL-Gundam
Posts: 567
Joined: Jul 06, 2011 9:17 am

Re: EmailReporting Plugin Not fetching emails

Post by SL-Gundam » Nov 13, 2018 10:51 am

1. You MUST upgrade to EmailReporting 0.10.1 - https://github.com/mantisbt-plugins/Ema ... ses/latest
This release fixes several issues. The most important changes are

- MantisBT dropped print_bracket_link in MantisBT 2.11. This required us to change some code so that the "Test" and "Complete test" functionality keeps working properly
- MantisBT 2.12 retired needed functions for realname validation. The validation had been removed from EmailReporting
For the rest all i can say: In theory your setup should work with EmailReporting 0.10.1. But Microsoft has a really buggy implementation of IMAP so no gaurantees.
We've already made multiple adjustments so that IMAP will work with Office365/Exchange. I believe it should but some people still have issues

So please let us know if it works for you. If not we will try to help you further

Post Reply