Plugin error - where do I start troubleshooting?

This plugin allows you to report an issue in MantisBT by sending an email to a particular mail account

Moderators: Developer, Contributor

Post Reply
mushu
Posts: 145
Joined: Jan 04, 2017 12:41 pm

Plugin error - where do I start troubleshooting?

Post by mushu » Jan 15, 2019 1:03 pm

Mantis 2.18.0
EmailReporting 0.10.0

I have separate DEV and PROD servers. When a new version is released we test on DEV and then promote to PROD if everything is fine after a week. I am trying to get it working on DEV server but the *exact* same files work fine on PROD server. Here is the error I am getting when doing the TEST mailbox function on DEV (it does not get the error on PROD):

Code: Select all

Operation successful

Description: developer bugs [DEV]
Mailbox type: POP3
Hostname: tlsv1.2://webmail.qq.local
TCP port (optional): 995
Connection encryption: TLSv1.2
Verify SSL certificate: 0
Username: svr\BugsMail
Password: ******
Authentication method: USER

Fatal error: Call to undefined function print_bracket_link() in C:\MantisBT2180\plugins\EmailReporting\pages\manage_mailbox_edit.php on line 97
The files are the same between DEV and PROD and I don't know where to look next. Thoughts?

mushu
Posts: 145
Joined: Jan 04, 2017 12:41 pm

Re: Plugin error - where do I start troubleshooting?

Post by mushu » Jan 15, 2019 2:19 pm

NEVER MIND - I just saw that there is a new version of the EmailReporting plugin that specifically fixes this weird "bracket" error. Updating now.

Post Reply