Page 1 of 1

Problem with login by email

Posted: Oct 31, 2017 9:20 am
by klappo
Hi,
I have enabled the email login option ($ g_email_login_enabled = ON;) but the users have accounts with addresses where the domain looks like: domainexample.network. I have checked that the problem is with the domain long and exactly with ".network"
The system only accepts 4 characters after dot, ie ".netw"
Example user@domainexample.netw is ok but user@domainexample.network is wrong and give me error "Your account may be disabled or blocked or the username/password you entered is incorrect."

Can anyone help?

Re: Problem with login by email

Posted: Oct 31, 2017 10:07 am
by atrol
You could deactivate e-mail validation by adding the following line to file config_inc.php

Code: Select all

$g_validate_email = OFF;

Re: Problem with login by email

Posted: Nov 07, 2017 10:40 am
by klappo
I checked that, this parametr has no effect on it, the problem still exists

Re: Problem with login by email

Posted: Dec 13, 2017 9:23 am
by klappo
Nobody has such a problem? Any other ideas?

Re: Problem with login by email

Posted: Dec 14, 2017 8:05 am
by rkarmann
Take a look at the email_api, you might be able to find out wich function is responsible for this issue.
--> Between line 90 and 190 (email validation functions, including regex)

Enable the LOG and you'll see how is user's email adress processed.