Page 1 of 1

Updating plugins wiki is needed

Posted: May 30, 2018 11:19 am
by mushu
Is there a central authority in charge of maintaining the plugins wiki at https://www.mantisbt.org/wiki/doku.php/ ... gins:start? There are several plugins that will only work in version 1.x of MantisBT and other links are broken, and even one link redirects to a potentially malicious website that tries to load a "search helper" browser extension. Not a good thing to allow Mantis to get any bad press for things like this. I don't have the time or knowledge of the plugins to be able to police this wiki, and hoping that someone can get in there and update it before something bad happens.

Also, are these the only plugins available for MantisBT? Or is there another place that lists more?

Re: Updating plugins wiki is needed

Posted: May 30, 2018 3:02 pm
by Starbuck
@Mushu - thanks for the note. There has been a lot of discussion about the plugins recently and we're trying to make that a much more visible and useful part of this ecosystem. Things are kinda in-flux now, but that's better than before.

A new General Plugins board has been created here specifically to document and discuss all of the plugins that we can identify. See my sig. I created a series of "About" posts, one for each plugin (not yet complete), where notes on the plugin status can be maintained. For issues with specific plugins, we should create new threads dedicated to the specific issue.

The wiki situation is a bit weird and I don't want to get into it right now. Suffice to say, your concerns are shared and we're trying to ensure that all information is available in the best way possible.

Re: Updating plugins wiki is needed

Posted: May 30, 2018 3:06 pm
by mushu
Thanks for the reply. The more serious concern is the potentially malicious browser extension that wants to be installed from the link to one of these Mantis plugins; that link needs to be removed because the original webpage redirects elsewhere.

Re: Updating plugins wiki is needed

Posted: May 30, 2018 3:17 pm
by atrol
Thanks @mushu for letting us know.
I removed the malicious link.

Let me know if I removed the right one (The Poser) or if there are even more malicious links.

Re: Updating plugins wiki is needed

Posted: May 30, 2018 3:19 pm
by mushu
I believe that was the only one that I found. Better safe than sorry!

Re: Updating plugins wiki is needed

Posted: May 30, 2018 3:20 pm
by atrol
mushu wrote:
May 30, 2018 11:19 am
Also, are these the only plugins available for MantisBT? Or is there another place that lists more?
There are certainly more, see https://www.mantisbt.org/wiki/doku.php/ ... pluginsitH
And I am pretty sure you will find even more when searching Github for Mantis and searching the web for Mantis plugins.

Re: Updating plugins wiki is needed

Posted: Jun 09, 2018 7:36 am
by LowellD
You're right, Atrol. I had no idea the plugin community is that big for Mantis. That's awesome.

Re: Updating plugins wiki is needed

Posted: Jun 09, 2018 1:47 pm
by Starbuck
Some confusion has been cleared up.
You'll see a lot of changes in the Plugins namespace in the wiki starting this month.

I really welcome all notes about plugins in the new Plugins>General Discussion area. Just slam whatever you have in there and I'll hit them all.
Please post notes on the status of whatever plugins you find, previously undocumented plugins, bad documentation, and of course bad links and links to malware.

If you find a MantisBT plugin developer that does not have representation in this ecosystem, please ask them to join the forum and post a note in the plugins area so we know they're there.

Thanks!!!