Mantis is slow

General discussion of Mantis.

Moderators: Developer, Contributor

shanthini
Posts: 25
Joined: Apr 10, 2010 7:01 am

Mantis is slow

Post by shanthini » Sep 18, 2018 2:05 am

We are using Mantis (Version: 2.15.0) for reporting bugs for the past few years. Reccentrly this seems to be very slow (Takes 30 to 40 seconds to close an issue). Currently the DB has nearly 60000 issues and 140 project.

Could you please suggest for a fix

Thanks

atrol
Site Admin
Posts: 7647
Joined: Mar 26, 2008 4:37 pm
Location: Germany

Re: Mantis is slow

Post by atrol » Sep 18, 2018 4:26 am

How long does it take to view a single issue?
When did it start to be slow?
Please use Search before posting and read the Manual

shanthini
Posts: 25
Joined: Apr 10, 2010 7:01 am

Re: Mantis is slow

Post by shanthini » Sep 18, 2018 5:51 am

Thanks. This is taking 30 to 40 seconds to close an issue

shanthini
Posts: 25
Joined: Apr 10, 2010 7:01 am

Re: Mantis is slow

Post by shanthini » Sep 18, 2018 5:53 am

Just now we noted that the RAM size is 512MB. Now we increased to 2GB. Hope it will work hereafter without issues.

shanthini
Posts: 25
Joined: Apr 10, 2010 7:01 am

Re: Mantis is slow

Post by shanthini » Sep 19, 2018 3:02 am

Hi atrol

After increasing the RAM also we are facing the same issue. We are using Mantis in our local network for reporting bugs. The DB size is 4.7GB. Currently the DB has nearly 60000 issues and 140 project.

Could you please suggest: Cane we disable the projects that are not in use to resolve this issue

Thanks

atrol
Site Admin
Posts: 7647
Joined: Mar 26, 2008 4:37 pm
Location: Germany

Re: Mantis is slow

Post by atrol » Sep 20, 2018 1:47 am

As a first step, you should answer my questions
atrol wrote:
Sep 18, 2018 4:26 am
How long does it take to view a single issue?
When did it start to be slow?
And some more questions:
Have you installed any plugins?
Do you use any custom functions?
Which PHP version, database version, operating system version do you use?


As a side note:
I assume your database size is quite hug because you store attachments in it.
You might consider to store attachments on filesystem.
But I do not expect that this will influence your performance issue.
Please use Search before posting and read the Manual

shanthini
Posts: 25
Joined: Apr 10, 2010 7:01 am

Re: Mantis is slow

Post by shanthini » Sep 20, 2018 2:38 am

Please find answers. I have attached the DB stats herewith. Thanks

How long does it take to view a single issue?
We are not facing issues while viewing

When did it start to be slow?
Takes more than a minute (Select two issues and closed in one shot)
6.55.17 AM– Close button hit
6.56.33 AM- Completed

Takes more than 40 seconds (Select a single issues and closed)
6.59.28 AM – Close button hit
7.00.11 AM - Completed


Have you installed any plugins?
The plugins installed are: Avatars via Gravatar 2.15.0, Import/Export issues 2.15.0, Mantis Graphs 2.15.0, MantisBT Core 2.15.0

Do you use any custom functions?
No

Which PHP version, database version, operating system version do you use?
PHP 5.5
MySQL 5.6
Windows server 2008 R2 Enterprise

shanthini
Posts: 25
Joined: Apr 10, 2010 7:01 am

Re: Mantis is slow

Post by shanthini » Sep 20, 2018 2:42 am

Attached the DB stats herewith
Attachments
MantisBT-DB-Statistics.png
MantisBT-DB-Statistics.png (183.81 KiB) Viewed 2660 times

atrol
Site Admin
Posts: 7647
Joined: Mar 26, 2008 4:37 pm
Location: Germany

Re: Mantis is slow

Post by atrol » Sep 20, 2018 4:13 am

The questions
When did it start to be slow?
is not meant that way.
Is it slow since yesterday, or last week, or last month ...?
When was it slow the first time?

Concernings Db statistics.
Your last rows shows "newrecords".
This is no Mantis table.
What is it?
Please use Search before posting and read the Manual

shanthini
Posts: 25
Joined: Apr 10, 2010 7:01 am

Re: Mantis is slow

Post by shanthini » Sep 20, 2018 4:52 am

Hi

When did it start to be slow?
-- Not sure exatctly, we are facing slowness from last week.

About 'newrecords' table
-- We are not using that table. I will delete that. By mistake this may be created

Thanks

atrol
Site Admin
Posts: 7647
Joined: Mar 26, 2008 4:37 pm
Location: Germany

Re: Mantis is slow

Post by atrol » Sep 21, 2018 2:28 am

Do you see a high CPU usage of any process in task manager of the server when closing an issue?

Is closing issue also slow when temporary deactivating e-mail notifications?
Add the following line to config_inc.php for it.

Code: Select all

$g_enable_email_notification	= OFF;
Please use Search before posting and read the Manual

shanthini
Posts: 25
Joined: Apr 10, 2010 7:01 am

Re: Mantis is slow

Post by shanthini » Sep 26, 2018 5:46 am

Dear Atrol,

When we included this line '$g_enable_email_notification = OFF;' we do not face the performance related issue and this is working fine. Actually we need to send mail notifications also. Could you please suggest on this.

Thanks

cas
Posts: 544
Joined: Mar 11, 2006 11:08 am
Contact:

Re: Mantis is slow

Post by cas » Sep 26, 2018 6:46 am

You can configure mantis to send out the mails using a cron job (linux) or a task (windows).
There is plenty of documentation around that process available.

shanthini
Posts: 25
Joined: Apr 10, 2010 7:01 am

Re: Mantis is slow

Post by shanthini » Sep 26, 2018 11:02 pm

Hi,

Thanks for your support

We have configured the script available in 'send_emails.php' inside 'scripts' folder using scheduler. Please suggest whether I need to set both

$g_enable_email_notification = ON;
$g_email_send_using_cronjob = ON;

We are using windows task scheduer for this

shanthini
Posts: 25
Joined: Apr 10, 2010 7:01 am

Re: Mantis is slow

Post by shanthini » Sep 26, 2018 11:13 pm

I tried this by below setting. Mails sending is working fine. But the performance issue still persists (loading slowly)

$g_enable_email_notification = ON;
$g_email_send_using_cronjob = ON;

I tried this by below setting. Mails sending is not working. But do not have performance issue.
$g_enable_email_notification = OFF;
$g_email_send_using_cronjob = ON;

Could you please suggest on this. Thanks

Post Reply