Webspace with no php.ini: memory_limit issue ???

General discussion of Mantis.

Moderators: Developer, Contributor

Post Reply
seppeltronics
Posts: 2
Joined: Nov 04, 2018 5:21 pm

Webspace with no php.ini: memory_limit issue ???

Post by seppeltronics » Nov 04, 2018 5:38 pm

Hello,

I just set up Mantis on my webserver/webspace, but I have the Failure:

„ memory_limit php.ini directive is at least equal to the post_max_size directive
The current value of the memory_limit directive is -1 bytes. This value needs to be at least equal to the post_max_size directive value of 67108864 bytes. „

The problem is, the managed webserver/webspace has no php.ini. I actually have never workes with PHP, so I do not know how to resolve that issue. I have put a php.ini file into the folder where Mantis is installed, but it did not help.

What can I do about it?

Thank you very much,

Best Regards,

Seppel

P.S. I've got two other warnings, but I would say they may not cause a problem?

register_argc_argv php.ini directive is disabled
This directive should be disabled to increase performance (it only affects PHP in CLI mode).

display_errors php.ini directive is disabled
For security reasons this directive should be disabled on all production and Internet facing servers.

atrol
Site Admin
Posts: 7682
Joined: Mar 26, 2008 4:37 pm
Location: Germany

Re: Webspace with no php.ini: memory_limit issue ???

Post by atrol » Nov 05, 2018 3:00 am

seppeltronics wrote:
Nov 04, 2018 5:38 pm

„ memory_limit php.ini directive is at least equal to the post_max_size directive
The current value of the memory_limit directive is -1 bytes. This value needs to be at least equal to the post_max_size directive value of 67108864 bytes. „
Known issue, https://www.mantisbt.org/bugs/view.php?id=21284
I will provide a fix for that.
Please use Search before posting and read the Manual

seppeltronics
Posts: 2
Joined: Nov 04, 2018 5:21 pm

Re: Webspace with no php.ini: memory_limit issue ???

Post by seppeltronics » Nov 05, 2018 12:57 pm

Hello,

I renamed the file from 'php.ini' to .user.ini and the failure was resolved. However I'm not sure if it really solved or just suppressed the failure.

Thank you very much.

Best Regards, Seppel

Post Reply