Date not displayed after upgrade from 1.1.6 to 1.3.18

General discussion of Mantis.

Moderators: Developer, Contributor

jasb
Posts: 17
Joined: Apr 04, 2019 4:42 pm

Date not displayed after upgrade from 1.1.6 to 1.3.18

Post by jasb » May 05, 2019 3:25 pm

Howdy,
I upgraded to the last 1.x version, 1.3.18 from 1.1.6.
Everything's fine so far, and i can now specify timezone in config, great.

But now I have two issues:

1,
my issues are all in 01-01-1970 as date of creation and update.

I still have access to the 1.1.6 install and it show's the date fine.
Am i missing something or it's needed something extra?
mantis_1.1.6.jpg
mantis_1.1.6.jpg (195.25 KiB) Viewed 1107 times
mantis_1.3.18.jpg
mantis_1.3.18.jpg (257.19 KiB) Viewed 1107 times
2,
Line breaks are not working in 1.3.18, in the old 1.1.6 works.

Check the attach's images.

Thanks in advanced,

jasb
Posts: 17
Joined: Apr 04, 2019 4:42 pm

Re: Date not displayed after upgrade from 1.1.6 to 1.3.18

Post by jasb » May 05, 2019 3:41 pm

Hum, checking the tables, not the order that is different, but the type of fields, for some how they're using different formats.
Can you help me with SQL's to convert, if this is whats needs to be fixed.

Current schema for mantis_bug_table:

CREATE TABLE `mantis_bug_table` (
`id` int(10) UNSIGNED NOT NULL,
`project_id` int(10) UNSIGNED NOT NULL DEFAULT '0',
`reporter_id` int(10) UNSIGNED NOT NULL DEFAULT '0',
`handler_id` int(10) UNSIGNED NOT NULL DEFAULT '0',
`duplicate_id` int(10) UNSIGNED NOT NULL DEFAULT '0',
`priority` smallint(6) NOT NULL DEFAULT '30',
`severity` smallint(6) NOT NULL DEFAULT '50',
`reproducibility` smallint(6) NOT NULL DEFAULT '10',
`status` smallint(6) NOT NULL DEFAULT '10',
`resolution` smallint(6) NOT NULL DEFAULT '10',
`projection` smallint(6) NOT NULL DEFAULT '10',
`category` varchar(64) NOT NULL DEFAULT '',
`date_submitted` datetime NOT NULL DEFAULT '1970-01-01 00:00:01',
`last_updated` datetime NOT NULL DEFAULT '1970-01-01 00:00:01',
`eta` smallint(6) NOT NULL DEFAULT '10',
`bug_text_id` int(10) UNSIGNED NOT NULL DEFAULT '0',
`os` varchar(32) NOT NULL DEFAULT '',
`os_build` varchar(32) NOT NULL DEFAULT '',
`platform` varchar(32) NOT NULL DEFAULT '',
`version` varchar(64) NOT NULL DEFAULT '',
`fixed_in_version` varchar(64) NOT NULL DEFAULT '',
`build` varchar(32) NOT NULL DEFAULT '',
`profile_id` int(10) UNSIGNED NOT NULL DEFAULT '0',
`view_state` smallint(6) NOT NULL DEFAULT '10',
`summary` varchar(128) NOT NULL DEFAULT '',
`sponsorship_total` int(11) NOT NULL DEFAULT '0',
`sticky` tinyint(4) NOT NULL DEFAULT '0',
`target_version` varchar(64) NOT NULL DEFAULT ''
) ENGINE=MyISAM DEFAULT CHARSET=utf8;

atrol
Site Admin
Posts: 7661
Joined: Mar 26, 2008 4:37 pm
Location: Germany

Re: Date not displayed after upgrade from 1.1.6 to 1.3.18

Post by atrol » May 05, 2019 4:19 pm

Dates should have been migrated to integer by the upgrade script.
https://github.com/mantisbt/mantisbt/bl ... a.php#L582
Please use Search before posting and read the Manual

jasb
Posts: 17
Joined: Apr 04, 2019 4:42 pm

Re: Date not displayed after upgrade from 1.1.6 to 1.3.18

Post by jasb » May 05, 2019 4:26 pm

Hi Atrol,

Thanks for your reply, for some reason it wasn't, i'll handle this manually, no problem, and will do a table by table check to confirm the schema for all of them.

And what about the newline issue, that appears ok in 1.1.6 and not in 1.3.18, do you have any suggestion?

atrol
Site Admin
Posts: 7661
Joined: Mar 26, 2008 4:37 pm
Location: Germany

Re: Date not displayed after upgrade from 1.1.6 to 1.3.18

Post by atrol » May 05, 2019 4:35 pm

What's the content of mantis_plugin_table ?
Please use Search before posting and read the Manual

jasb
Posts: 17
Joined: Apr 04, 2019 4:42 pm

Re: Date not displayed after upgrade from 1.1.6 to 1.3.18

Post by jasb » May 06, 2019 3:21 am

Thank you!!

There was no table!!!
Fixed, copy from the old db.

Sometimes i have this error when i click "view issues", what can it be?
[update]
when i click "view issues" or then i click the "ID" column to order,


SYSTEM ERROR
'Argument 1 passed to filter_ensure_valid_filter() must be of the type array, null given, called in /home/hosting/decimal.pt/bugs/core/filter_api.php on line 869 and defined' in '/home/hosting/decimal.pt/bugs/core/filter_api.php' line 486
Please use the "Back" button in your web browser to return to the previous page. There you can correct whatever problems were identified in this error or select another action. You can also click an option from the menu bar to go directly to a new section.

atrol
Site Admin
Posts: 7661
Joined: Mar 26, 2008 4:37 pm
Location: Germany

Re: Date not displayed after upgrade from 1.1.6 to 1.3.18

Post by atrol » May 06, 2019 5:19 am

jasb wrote:
May 06, 2019 3:21 am
There was no table!!!
Fixed, copy from the old db.
You will get problem after problem as there is obviously something complete wrong with your upgrade.
It seems you never run the upgrade script or it stopped because of errors.

Check the the result of

Code: Select all

SELECT value FROM mantis_config_table WHERE config_id = 'database_version';
It should be 209 after the upgrade.
If not, start from scratch using a copy of your 1.1 database.
Please use Search before posting and read the Manual

jasb
Posts: 17
Joined: Apr 04, 2019 4:42 pm

Re: Date not displayed after upgrade from 1.1.6 to 1.3.18

Post by jasb » May 06, 2019 5:25 am

I did a clean install of 1.3.18 and i'm comparing and adjusting every table/field manually, seems that my 1.1.6 install had some db problems also and never noticed it, it has about 11 years!!
Some fields were in wrong order also, not problematic as mantis seems to be specifying the fields, but i took the oportunity to make everything right.

I'll let you know the result after confirming the db schema,

atrol
Site Admin
Posts: 7661
Joined: Mar 26, 2008 4:37 pm
Location: Germany

Re: Date not displayed after upgrade from 1.1.6 to 1.3.18

Post by atrol » May 06, 2019 6:23 am

Changing the database schema is not enough.
You have also to migrate data the same way it's done by the upgrade script.
Please use Search before posting and read the Manual

jasb
Posts: 17
Joined: Apr 04, 2019 4:42 pm

Re: Date not displayed after upgrade from 1.1.6 to 1.3.18

Post by jasb » May 06, 2019 7:49 am

Atrol,

db version, 209.
My install even on 1.1.6 has some issue i'm aware of that, i'm just asking for help to have it all good.
I confirmed all tables, fields and converted all date fields with the unix_timestamp, everything's fine so far, dates are show'n ok.
Till now i just have that issue, when i try to order in the columns, where can i search for? maybe some parameter in the defaults or config_inc.php ?

atrol
Site Admin
Posts: 7661
Joined: Mar 26, 2008 4:37 pm
Location: Germany

Re: Date not displayed after upgrade from 1.1.6 to 1.3.18

Post by atrol » May 06, 2019 8:13 am

jasb wrote:
May 06, 2019 7:49 am
Till now i just have that issue, when i try to order in the columns, where can i search for?
As told before, you will encounter even more problems as adjusting the schema is not enough.
In this case, I assume that the problem is caused by filter data (mantis_filters_table) which has not been migrated.
You could delete your filters or try to reimplement what the upgrade script would have done.
https://github.com/mantisbt/mantisbt/bl ... i.php#L430
Please use Search before posting and read the Manual

jasb
Posts: 17
Joined: Apr 04, 2019 4:42 pm

Re: Date not displayed after upgrade from 1.1.6 to 1.3.18

Post by jasb » May 06, 2019 8:17 am

Got it, perfect now!!

Thanks Atrol, If i need anything else I'll let you know.

Jorge,

atrol
Site Admin
Posts: 7661
Joined: Mar 26, 2008 4:37 pm
Location: Germany

Re: Date not displayed after upgrade from 1.1.6 to 1.3.18

Post by atrol » May 06, 2019 8:30 am

BTW, what's the reason that you upgraded to 1.3.18 but not latest 2.x.x?
Please use Search before posting and read the Manual

jasb
Posts: 17
Joined: Apr 04, 2019 4:42 pm

Re: Date not displayed after upgrade from 1.1.6 to 1.3.18

Post by jasb » May 06, 2019 9:08 am

Atrol,

Don't get me wrong, Personally don't like the design of 2.x :(
But, this is me, i tried it in a clean install and so, it's cute, but i preffer the 1.x design of Mantis.

As i said, it's *just* my personal opinion,

atrol
Site Admin
Posts: 7661
Joined: Mar 26, 2008 4:37 pm
Location: Germany

Re: Date not displayed after upgrade from 1.1.6 to 1.3.18

Post by atrol » May 06, 2019 9:24 am

Understand.

I found that especially users who worked a very long time with the old design don't like the new design that much at first sight (including myself).
After working a while with the new design (and some of the new / improved functionalities) most of the users don't want to go back any longer.

What's your most annoying design change in 2.x?

Keep in mind that 1.3.x will just get updates for major security issues.
Please use Search before posting and read the Manual

Post Reply