Mantis Integration Error with klaros TCMS

General discussion of Mantis.

Moderators: Developer, Contributor

Post Reply
jax06
Posts: 4
Joined: 12 Nov 2020, 11:08

Mantis Integration Error with klaros TCMS

Post by jax06 »

I was trying to integrate to Mantis BT in Klaros Test Management System, but Mantis throws an exception while loging into it on Klaros interface.

Exception is described below:

com.itsolut.mantis.core.exception.MantisRemoteException: Error Type: SYSTEM NOTICE, Error Description: Array to string conversion

MantisBT Version 2.21.1
PHP Version 5.6.12
Database Driver mysqli
Database Version, Description 5.6.26, 5.6.26.

I have also attached the screen shot of error and windows console log.

Please help me to resolve this issue.
Attachments
Logfile.txt
(19.54 KiB) Downloaded 13 times
Mantis_integeration_error.png
Mantis_integeration_error.png (91.17 KiB) Viewed 352 times
atrol
Site Admin
Posts: 7881
Joined: 26 Mar 2008, 21:37
Location: Germany

Re: Mantis Integration Error with klaros TCMS

Post by atrol »

As a side note: The exception occurs in Klaros, and also the attached log is not from Mantis but Klaros.
I don't expect you will get help for this in the Mantis forum, but who knows ...
Please use Search before posting and read the Manual
jax06
Posts: 4
Joined: 12 Nov 2020, 11:08

Re: Mantis Integration Error with klaros TCMS

Post by jax06 »

Yes you are right, log attached is from Klaros but its related to Mantis BT that's why posted here.

I have posted same issue on Klaros forum before as well but still no luck then I cam here to seek the answer.
atrol
Site Admin
Posts: 7881
Joined: 26 Mar 2008, 21:37
Location: Germany

Re: Mantis Integration Error with klaros TCMS

Post by atrol »

Run admin/check/index.php to validate whether everything is setup correctly (you might have to restore the admin folder, as it's recommend to remove it after installation)

Check also your webserver / PHP log files for any error or warnings.

BTW 2.21.1 is outdated and comes with known security issues, so I recommend to upgrade to lastest stable version (2.24.3 at the moment)
Please use Search before posting and read the Manual
Post Reply