Error while sending email from the system...

Get help from other users here.

Moderators: Developer, Contributor

Post Reply
dexpro
Posts: 3
Joined: Jan 12, 2006 12:41 pm

Error while sending email from the system...

Post by dexpro »

I've PHPMAiler enabled and am using SMTP as the preferred method to send emails. When submitting a new bug or changing the bug or doing any sort of update - after submission I always get a blank page and no email is sent out where as the changes are posted in the database and when I hit the back button I see the changes posted already to the issue.

I made requisite changes as per the instructions in the PHP.INI and default_config_inc.php files. HAve setup the phpmailer class files in the php/includes directory. I am running WAMP.

Any help is greatly appreciated as this is getting greatly frustrating. :cry: :oops:

Code: Select all

SYSTEM WARNING: include_once(c:\php\includes;class.phpmailer.php) [<a href='function.include-once'>function.include-once</a>]: failed to open stream: No such file or directory

SYSTEM WARNING: include_once() [<a href='function.include'>function.include</a>]: Failed opening 'c:\php\includes;class.phpmailer.php' for inclusion (include_path='.;C:\php5\pear')


Fatal error: Class 'phpmailer' not found in C:\wamp\www\html\modules\mantis\core\email_api.php on line 615
Notice [PHP]: Object of class XoopsUser could not be converted to int in file C:\wamp\www\html\class\theme.php line 442
PHP Version:
5.1.2

MySQL Version:
5.0.18-nt

Server Software:
Apache/2.0.55 (Win32) PHP/5.1.2

User's Browser:
Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.1.4322)

thraxisp
Developer
Posts: 509
Joined: Feb 13, 2005 10:38 pm
Location: Ottawa, Canada
Contact:

Post by thraxisp »

From the error description, it appears that the path substitution in the include path is wrong. You didn't include the line(s) from the php.ini file that define this.

As an aside, this error doesn't seem to come from Mantis. Mantis includes the phpMailer software in a subdirectory and includes it directly.
--
Glenn Henshaw Logical Outcome Ltd.
Mantis developer and user w: http://www.logicaloutcome.ca

dexpro
Posts: 3
Joined: Jan 12, 2006 12:41 pm

Post by dexpro »

Okay, I was able to fix the path, and now I am getting the following error:

Code: Select all

SYSTEM WARNING: fsockopen() [<a href='function.fsockopen'>function.fsockopen</a>]: unable to connect to :26 (A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
)
PROBLEMS SENDING MAIL TO:
Mailer Error: Language string failed to load: connect_host
Notice [PHP]: Object of class XoopsUser could not be converted to int in file C:\wamp\www\html\class\theme.php line 442
I am able to connect to the SMTP server successfully using Telnet, also I tried with 26 port it didn't work either.

Help, please!! :oops:

Post Reply