Please read this if you have problems with emails

Get help from other users here.

Moderators: Contributor, Developer

M@rce
Posts: 99
Joined: May 05, 2011 3:46 pm
Location: Montevideo - Uruguay

Re: Please read this if you have problems with emails

Post by M@rce » Nov 24, 2011 9:22 am

Hi,
I resolved this issue replacing in defaults configuration this items:

$g_phpMailer_method = PHPMAILER_METHOD_SMTP;
$g_smtp_host = '222.33.444.555:25';

Regards.
"La inteligencia consiste no sólo en el conocimiento, sino también en la destreza de aplicar los conocimientos en la práctica."
Aristóteles

glennp
Posts: 7
Joined: Feb 08, 2012 11:51 am

Re: Please read this if you have problems with emails

Post by glennp » Feb 08, 2012 12:25 pm

This was extremely frustrating to make Mantis emails work. But it really wasn't a problem with PHP or Mantis. We have a web server and a mail server sitting behind the firewall with proper ports opened to the internet. When I need for these servers to talk to each other it MUST be through the internal network. In order to address one server from another server using the outside internet URL I have to update the hosts file linking the outside URL with the internal ip address. Once I added the "mail.xxxxxx.com" to the hosts file on the server where I installed Mantis it worked fine. I end up overlooking this every time!!!!

If you are trying to set up Mantis behind a firewall and can't seem to make it work, you might double check this. You WON'T receive any error messages.

mantis1
Posts: 12
Joined: Apr 09, 2012 5:45 am

Re: Please read this if you have problems with emails

Post by mantis1 » Apr 09, 2012 6:04 am

dientesverdes wrote:I tried everithing you said in this post, but mantis can't send email notifications.

Mantis, always, show this error

SYSTEM WARNING: stream_socket_enable_crypto() [streams.crypto]: this stream does not support SSL/crypto
I don't know what else i can do. Can you help me?

I apologize for my english, i'm from latinamerica so i do my best. :D

i am also getting the same problem and i am not able to get any mails .but when i changed
$g_smtp_connection_mode = 'tsl'; to the $g_smtp_connection_mode = 'ssl';
its saying your confirmation is sent to the your mail id but in my inbox no messages from mantis. I am not getting the actual problem
please someone help me out from this problem.

thank you all.

atrol
Site Admin
Posts: 7477
Joined: Mar 26, 2008 4:37 pm
Location: Germany

Re: Please read this if you have problems with emails

Post by atrol » Apr 09, 2012 7:48 am

Did you try all the steps under section
What to do if you still dont receive emails?
Especially did you check that the ssl extension is enabled?
Please use Search before posting and read the Manual

mantis1
Posts: 12
Joined: Apr 09, 2012 5:45 am

Re: Please read this if you have problems with emails

Post by mantis1 » Apr 09, 2012 7:55 am

atrol wrote:Did you try all the steps under section
What to do if you still dont receive emails?
Especially did you check that the ssl extension is enabled?

ssl extension in where i have to enable? means in which file?

thanks...

atrol
Site Admin
Posts: 7477
Joined: Mar 26, 2008 4:37 pm
Location: Germany

Re: Please read this if you have problems with emails

Post by atrol » Apr 09, 2012 8:18 am

mantis1 wrote: ssl extension in where i have to enable? means in which file?
That depends on your operationg environment.
For example the author of this topic explained this for XAMPP
- If you are using XAMPP then make sure you have enabled the openssl service by checking your /xampp/php/php.ini for the following line: extension=php_openssl.dll;
and also for WAMP
- If you are using WAMP server then make sure you have enabled the Apache >>Apache modules>>ssl_module AND PHP>>Php extensions>>php_openssl
Please use Search before posting and read the Manual

mantis1
Posts: 12
Joined: Apr 09, 2012 5:45 am

Re: Please read this if you have problems with emails

Post by mantis1 » Apr 09, 2012 9:10 am

atrol wrote:
mantis1 wrote: ssl extension in where i have to enable? means in which file?
That depends on your operationg environment.
For example the author of this topic explained this for XAMPP
- If you are using XAMPP then make sure you have enabled the openssl service by checking your /xampp/php/php.ini for the following line: extension=php_openssl.dll;
and also for WAMP
- If you are using WAMP server then make sure you have enabled the Apache >>Apache modules>>ssl_module AND PHP>>Php extensions>>php_openssl
Thanks for the reply

I am using xampp and in /xampp/php/php.ini, extension=php_openssl.dll; line was there already in that line its starting from ';' this symbol i have to remove this symbol for enabling or what please tell me.

atrol
Site Admin
Posts: 7477
Joined: Mar 26, 2008 4:37 pm
Location: Germany

Re: Please read this if you have problems with emails

Post by atrol » Apr 09, 2012 9:20 am

mantis1 wrote:';' this symbol i have to remove this symbol for enabling
Yes
Please use Search before posting and read the Manual

mantis1
Posts: 12
Joined: Apr 09, 2012 5:45 am

Re: Please read this if you have problems with emails

Post by mantis1 » Apr 10, 2012 5:29 am

atrol wrote:
mantis1 wrote:';' this symbol i have to remove this symbol for enabling
Yes
thanks for the replay,
But still i am not able to fix mail receiving problem, still i am not getting any mails .

this is my config_inc.php

<?php
$g_hostname = 'localhost';
$g_db_type = 'mysql';
$g_database_name = 'bugtracker';
$g_db_username = 'root';
$g_db_password = 'XXXXX';
$g_allow_signup = ON; //allows the users to sign up for a new account
$g_enable_email_notification = ON; //enables the email messages
$g_phpMailer_method = PHPMAILER_METHOD_SMTP;
$g_smtp_host = 'mail.gmail.com';
$g_smtp_connection_mode = 'ssl';
$g_smtp_port = 25;
$g_smtp_username = 'XXXXX@gmail.com'; //replace it with your gmail address
$g_smtp_password = 'XXXXXXXXXX'; //replace it with your gmail password
$g_administrator_email = 'root@localhost.com'; //this will be your administrator email address
$g_mail_receive_own = ON;
$g_phpMailer_method = 2;
?>

and same settings were there in config_defualts_inc.php
and in php.ini-development i have enable the extension=php_openssl.dll also.

please please help me....

thanks in advance.

istvanb
Posts: 226
Joined: Aug 22, 2010 4:00 pm

Re: Please read this if you have problems with emails

Post by istvanb » Apr 10, 2012 11:40 am

As its indicated in description the smtp port is NOT 25 for gmail. Try it with the one mentioned and check if you receive mails then.

Also delete "$g_phpMailer_method = 2;" since its redundant.

mantis1
Posts: 12
Joined: Apr 09, 2012 5:45 am

Re: Please read this if you have problems with emails

Post by mantis1 » Apr 12, 2012 8:55 am

istvanb wrote:As its indicated in description the smtp port is NOT 25 for gmail. Try it with the one mentioned and check if you receive mails then.

Also delete "$g_phpMailer_method = 2;" since its redundant.
thanks for the reply.

i have used 465 for the ssl and 587 for the tsl but still i am not getting any mails.
and when i used 465 with ssl its saying reset password is sent to your mail but in inbox nothing was there and
when i used 587 with tls i am getting this error.
[SYSTEM WARNING: stream_socket_enable_crypto() [streams.crypto]: this stream does not support SSL/crypto]

i am not getting what is this please please help me .

thanks in advanced,,

istvanb
Posts: 226
Joined: Aug 22, 2010 4:00 pm

Re: Please read this if you have problems with emails

Post by istvanb » Apr 12, 2012 9:10 am

Gmail will communicate on port tls 587 (not sure about ssl 465, but tls 587 work just fine for me). So you can try using port25, but it wont work for sure. I recommend to go with 587 because it works for sure, so dont change the lines you can find in the original post.

About the error message: have you performed these steps?
- If you are using XAMPP then make sure you have enabled the openssl service by checking your /xampp/php/php.ini for the following line: extension=php_openssl.dll; if it does not exist then shut down the http service, add the line and restart the http service.
- If you are using WAMP server then make sure you have enabled the Apache >>Apache modules>>ssl_module AND PHP>>Php extensions>>php_openssl

mantis1
Posts: 12
Joined: Apr 09, 2012 5:45 am

Re: Please read this if you have problems with emails

Post by mantis1 » Apr 12, 2012 9:31 am

istvanb wrote:Gmail will communicate on port tls 587 (not sure about ssl 465, but tls 587 work just fine for me). So you can try using port25, but it wont work for sure. I recommend to go with 587 because it works for sure, so dont change the lines you can find in the original post.

About the error message: have you performed these steps?
- If you are using XAMPP then make sure you have enabled the openssl service by checking your /xampp/php/php.ini for the following line: extension=php_openssl.dll; if it does not exist then shut down the http service, add the line and restart the http service.
- If you are using WAMP server then make sure you have enabled the Apache >>Apache modules>>ssl_module AND PHP>>Php extensions>>php_openssl

what is http service in this?

istvanb
Posts: 226
Joined: Aug 22, 2010 4:00 pm

Re: Please read this if you have problems with emails

Post by istvanb » Apr 12, 2012 9:44 am

so you didnt...

1, Start menu >>> Run
2, type: services.msc

shut down the Apache service (yeah I ASSUME you use xampp, since you havent mentioned. If you use something else you may shut down something else), make the changes, then restart the service. Probably you can do the same via the xampp control panel as well, but that sometimes has issues, while accessing the services directly always works for me.

mantis1
Posts: 12
Joined: Apr 09, 2012 5:45 am

Re: Please read this if you have problems with emails

Post by mantis1 » Apr 13, 2012 12:28 am

istvanb wrote:so you didnt...

1, Start menu >>> Run
2, type: services.msc

shut down the Apache service (yeah I ASSUME you use xampp, since you havent mentioned. If you use something else you may shut down something else), make the changes, then restart the service. Probably you can do the same via the xampp control panel as well, but that sometimes has issues, while accessing the services directly always works for me.
yes i am using xampp,
the services.msc is opening one window that has many thing in it,i have to start something or what in that,

and i am getting still this error

SYSTEM WARNING: stream_socket_enable_crypto() [streams.crypto]: this stream does not support SSL/crypto

and i have enable (means i have removed ';' this symbol) extension=php_openssl.dll in
/xampp/php/php.in-production and in /xampp/php/php.in-development

please help me,
and thanks for your reply,

Post Reply