Page 3 of 7

Re: Please read this if you have problems with emails

Posted: Apr 17, 2012 2:30 am
by mantis1
mantis1 wrote:
istvanb wrote:so you didnt...

1, Start menu >>> Run
2, type: services.msc

shut down the Apache service (yeah I ASSUME you use xampp, since you havent mentioned. If you use something else you may shut down something else), make the changes, then restart the service. Probably you can do the same via the xampp control panel as well, but that sometimes has issues, while accessing the services directly always works for me.
yes i am using xampp,
the services.msc is opening one window that has many thing in it,i have to start something or what in that, i am not getting .

and i am getting still this error

SYSTEM WARNING: stream_socket_enable_crypto() [streams.crypto]: this stream does not support SSL/crypto

and i have enable (means i have removed ';' this symbol) extension=php_openssl.dll in
/xampp/php/php.in-production and in /xampp/php/php.in-development

please help me,
and thanks for your reply,

Re: Please read this if you have problems with emails

Posted: Apr 17, 2012 3:10 am
by istvanb
You should shut down the apache service. Dont worry about it, I guess you have already rebooted your machine since then, so the change you made is effective by now. I assume you dont see the problem anymore. Let us know.

If you still see the problem, then please make sure you have tried everything mentioned in the original post, just to make sure we are facing a new type of problem here, and not something which could be resolved based on the already given information.

i-

Re: Please read this if you have problems with emails

Posted: Apr 17, 2012 4:35 am
by mantis1
istvanb wrote:You should shut down the apache service. Dont worry about it, I guess you have already rebooted your machine since then, so the change you made is effective by now. I assume you dont see the problem anymore. Let us know.

If you still see the problem, then please make sure you have tried everything mentioned in the original post, just to make sure we are facing a new type of problem here, and not something which could be resolved based on the already given information.

i-
thank for your reply,

i think some problem with
$g_smtp_host = 'smtp.gmail.com'; this line which is located in config_inc.php (located in: <XAMPP>\htdocs\mantis\)

because when ever i change gmail with some value its saying A confirmation request has been sent to the selected e-mail address.using this the user will be able to change the password.
but when i open my mail id there is no mail from mantis.

and if i wont change any thing in this $g_smtp_host = 'smtp.gmail.com'; which is located in config_inc.php (located in: <XAMPP>\htdocs\mantis\) then i am getting this error.

SYSTEM WARNING: stream_socket_enable_crypto() [streams.crypto]: this stream does not support SSL/crypto.
please help me.

Re: Please read this if you have problems with emails

Posted: Apr 17, 2012 5:35 am
by mantis1
mantis1 wrote:
istvanb wrote:You should shut down the apache service. Dont worry about it, I guess you have already rebooted your machine since then, so the change you made is effective by now. I assume you dont see the problem anymore. Let us know.

If you still see the problem, then please make sure you have tried everything mentioned in the original post, just to make sure we are facing a new type of problem here, and not something which could be resolved based on the already given information.

i-
thank for your reply,

i think some problem with
$g_smtp_host = 'smtp.gmail.com'; this line which is located in config_inc.php (located in: <XAMPP>\htdocs\mantis\)

because when ever i change gmail with some other value its saying A confirmation request has been sent to the selected e-mail address.using this the user will be able to change the password.
but when i open my mail id there is no mail from mantis.

and if i wont change any thing in this $g_smtp_host = 'smtp.gmail.com'; which is located in config_inc.php (located in: <XAMPP>\htdocs\mantis\) then i am getting this error.

SYSTEM WARNING: stream_socket_enable_crypto() [streams.crypto]: this stream does not support SSL/crypto.
please help me.

Re: Please read this if you have problems with emails

Posted: Apr 17, 2012 5:58 am
by istvanb
Hey,

there is no reason for sending your posts twice. Its up to you if you think there is a problem with the smtp line (as well as I was fine you trying port25 instead of a valid one), but it does not change the fact that it works fine. Just for your reference I changed my corporate settings to gmail again and it works without any issues.

You still have not answered the question if you have tried everything mentioned in the original post (and you can check as well the debug method mentioned in the next couple comments). I am not gonna babysit you thru this, so do your homework and then let us know whats the status. Please dont expect us to try everything what you have tried (as like port25 which is nonsense), just stick to the original instructions.

i-

Re: Please read this if you have problems with emails

Posted: Apr 27, 2012 2:08 am
by mantis1
istvanb wrote:Hey,

there is no reason for sending your posts twice. Its up to you if you think there is a problem with the smtp line (as well as I was fine you trying port25 instead of a valid one), but it does not change the fact that it works fine. Just for your reference I changed my corporate settings to gmail again and it works without any issues.

You still have not answered the question if you have tried everything mentioned in the original post (and you can check as well the debug method mentioned in the next couple comments). I am not gonna babysit you thru this, so do your homework and then let us know whats the status. Please dont expect us to try everything what you have tried (as like port25 which is nonsense), just stick to the original instructions.

i-

yes i have tried everything mentioned in original post. and with that i have resolved 'SYSTEM WARNING: stream_socket_enable_crypto() [streams.crypto]: this stream does not support SSL/crypto.' this error also now i am not getting this error.

but still i am not able to get a email. what to do for that.
please help me out from this..

thank you.

Re: Please read this if you have problems with emails

Posted: Apr 27, 2012 2:58 am
by atrol
http://lmgtfy.com/?q=SYSTEM+WARNING%3A+ ... ble_crypto()
Most of the answers show that php_openssl is missed.
So it seems that you still didn't succeed in enabling this extension.
You should use the XAMPP forum to get an answer for this.

Re: Please read this if you have problems with emails

Posted: Apr 27, 2012 9:40 am
by mantis1
atrol wrote:http://lmgtfy.com/?q=SYSTEM+WARNING%3A+ ... ble_crypto()
Most of the answers show that php_openssl is missed.
So it seems that you still didn't succeed in enabling this extension.
You should use the XAMPP forum to get an answer for this.
Thanks for the above link. now i am able to get a mails.

Re: Please read this if you have problems with emails

Posted: May 14, 2012 1:04 pm
by aimbire
So i followed the instructions correctly and did manage to get the email being sent from http://$MANTIS/_admin/test_email.php. - The administrator inbox gets the 'Testing PHP mail() function' accordingly, but that's it.

No other emails are being sent, new users, changed statuses or even password resets. Any idea what might be the follow? Below is my config_inc.php, with most of the values edit to prevent information to leak.
<?php
$g_hostname = 'hostname';
$g_db_type = 'dbtype;
$g_database_name = 'databasename';
$g_db_username = 'username';
$g_db_password = 'password';

$g_allow_signup = OFF;

$g_phpMailer_method = PHPMAILER_METHOD_SMTP;
$g_smtp_host = 'smtp.corporation.com';
$g_smtp_username = 'smtpusername@corporation.com';
$g_smtp_password = 'smtppassword';
$g_smtp_connection_mode = 'tls';
$g_smtp_port = 587;

$g_administrator_email = 'administrator@corporation.com';
$g_webmaster_email = 'webmaster@corporation.com';
$g_from_email = 'from@corporation.com';
$g_return_path_email = 'returnpath@corporation.com';

$g_allow_blank_email = ON;
$g_enable_email_notification = ON;
$g_validate_email = OFF;

$g_status_enum_string = '10:new,20:feedback,30:acknowledged,40:confirmed,50:assigned,60:testing,70:tested,80:resolved,90:closed';
$g_status_colors['testing'] = '#4876FF';
$g_status_colors['tested'] = '#FFA500';
$g_status_colors['new'] = '#FFFF00';
$g_status_colors['resolved'] = '#00CD66';
$g_status_colors['acknowledged'] = '#E8E8E8';
$g_default_language= 'portuguese_brazil';

$g_log_level = LOG_EMAIL;
$g_log_destination = 'file:c:/temp/mantisbt.log';
?>

Re: Please read this if you have problems with emails

Posted: Jun 19, 2012 3:28 am
by nantha84
It still confusing me.

We need to edit in which file:

config_defaults_inc.php or config_inc.php

and for " extension=php_openssl.dll"

php.ini-production or php.ini

Re: Please read this if you have problems with emails

Posted: Jul 17, 2012 9:28 pm
by lavanya
I too have the same problem.. the testmail.php worked correctly for me. But still i couldn login inside mantis1.2.11. It shows "Your account may be disabled or blocked or the username/password you entered is incorrect.". I didn receive mail to my inbox also. I tried to create a new account, account created in database. I didn receive email to inbox and i couldn login also inside mantis..

Re: Please read this if you have problems with emails

Posted: Oct 23, 2012 10:03 am
by Liana
Hello,

I'm having problems with email sending... I'm using mantis 1.2.11 wampserver 2.1 (apache 2.2.17 php 5.3.5)
I'm having this configuration in config_defauls_inc.php:

$g_phpMailer_method = PHPMAILER_METHOD_SMTP;
$g_smtp_host = 'smtp.gmail.com';
$g_smtp_username = 'mantis@gmail.com';
$g_smtp_password = 'XXX';
$g_administrator_email = 'mantis@gmail.com';
$g_webmaster_email = 'mantis@gmail.com';
$g_from_email = 'mantis@gmail.com';
$g_return_path_email = 'mantis@gmail.com';
$g_smtp_connection_mode = 'tls';
$g_smtp_port = 587;
$g_email_set_category = ON;
$g_allow_blank_email = ON;
$g_enable_email_notification = ON;
$g_validate_email = OFF;

On the file php.ini I have the statement ;extension=php_openssl.dll e I enabled the extension in PHP EXTENSION but I didn't find the extension in Apache module... I had enabled and not enabled the extension in Apache module when I was doing tests, but now I can't see the extension anymore. Even then, I enabled in PHP the extension php_openssl but It isn't working yet.
Does someone can help me with my configuration??

Re: Please read this if you have problems with emails

Posted: Nov 26, 2012 1:33 am
by pwf
I used SimpleScripts to make a new installation of Mantis into one of my domains, hosted at on-rev.com. I have several domains hosted there. Mantis will send email notifications only to addresses within one of my domains. I cannot get it to send email to addresses in other domains not hosted at on-rev.com. Any suggestions?

Re: Please read this if you have problems with emails

Posted: Nov 26, 2012 10:56 am
by pwf
Forgot to mention the version: 1.2.11
I do not have the option of restarting Apache.

Re: Please read this if you have problems with emails

Posted: Dec 13, 2012 10:08 am
by Smophie
Hello,

I have followed all of the instructions listed in this thread but have yet been unable to receive emails.

In test_email.php I get: (And not very verbose either!)

Testing Mail - PROBLEMS SENDING MAIL TO: XXXX@gmail.com. Please check your php/mail server settings.

I can see in my McAfee log that something is happening on smtp.gmail.com:587 but that's about it.

I'm using IIS 5.1 if that helps

Kind Regards