Workflow issue with new mantis install

Get help from other users here.

Moderators: Developer, Contributor

Post Reply
istvanb
Posts: 226
Joined: Aug 22, 2010 4:00 pm

Workflow issue with new mantis install

Post by istvanb » Feb 14, 2012 9:13 am

Hi,

I have a fresh installation of mantis 1.2.8 (xampp is new as well and no issues have been created in the system yet). I have tried to change the workflow as the code shows below (custom_inc.php), but for some reasons the resolved status shows up as @70@. (see the attached picture)

Also as you see new is still followed by acknowledged. I have checked the sql database and found this:

a:5:{i:10;s:45:"30:acknowledged,50:assigned,70:@70@,90:closed";
i:30;s:36:"10:new,50:assigned,70:@70@,90:closed";
i:50;s:40:"10:new,30:acknowledged,70:@70@,90:closed";
i:70;s:44:"10:new,30:acknowledged,50:assigned,90:closed";
i:90;s:42:"10:new,30:acknowledged,50:assigned,70:@70@";}

It looks for some reasons the sql database has not been updated properly.

what could be the reason for this, and how can I resolve it?

thx,
istvan

Code: Select all

	$g_status_enum_string			=  '10:new,
										30:assigned,
										50:inwork,
										70:resolved,
										90:closed';

	$s_status_enum_string			=  '10:new,
										30:assigned,
										50:in work,
										70:resolved,
										90:closed';
										

	$g_status_colors		= array( 'new'			=> '#fcbdbd', // red    (scarlet red #ef2929)
									 'assigned'		=> '#e3b7eb', // purple (plum        #75507b)
									 'inwork'	=> '#ffcd85', // orange (orango      #f57900)
									 'resolved'	=> '#fff494', // yellow (butter      #fce94f)
									 'closed'		=> '#c2dfff'); // blue   (sky blue    #729fcf)
Attachments
workflow.gif
workflow.gif (30.99 KiB) Viewed 1632 times

istvanb
Posts: 226
Joined: Aug 22, 2010 4:00 pm

Re: Workflow issue with new mantis install

Post by istvanb » Feb 14, 2012 11:42 am

The $s_status_strings_enum must be in the custom_strings_inc.php and then it will work. I think this topic can be closed now.

Post Reply