SMTP Config for Google Apps

Get help from other users here.

Moderators: Developer, Contributor

Post Reply
namtab
Posts: 2
Joined: May 24, 2012 5:11 am

SMTP Config for Google Apps

Post by namtab » May 24, 2012 5:29 am

Hi,

I've been having problems with configuring SMTP with a Google Apps account.

I read carefully everything in the http://www.mantisbt.org/forums/viewtopi ... =3&t=15398 "Please read this if you have problems with emails" topic.


I've tried all configurations, but mail fails to arrive.
In all cases, test_email.php yields:
Testing Mail - PROBLEMS SENDING MAIL TO: user@custom-gapps-domain.com. Please check your php/mail server settings.


My config:
Hosted Linux, PHP Version 5.2.6-1, SSL and TLS Stream Socket Transports available, Mantis 1.2.4

Code: Select all

# --- Email Configuration ---
$g_phpMailer_method		= PHPMAILER_METHOD_SMTP;
$g_smtp_host			= 'ssl://smtp.gmail.com:465';
$g_smtp_connection_mode 	= 'ssl';
$g_smtp_username		= 'user@custom-gapps-domain.com';
$g_smtp_password		= 'password';
$g_administrator_email  	= 'user@custom-gapps-domain.com;
$g_webmaster_email      	= 'otheruser@custom-gapps-domain.com';
$g_from_name			= 'FROM NAME';
$g_from_email           	= 'user@custom-gapps-domain.com';
$g_return_path_email    	= 'user@custom-gapps-domain.com';
$g_email_send_using_cronjob 	= OFF;
Also tried with

Code: Select all

$g_smtp_host			= 'smtp.gmail.com';
$g_smtp_port			= 465;
$g_smtp_connection_mode 	= 'ssl';
and

Code: Select all

$g_smtp_host			= 'smtp.gmail.com';
$g_smtp_port			= 587;
$g_smtp_connection_mode 	= 'tls';

I eventually also tried with a regular (personal) GMail account, same results..

I'm a bit desperate as I am under a 1 week countdown to the switchoff of the old SMTP hosted functionality.

I could also use a hand with enabling some sort of logging or even on-page flushing of what's happening under the hood...

As you may have already concluded, I do not have a solid experience with PHP, so please be patient.

I can provide any other required info, if able or assisted.

Thank you in advance.

istvanb
Posts: 226
Joined: Aug 22, 2010 4:00 pm

Re: SMTP Config for Google Apps

Post by istvanb » Jun 13, 2012 6:41 am

I hope you could resolve your problem, if so please let us know.

If you still struggle with it then turn off every system security for a minute and try to send a mail then to see if it works. Also I recommend to install mantis on your personal computer probably with less security restrictions and check the solution from the original topic. Please stick with a regular gmail account.

Good luck,
i-

namtab
Posts: 2
Joined: May 24, 2012 5:11 am

Re: SMTP Config for Google Apps

Post by namtab » Jun 14, 2012 2:10 am

Hi Istvan,

it turns out the problem was my hosting environment blocking ports TLS 587 and SSL 465 outgoing, so no resolution to that... other than finding a better hoster :wink: ..

Thank you for your reply :!:

Post Reply