Mantis SVN source control integration

Get help from other users here.

Moderators: Developer, Contributor

Post Reply
milos
Posts: 2
Joined: Mar 23, 2017 12:52 pm

Mantis SVN source control integration

Post by milos » Mar 23, 2017 1:05 pm

Import process fails. I tried googling but any mentions on thi topic are 6-7 years old. I think I probably know what is the problem, I do not know how to fix it.
Plugin is installed,repository info is configured correctly, so is path to svn bin and fields. I created repository. Started import process. And it fails. The reason it fails is:

'SimpleXMLElement::__construct(): Entity: line 3: parser error : Premature end of data in tag info line 2' in 'C:\xampp\htdocs\mantis\plugins\SourceSVN\SourceSVN.php' line 275

Which means that in this php code:

Code: Select all

$t_svninfo_xml = shell_exec( "$svn info $t_url --xml" );
  try {
   # create parser
   
   $t_svninfo_parsed_xml = new SimpleXMLElement($t_svninfo_xml);
   
  }
  catch( Exception $e ) {
   # parsing error - no success here
   echo "<pre>svn info returned invalid xml code: {$t_svninfo_xml} </pre>";
   return array();
  }
XML that shell exec returns is not valid XML.
Both Mantis and SVN are installed on the same windows server.
I am open to any suggestions.
Mantis 2.2.1
OS: Win Server 2012

obmsch
Posts: 14
Joined: Mar 26, 2013 5:19 pm

Re: Mantis SVN source control integratio

Post by obmsch » Mar 30, 2017 1:44 pm

Still an issue? If yes, what is the:

SVN client version?
SVN server version?
Output of "svn info url --xml" from cmd? Make sure you use the same svn ($svn, there might be others in the path) and url=$t_url.

Is the xml from (3) Ok? Just to make sure this is a plugin issue and not a problem with svn and/or your configuration. I am quite sure its the latter, no problems on my side with SVN projects and different mantis/plugin versions for years.
Otherwise you should file an issue: https://github.com/mantisbt-plugins/source-integration

Martin

milos
Posts: 2
Joined: Mar 23, 2017 12:52 pm

Re: Mantis SVN source control integration

Post by milos » Mar 31, 2017 11:54 am

Not an issue anymore.
The problem was ssl, i entered path to svn repo as https://192.168.0.x:port, but the certificate was signed as domain name. So $svn info $url returned ssl error, once i changed the path to svn repo in mantis to https://svndomain:port problem was gone. Although both https://192.168.0.x:port and https://svndomain:port point to the same svn repo and it can be accessed through browser using anyone of the two.
It now works as it should.
Mantis 2.2.1
OS: Win Server 2012

Post Reply