Customer Management

Get help from other users here.

Moderators: Developer, Contributor

Post Reply
edelmar
Posts: 6
Joined: Oct 28, 2017 5:52 am

Customer Management

Post by edelmar »

I would like to activate the Customer Management plugin in Mantis 2.1.0, but the following messages appear to me:

Outdated Outbuildings MantisBT Core 1.2.1.
  jQuery 1.4.3
  jQueryUI 1.8.0

How could you solve the problem with outdated dependencies ?.
How can i install jQuery 1.4.3 and jQueryUI 1.8.0?

I am using Customer Management 1.0.0

Thank you very much

atrol
Site Admin
Posts: 7757
Joined: Mar 26, 2008 4:37 pm
Location: Germany

Re: Customer Management

Post by atrol »

It's a known request to use this plugin in newer versions that MantisBT 1.2.x https://github.com/mantisbt-plugins/cus ... t/issues/5

But there is hardly anyone contributing to the plugin since more than four years, so you are quite alone with the issue
https://github.com/mantisbt-plugins/cus ... ntributors
edelmar wrote: How could you solve the problem with outdated dependencies ?.
How can i install jQuery 1.4.3 and jQueryUI 1.8.0?
This is certainly the easiest part of it.
jQuery is part of newer MantisBT versions and jQueryUI is available as a plugin starting with MantisBT 2.2.0 (btw. you should use MantisBT 2.8.0 as 2.1.0 is outdated and contains some major security bugs)
https://github.com/mantisbt-plugins/jQuery-UI
Please use Search before posting and read the Manual

edelmar
Posts: 6
Joined: Oct 28, 2017 5:52 am

Re: Customer Management

Post by edelmar »

I'm sorry to hear that the project is stopped. I think customer management can be very useful in Mantis.

I have updated Mantis 2.8.0 following this tutorial:

http://mantisbt.org/docs/master-1.2.x/e ... grade.html

I have also been able to correctly install the jQueryUI plugin

Thank you so much for help me.

rombert
Posts: 66
Joined: Nov 05, 2009 3:43 am

Re: Customer Management

Post by rombert »

If you do manage to make it work, patches are welcome.

Post Reply