Mantis attempts but never completes SVN Import Everything

Get help from other users here.

Moderators: Contributor, Developer

Post Reply
Posts: 1
Joined: Nov 06, 2017 3:29 pm

Mantis attempts but never completes SVN Import Everything

Post by jayce » Nov 21, 2017 11:34 am


I am having an issue that seemingly no one else on this forum or the rest of the internet is having. So, obviously, I have misconfigured something extremely basic and for the life of me I cannot figure out what it is. Details about my setup:

Mantis 2.6.0, schema version 209
- Source Control Integration 2.1.0
- Source Subversion Integration 2.1.0
- Source Subversion / WebSVN Integration 2.0.1
PHP 5.6.31
Maria DB 5.5.41
Apache 2.4.6
Subversion 1.7.14
CentOS 7.1.1503

I have svnserve listening on the same machine as the web server and mantisbt. Directory under source control is mounted remotely over NFS. Both firewall and SE Linux are off as i troubleshoot this. I am able to use SVN from the command line as normal, both locally as well as remotely. Checkouts, info, blame, commits, etc. work as expected. It is a very small repository and takes on the order of seconds to check it out in its entirety.

I am attempting to use Source Control Integration [1] to integrate our SVN repositories with mantisbt. I create a new repository and select 'Import Everything.' When this happens, I can see from the output of svnserve that it successfully executes the following:

Code: Select all

svn log -v -r 0:HEAD --limit 200 svn://localhost/svn_repo --xml
In the browser, this never seems to complete. The browser simply says 'waiting for <servername>' in the lower left of the status bar. Additionally the entire mantisbt ui becomes unresponsive. I have to restart httpd in order to do anything else with mantis from this browser; accessing from another browser allows me to use the mantis ui but svn import still fails in the same way. Looking at the traffic in wireshark, I can see the HTTP POST from my machine to the server as:

Code: Select all

/<mantis_installation_alias>/plugin.php?page=Source/repo_import_full&id=59 HTTP/1.1
I don't see any other traffic involving this transaction - nothing ever seems to come back to my browser. This is tested on Chrome 45 and 59 as well as Firefox 51, so I do not believe the browser is the issue. I have also tried using WebSVN and am having the exact same problem. I would appreciate any advice you all may have.




Posts: 1
Joined: Feb 04, 2018 4:20 pm

Re: Mantis attempts but never completes SVN Import Everything

Post by beboobailey » Feb 04, 2018 4:22 pm


Did you ever find a solution to this problem? I have the same issues with a very similar setup. I have also tried using file:/// and svn:// (using svnserve) to no avail.


Posts: 5
Joined: Jan 04, 2018 5:41 am

Re: Mantis attempts but never completes SVN Import Everything

Post by Tsjakka » Feb 12, 2018 9:57 am

I'm experiencing the same problem. :cry:

Post Reply