Database connection failed. Error received from database was #0: PHP Support for database is not enabled.

Get help from other users here.

Moderators: Contributor, Developer

Post Reply
sentinel
Posts: 2
Joined: Sep 17, 2018 12:21 am

Database connection failed. Error received from database was #0: PHP Support for database is not enabled.

Post by sentinel » Sep 17, 2018 12:41 am

Hi Guys,

We are having an issue with our MantisBT from this weekend and hoping some one could help. We're not quite sure if there something has changed by the hosting provider (Upgrade of the server or php mysql) but when we try to load the mantis, we get error: Database connection failed. Error received from database was #0: PHP Support for database is not enabled. (screenshot attached)

We tried to modify configuration using the following link

https://www.mantisbt.org/bugs/view.php?id=23466

After changing $g_db_type = 'mysql'; to $g_db_type = 'mysqli'; there is no error message but also the web page is blank with nothing in it.

The version of Mantis we are using is very old: Mantis 125, Database version 183

TIA
Attachments
Mantis_error.PNG
Screenshot for mantis error
Mantis_error.PNG (12.88 KiB) Viewed 670 times

atrol
Site Admin
Posts: 7514
Joined: Mar 26, 2008 4:37 pm
Location: Germany

Re: Database connection failed. Error received from database was #0: PHP Support for database is not enabled.

Post by atrol » Sep 17, 2018 2:26 am

Maybe your provider changed your PHP version to a newer one (>= 7.0).
Maybe there is a setting where you can change it back.

If not, you have to upgrade Mantis, as Mantis 1.2.5 does not support latest PHP versions.
Please use Search before posting and read the Manual

sentinel
Posts: 2
Joined: Sep 17, 2018 12:21 am

Re: Database connection failed. Error received from database was #0: PHP Support for database is not enabled.

Post by sentinel » Sep 21, 2018 12:48 am

Thanks mate for the reply, actually the hosting provided did upgrade to 7.0. We upgraded Mantis to 270 and now it is up again!

Thanks

Post Reply