APPLICATION ERROR #1400 LDAP Authentication Failed.".

Get help from other users here.

Moderators: Contributor, Developer

Post Reply
auguard
Posts: 4
Joined: Oct 30, 2018 9:31 pm

APPLICATION ERROR #1400 LDAP Authentication Failed.".

Post by auguard » Oct 31, 2018 9:16 pm

Hi admin,

Now I want use LDAP Authentication , I have referred similar other posts in mantis forum but didn't work for me, can support Chinese language in the OU option

$g_login_method = LDAP;
$g_ldap_server = 'ldap://cn.net.ntes:389';
$g_ldap_root_dn = 'DC=CN,DC=NET,DC=NTES';
$g_ldap_bind_dn = 'CN=zabbix_service,OU=杭州,OU=功能帐号,DC=cn,DC=net,DC=ntes';
$g_ldap_bind_passwd = '*****';
$g_ldap_realname_field = 'cn';
$g_ldap_protocol_version = 3;
$g_use_ldap_email = ON;
$g_use_ldap_realname = ON;
$g_ldap_organization = '';
$g_ldap_uid_field = 'sAMAccountName';

Mantis Version: 2.18
PHP Version :7.2.11
OS : CentOS 7.1
LDAP/ AD Server : Windows Server 2012 R2

Appreciate your inputs.

Thank you!

auguard
Posts: 4
Joined: Oct 30, 2018 9:31 pm

Re: APPLICATION ERROR #1400 LDAP Authentication Failed.".

Post by auguard » Nov 01, 2018 3:42 am

log:

2018-11-01 07:47 CET LDAP ldap_api.php:327 ldap_authenticate_by_username() Binding to LDAP server
2018-11-01 07:47 CET LDAP ldap_api.php:63 ldap_connect_bind() Attempting connection to LDAP server/URI 'ldap://cn.net.ntes:389'.
2018-11-01 07:47 CET LDAP ldap_api.php:66 ldap_connect_bind() Connection accepted by LDAP server
2018-11-01 07:47 CET LDAP ldap_api.php:79 ldap_connect_bind() Setting LDAP protocol version to 3
2018-11-01 07:47 CET LDAP ldap_api.php:101 ldap_connect_bind() Attempting bind to ldap server with username and password
2018-11-01 07:47 CET LDAP ldap_api.php:114 ldap_connect_bind() Bind to ldap server successful
2018-11-01 07:47 CET LDAP ldap_api.php:335 ldap_authenticate_by_username() Searching for (&(sAMAccountName=administrator))
2018-11-01 07:47 CET LDAP ldap_api.php:46 ldap_log_error() ERROR #1: Operations error
2018-11-01 07:47 CET LDAP ldap_api.php:340 ldap_authenticate_by_username() ldap search failed

leontai
Posts: 1
Joined: Jan 14, 2019 2:21 pm

Re: APPLICATION ERROR #1400 LDAP Authentication Failed.".

Post by leontai » Jan 14, 2019 2:23 pm

Did you fixed the issue? Any solution?

Post Reply