Installation fails with a database on an AWS instance.

Get help from other users here.

Moderators: Developer, Contributor

Post Reply
marin007
Posts: 1
Joined: Jan 17, 2019 1:41 pm

Installation fails with a database on an AWS instance.

Post by marin007 » Jan 17, 2019 2:31 pm

I try to install mantis via admin/install.php on a centos server (amazon host) with an amazon AWS MySQL RDS.
Remote login to MySQL instance from webserver works as user "user" in mysql-client also, "user" seems to have all required privileges.

When starting the database creation, everything works up to:


Checking Installation...
Attempting to connect to database as user: POSSIBLE PROBLEM: Database user doesn't have access to the database ( )

The credentials that I am using work very well in MySQL client as I said.

I tested the instalation localy and it works. But I need to use the amazon instance.

Mantis version :2.18.0

I checked the code.

the error come after:

"
................................................................
<td>
Attempting to connect to database as admin
</td>
<?php
$t_db_open = false;
$g_db = ADONewConnection( $f_db_type );
$t_result = @$g_db->Connect( $f_hostname, $f_admin_username, $f_admin_password );

if( $t_result ) {
# due to a bug in ADODB, this call prompts warnings, hence the @
# the check only works on mysql if the database is open
$t_version_info = @$g_db->ServerInfo();

# check if db exists for the admin
$t_result = @$g_db->Connect( $f_hostname, $f_admin_username, $f_admin_password, $f_database_name );
if( $t_result ) {
$t_db_open = true;
$f_db_exists = true;
}

print_test_result( GOOD );
} else {
print_test_result(
BAD,
true,
'Does administrative UserFirstAttempt have access to the database? ................
......................................................................................

"
I verified the content of variables : $f_hostname, $f_admin_username, $f_admin_password );

The same as I use when connect with MySQL-client.
I put the URL of the database and the ip too. Doesn't help.

Can somebody help me ?

atrol
Site Admin
Posts: 7648
Joined: Mar 26, 2008 4:37 pm
Location: Germany

Re: Installation fails with a database on an AWS instance.

Post by atrol » Jan 17, 2019 3:00 pm

Removing @ from both @$g_db->Connect calls might display some more error details.
Please use Search before posting and read the Manual

Post Reply