How to configure the SMTP host in config_defaults_inc

Get help from other users here.

Moderators: Developer, Contributor

Post Reply
kathirdes25
Posts: 1
Joined: 03 Jun 2008, 12:42

How to configure the SMTP host in config_defaults_inc

Post by kathirdes25 »

Hi Everyone,

I have installed Mantis 1.0.0 in Windows, Everything is working fine, but i am not able to configure the SMTP host, hence i couldn't able to create account using Email. My Email has been configured using microsoft Exchange server.

$g_smtp_host = 'localhost:port';

I gave my exchange server ip address as 172.25.35.20:25, but it says as below

"SYSTEM WARNING: fsockopen(): unable to connect to 172.25.35.20:25

PROBLEMS SENDING MAIL TO: desigan.kathiresan@acs-inc.com
Mailer Error: SMTP Error: Could not connect to SMTP host."

So please help, how to configure SMTP host with using Microsoft Exchange server

Cheers,
Kathiresan
vboctor
Site Admin
Posts: 1292
Joined: 13 Feb 2005, 22:11
Location: Redmond, Washington
Contact:

Re: How to configure the SMTP host in config_defaults_inc

Post by vboctor »

Try connecting manually from the web server to the Exchange server using telnet. I'm suspecting one of two things:

1. The web server can't connect to Exchange server.
2. The Exchange Server is not configured to accept anonymous submissions.

You can also check the Exchange receive protocol logs to see whether a session was established and at one stage it failed.
Migrate your MantisBT to the MantisHub Cloud
tetsunami
Posts: 26
Joined: 21 Apr 2010, 14:45

Re: How to configure the SMTP host in config_defaults_inc

Post by tetsunami »

Actually i have the same problem... i was looking on this forum the way mantis sends mails and it says matis use phpmailer, then i configure for gmail and it works , so then i tried on my exchange server and it fails
so i was thinking the problem was on my server but i test the phpmailer class by itself and it works , so then in thinking about the

$g_smtp_connection_mode = 'tls';

cause its the only diferent paremeter witch its not set on phpmailse basic class
someone knows the correct type _? for exchange server
Post Reply