installation woes

Get help from other users here.

Moderators: Developer, Contributor

Post Reply
dingfelder
Posts: 100
Joined: Aug 14, 2005 5:47 pm
Location: new zealand
Contact:

installation woes

Post by dingfelder »

After installing mantis, I see no output after logging in.

Going to index.php, I see a blank page.

PHP Version 4.4.0
Mysql version 4.1.7
Mantis version 1.0.0rc1

the admin check page shows "good" for everything except File Uploads, which has the following:

File uploads are ENABLED.
File uploads will be stored in the DATABASE.
PHP variable 'upload_max_filesize': 2000000 bytes
PHP variable 'post_max_size': 8000000 bytes
Mantis variable 'max_file_size': 5000000 bytes

Somehow, I got to a login page, and hit signup as a new user...
it sent my user/pass to my email successfully, and the database tables seem fine, as it added the user to the user table. Going to the verify page from the email did allow me to signin and change my password, but after that, I just get a blank page now.

I also see one error on the verify page:
SYSTEM WARNING: Cannot modify header information - headers already sent by (output started at /var/www/html/bugtrack/config_inc.php:11)

dingfelder
Posts: 100
Joined: Aug 14, 2005 5:47 pm
Location: new zealand
Contact:

adding

Post by dingfelder »

I should add, we are using apache 2.x and are running on linux.

thraxisp
Developer
Posts: 509
Joined: Feb 13, 2005 10:38 pm
Location: Ottawa, Canada
Contact:

Post by thraxisp »

Is this a new installation? Has the database been created and initialized through admin/install.php?
--
Glenn Henshaw Logical Outcome Ltd.
Mantis developer and user w: http://www.logicaloutcome.ca

dingfelder
Posts: 100
Joined: Aug 14, 2005 5:47 pm
Location: new zealand
Contact:

new install

Post by dingfelder »

Is this a new installation?
yes this is a new install.
Has the database been created and initialized through admin/install.php?
The DB "appears" to be OK, (as I said above after going through the registration process, it added a user to the user table) but am definately not sure if all the tables are installed or the data is valid.

The tables that exist are:

mantis_bug_file_table
mantis_bug_history_table
mantis_bug_monitor_table
mantis_bug_relationship_table
mantis_bug_table
mantis_bug_text_table
mantis_bugnote_table
mantis_bugnote_text_table
mantis_config_table
mantis_custom_field_project_table
mantis_custom_field_string_table
mantis_custom_field_table
mantis_filters_table
mantis_news_table
mantis_project_category_table
mantis_project_file_table
mantis_project_hierarchy_table
mantis_project_table
mantis_project_user_list_table
mantis_project_version_table
mantis_sponsorship_table
mantis_tokens_table
mantis_user_pref_table
mantis_user_print_pref_table
mantis_user_profile_table
mantis_user_table

the tables are empty except:

mantis_config_table
mantis_user_pref_table
mantis_user_table

thraxisp
Developer
Posts: 509
Joined: Feb 13, 2005 10:38 pm
Location: Ottawa, Canada
Contact:

Post by thraxisp »

That is the way it should be. You are logging in as the 'administrator'?

I missed the error. Do you have extra blank lines at the end of the config_inc.php file?
--
Glenn Henshaw Logical Outcome Ltd.
Mantis developer and user w: http://www.logicaloutcome.ca

dingfelder
Posts: 100
Joined: Aug 14, 2005 5:47 pm
Location: new zealand
Contact:

yes indeed

Post by dingfelder »

you are 100% correct, it was dues to spaces at the end of the file.

Thanks a bunch !

Post Reply